Welcome to the ASDSoft.WebSigner

ASDSoft.WebSigner component provides functionality for signing a content in client browser environment. The component has two parts:

  • Server-side

    The server-side component must be hosted in .NET Framework ASP.NET WebForms or MVC application or in ASP.NET Core application.

  • Client-side

    The client-side component has two parts:

    1. Javascript running in HTML page in the browser for running desktop .NET application a showing status of signing process in the page.

    2. Desktop .NET application with a window for selecting certificate, show signing content a button for signing.

Getting Started

To get started, see the main howto articles below for use component.

  • Add libraries references to server project

  • Implement SignerBase abstract class

  • Implement DocumentSignerBase abstract class

  • Implement SerializedCachePersistorBase abstract class (optional)

  • Register and configure component on startup application

  • Call signing functionality

  • Call login functionality

See Also

Other Resources

Version History


Version History

The topics in this section describe the various changes made to the ASDSoft.WebSigner over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 2.5.0 from 15.11.2023

    Version 2.4.0 from 21.11.2022

  • Version 2.3.0 from 14.3.2022

  • Version 2.2.1 from 29.9.2021

  • Version 2.2.0 from 15.4.2021

  • Version 2.1.0 from 27.10.2020

  • Version 2.0.0 from 10.7.2020

  • Version 1.5.0 from 3.12.2019

  • Version 1.4.0 from 17.4.2019

  • Version 1.3.0 from 24.5.2018

  • Version 1.2.0 from 16.5.2018

  • Version 1.1.0 from 14.3.2018

  • Version 1.0.0 from 19.2.2018

See Also

Other Resources

Welcome to the ASDSoft.WebSigner


Version 2.5.0

Version 2.5.0 was released on 15.11.2023.

Changes in This Release

  • Nové třídy SignerBaseTIdentification a DocumentSignerBaseTIdentification vycházející z původní třídy SignerBase pro jednodušší předávání informací z hostující aplikace o tom, co a jak má být podepsáno a pro jednodušší uložení podpisu do dokumentu pomocí ASDSoft.SignTools komponenty. Více viz programátorská dokumentace.

  • Nový konfigurační element ASDSoft.WebSigner/SigningCategories pro konfiguraci podpisu pomocí konfiguračního souboru místo pevného nastavení v kódu při startu aplikace. Více viz programátorská dokumentace.

  • Povolení přístupu k volání funkcí serveru v anonymním režimu bez aplikačního přihlášení a vyžadování antiforgery tokenu. Důležité pro hostující web aplikace, které mají zapnuto implicitní vyžadování autentizace a antiforgery.

  • Podpora Claims v defaultním IAuthenticationPersistor. Doposud se uchovával pouze název identity, nyní i všechny Claims dané identity.

  • Rozdělení Nuget instalačního balíčku pro server na dva pro možnost referencování jen backendu (ASDSoft.WebSigner.Server.Backend) bez klientských souborů pro stažení ze serveru (ASDSoft.WebSigner.Server).

  • Snížení času pro zobrazení hlášení v podpisové stránce o chybějící klientské aplikaci z 15 sekund na 5 sekund.

  • Okamžitá detekce nainstalované klientské aplikace při spuštění podpisu na starších prohlížečích IE a Edge (ne Edge-Chromium). V těchto případech se hlášení zobrazí ihned, nikoliv až po 5 sekundách.

  • Doplněna podpora pro Edge/Chrome 95.0+ v režimu šetření energie, kdy docházelo k přerušení podepisovací session po delší době nečinnosti v prohlížeči (uspání záložky).

  • Doplněna podpora .NET 7+ pro monitorovací API /ASDWebSigner/SignatureContext/Monitor. V předchozí verzi 2.4.0 nebylo toto API na .NET 7+ funkční.

  • Doplněno zalamování dlouhého názvu souboru s certifikátem na více řádků v okně pro zadání hesla k privátnímu klíči. Doposud byl dlouhý název oříznut na velikost okna (nebyl vidět celý).

  • Doplněna WebSigner ikona v titulku dialogových oken klientské aplikace v prostředí Linux a Mac OSX.

  • ýznamné zrychlení startu podepisovací klientské aplikace v prostředí Linux a Mac OSX.

  • [Client runtime] Klientská aplikace v prostředí Linux a Mac OSX nově vyžaduje minimální Web Signer runtime 2.1.0+ (z 27.10.2020 a novější).

  • Podpora nejnovějších Android a iOS verzí, na kterých předchozí verze aplikace končily chybou při zobrazování hlášení.

  • Optimalizace spuštění aplikace na iOS.

  • Oprava chyby, kdy na .NET Core / .NET při uložení podepsaného obsahu (volána metoda SignerBase.ProcessSigning) došlo v případě podpisu pouze jedné položky ke ztrátě HttpContext po prvním volání await v implementaci uložení. To samé platí i pro .NET Framework, tam to ale doposud vyřešeno není a nastává nejen při podpisu jedné položky, ale i při hromadném podpisu.

  • Oprava chyby, kdy došlo k pádu při startu .NET Core / .NET hostující aplikace v případě, kdy chyběl ASDWebSigner/Client adresář pro stažení klientských instalačních souborů.

  • Oprava chyby v klientské aplikaci v prostředí Mac OSX, kdy po zadání chybného hesla k certifikátu a stisknutí Enter v hlášení o chybném hesle, byl v opětovně zobrazeném okně v položce pro zadání hesla před vyplněn znak, místo prázdné položky.

  • Oprava chyby v klientské aplikaci v prostředí Linux, kdy jednotlivá okna nebyla zobrazována na středu obrazovky, ale v různých náhodných polohách u kraje obrazovky.

  • Oprava chyby v klientské aplikaci v prostředí Linux, kdy docházelo k samovolnému posouvání hlavního okna po zobrazení a zavření jiného dialogového okna.

  • Oprava chyby v klientské aplikaci v prostředí Linux, kdy někdy náhodně po zobrazení hlavního okna toto okno nebylo vidět celé (velikost okna se nepřizpůsobila obsahu okna).

  • Oprava chyby v ochraně podpisu biometrií na mobilní platformě Android a iOS, kdy při vícenásobném zadání otisku došlo k zablokování biometrie.

  • Oprava výkonnostní chyby při spuštění na iOS, kdy v některých případech došlo k opakované dvojnásobné inicializaci a tím delšímu startu aplikace.

See Also

Other Resources

Version History


Version 2.4.0

Version 2.4.0 was released on 21.11.2022.

Changes in This Release

  • Doplněna kompletní podpora podpisu pomocí certifikátu s klíči typu ECDSA (eliptické křivky). Doposud byly podporovány pouze RSA klíče. Zatím nelze importovat ECDSA z PEM souborů na platformách Windows a iOS (zde zůstává pro import ECDSA pouze PFX/p12 formát).

  • Doplněna autodetekce HW bezpečnostních zařízeních (HW Token) TokenMe a ProID od PostSignum na Mac OSX a Linux.

  • Doplněna podpora MacOS 13. Předchozí verze WebSigner nemusely v tomto prostředí fungovat ve všem korektně.

  • [Client runtime] Doplněna podpora novějších verzí Linux (například Ubuntu 22.x), kde klientská aplikace nešla spustit.

  • Na Windows doplněna podpora SW kryptografických poskytovatelů (CSP), které mají privátní klíč uložen mimo klientský počítač (obdobné chování jako u HW poskytovatelů - HW token).

  • Změněna logika klientské aplikace při použití funkce Storno při zadávání hesla pro přístupu k privátnímu klíči či HW Tokenu. Doposud byl v takovém případě podpis ukončen bez provedeného podpisu. Nově je uživatel vrácen do hlavního okna pro podpis a může zvolit jiný certifikát, případně podpis opakovat s původně vybraným certifikátem.

  • Při hromadném podpisu více dokumentů byl doplněn informační pruh o průběhu podepisování (grafické procentuální vyjádření dokončení podepisování).

  • Při hromadném podpisu byla při ukládání podpisů do výsledných dokumentů ve stránce ve web prohlížeči k informativnímu textu „Ukládám vytvořené podpisy...“ doplněna i textová informace o průběhu ukládání procentuálním vyjádřením.

  • Urychlení hromadných podpisů díky paralelnímu provádění přípravy dokumentů pro podpis na straně serveru a vlastním podepisováním na straně klienta. Zrychlení se projeví především v případě, kdy je podepisováno pomocí HW Tokenu, který je obecně pomalý (postupné podepisování se spustí hned po přípravě prvního dokumentu, tedy že se nečeká až budou připraveny všechny dokumenty).

  • Doplněna podpora dvou-fázové autentizace při použití HW Tokenu na Mac OSX a Linux (PIN k tokenu + PIN k privátnímu klíči).

  • Doplněna podpora pro Safari na Mac OSX v režimu šetření energie, kdy docházelo k přerušení podepisovací session po cca 1 minutě od spuštění.

  • Přidána monitorovací URL /ASDWebSigner/SignatureContext/Monitor pro sledování dostupnosti a stavu podepisovací komponenty z dohledových monitorovacích systémů.

  • Optimalizace výkonu získávání informací o odvolání certifikátů pro dlouhodobé ověřování platnosti podpisu LTV v případě hromadných podpisů. Nově je ověření prováděno pouze jednou pro všechny podpisy dohromady, původně bylo prováděno opakovaně pro každý podpis. Při podpisu řádově stovek dokumentů může zabránit blokaci ze strany certifikačních autorit z důvodu podezření na DDoS útok.

  • Optimalizace čtení OCSP statusu odvolání certifikátu pro LTV režim (dlouhodobé ověření podpisu) a publikace případných chyb. Nově není možno podepsat s nastavením Ades=LtvOcsp, pokud není OCSP server CA dostupný nebo vrátí chybu.

  • Doplnění jména organizace případně identifikace organizace (atribut OID.2.5.4.97) do zobrazovaného názvu certifikátu ve výběrovém seznamu certifikátů pro podpis, pokud jsou v certifikátu uvedeny a jsou odlišné od základního názvu certifikátu.

  • Doplněna detekce a podpora prohlížeče Opera Touch na mobilní platformě.

  • Ošetření stavu na Mac OSX a Linux, kdy je na počítači nainstalováno více PKCS11 poskytovatelů, přičemž při jejich vyhledávání a načítání certifikátu dojde k chybě Pkcs11Exception: Method C_GetTokenInfo returned CKR_GENERAL_ERROR, a to v případě, kdy poskytovatel, který není určen pro aktuálně vložený Token se jej pokusí načíst, následně dojde k pádu aplikace a není možno použít žádný certifikát. Bylo provedeno i dodatečné ošetření pro případ, že by došlo k jakémukoliv dalšími problému s načítáním dat z tokenu. V takovém případě nebude dostupný pouze Token/Certifikát, u kterého došlo k problému, ale aplikace nespadne a je možno použít jiný dostupný Token/Certifikát.

  • Zajištění správné hodnoty v HttpContext.Session v dlouho trvajícím vlákně pro uložení podpisu pro případné následné použití v implementaci SignerBase v prostředí .NET Core/NET na straně serveru v případě, že hostující aplikace používá Session. Doposud tato property nabývala jiné hodnoty, než odpovídala Session z prohlížeče. V případě .NET Framework prostředí vše fungovalo správně i dříve.

  • Ošetření nepodporovaných algoritmů podepisovacích klíčů certifikátů. V případě nepodporovaného algoritmu je certifikát označen v seznamu červeně s popisem důvodu, přičemž v takovém případě jej nelze použít pro podpis. Před verzi 2.4.0 byl podporován pouze algoritmus RSA. Od verze 2.4.0 je podporován i algoritmus ECDSA.

  • Ošetření stavu na Android, kdy uživatel neudělil/odebral oprávnění pro přístup aplikace k souborům. V takovém případě aplikace bez varování spadla (byla ukončena). Nyní je zobrazen systémový dialog pro povolení oprávnění.

  • Úprava podpora režimu uspávání prohlížečů na mobilní platformě v novějších verzích Android a iOS, pokud se během podpisu nachází v pozadí. Na nových OS vedlo k předčasnému ukončení podepisovací session.

  • Úprava instalačního skriptu klientské aplikace pro Linux, tak aby byl funkční i při použití Web Proxy s autentizací.

  • Oprava chyby na Mac OSX a Linux, kdy po kliku na + tlačítko pro zobrazení dialogu pro přidání/odebrání certifikátů je dialog zobrazen za hlavním oknem v případě kliku ještě před načtením podepisovaného obsahu.

  • Oprava chyby na mobilních platformách Android a iOS, kdy uživatel neměl nastaveno na zařízení ověření pomocí otisku prstu, ale měl nastaveno ověření pomocí rozpoznání obličeje. V takovém případě aplikace umožnila nekorektně nastavit ochranu použití privátních klíčů pomocí biometrie (otisk prstu), čímž došlo k zablokování aplikace a bylo ji nutno odinstalovat a znovu nainstalovat.

  • Oprava chyby, kdy v případě, že se po úspěšném ověření kvalifikovaného certifikátu v EU TSL nepodařilo stáhnou vydávající certifikát CA, byl takový certifikát neadekvátně neakceptován pro podpis. Nyní lze takový certifikát použít a je zalogován problém se stažením certifikátu CA. Problém nenastával v případě, kdy byla celá cesta certifikátů CA nainstalována v lokálním úložišti CA v OS.

  • Oprava chyby na Mac OSX a Linux, kdy mohla být některá dialogová okna a upozorňující hlášení zobrazena za předchozím aktivním oknem a tím nebyla vidět.

  • Oprava vizuální chyby na Mac OSX a Linux, kdy po rozbalení seznamu certifikátů a následném přesunu polohy hlavního okna zůstal seznam certifikátů zobrazen mimo hlavní okno na původní poloze.

  • Oprava chyby v prostředí Mac OSX, kdy mohlo dojít k pádu aplikace při kliku na tlačítko + pro přidání certifikátů ještě před tím, než byl načten podepisovaný obsah.

  • Oprava bezpečnostní chyby CWE-601: URL Redirection to Untrusted Site ('Open Redirect'), viz. https://www.security-database.com/cwe.php?name=CWE-601

  • Oprava bezpečnostní chyby CWE-524: Information Exposure Through Caching, viz. https://www.security-database.com/cwe.php?name=CWE-524

  • Oprava drobných nedostatků v logování a trasování pro lepší zjišťování problémových stavů.

  • Změna úrovně logování požadavků na neexistující session z úrovně Information na úroveň Warning.

  • [Breaking change] Ukončení podpory .NET 4.5 na straně serveru. Nyní je vyžadován minimálně .NET Framework 4.6.1+ nebo .NET Core 3.1 nebo .NET 5.0+.

  • [Breaking change] Zjednodušení metody AddAsdWebSignerWithSignTools na .NET Core a .NET platformě, odebrán již zbytečný parametr configuration.

  • [Client runtime] doplnění verze Client Runtime do informativního výpisu/logu při startu klienta.

  • Ošetření chyby System.NotSupportedException: The certificate key algorithm is not supported při deserializaci seznamu certifikátu poslaných z klienta na server v případě, kdy byl v seznamu nějaký certifikát z ECDSA algoritmem (eliptické křivky). V takovém případě nešlo následně podepsat žádným certifikátem, tedy ani se standardním RSA algoritmem.

  • Pokud byl nakonfigurována implementace IAuthenticationPersistor, tak v případě, kdy byl HtpContect.Curent.User null, tak nebyla volána metoda IAuthenticationPersistor.RestoreUser a tím byl kód pro předání podpisu vyvolaný z WebSignera prováděn v anonymním kontextu bez přihlášení uživatele.

  • Pokud byla nakonfigurována implementace IAuthenticationPersistor, tak byla opravena chyba v .NET Framework prostředí, kdy nebyl při volání uložení výsledku podpisů nastaven (obnoven) HttpContext.Current.User na původní autentizovanou hodnotu. V prostředí .NET Core toto fungovalo správně.

See Also

Other Resources

Version History


Version 2.3.0

Version 2.3.0 was released on 14.3.2022.

Changes in This Release

  • Kompletně přepracován přístup k privátním klíčům certifikátů. Privátní klíč se nově neověřuje už při plnění seznamu dostupných certifikátů, ale až při spuštění akce podpisu pro jeden zvolený certifikát. Hlavním důvodem je zamezení zobrazování předčasných hlášek pro vložení karty s certifikátem již při otvírání okna pro podpis (zobrazení seznamu dostupných certifikátů). Což nastávalo v případech některých HW Tokenu a jejich specifických konfigurací v situaci, kdy není karta s certifikátem vložena. Druhotným efektem je zrychlení načtení seznamu dostupných certifikátů, zvláště v případě použití HW Tokenu.

  • Přidán nový typ podepisovaného obsahu FileContent. Umožňuje podepsat hash jakéhokoliv souboru s možností zobrazení podepisovaného souboru jako link na dokument.

  • V případě chybných přihlašovacích údajů k Web Proxy, která vyžaduje přihlášení, je nově zobrazen v dialogu pro přihlášení upozorňující text a je před-vyplněno posledně zadané přihlašovací jméno.

  • Podpora importu certifikátů na Android a iOS i z PEM souborů, doposud byl podporován pouze PFX/p12 formát.

  • Úprava hlášení při importu certifikátů z PXF/p12 na Andorid a iOS tak, aby bylo zřejmé, že nemusí být jen chybně zadané heslo, ale i soubor s chybným formátem či poškozený soubor.

  • Zakázána změna velikosti okna na Mac OSX a Linux (sjednoceno s chováním pod Windows).

  • [Obsolete] Nově lze CreateSessionRequest vytvářet nejen na základě předaných hodnot identifikace category/identification, ale také formou JavaScript výrazů pro naplnění hodnot na straně klienta z JS. Ve třídě CreateSessionRequest byly vytvořeny dvě nové statické metody CreateForJsExpression a CreateForValue, přičemž původní konstruktor této třídy byl označen jako Obsolete, v budoucích verzích může být označen jako private.

  • Přidány dvě nové přetížení metody SignerBase.CreateSignatureSession s předáním kolekce IContentBuilder, typicky pro předání instancí DocumentSignerLinkContent místo SignatureRequest. Byly vytvořeny pro potřeby použití hash algorimu definovaného v konfiguraci podpisu, místo konstanty v kódu v konstruktoru SignatureRequest (viz oprava chyby při použití DocumentSignerLinkContent níže).

  • Úprava zpracování odpovědi ze služby EU TSL pro podporu nového formátu zprávy. Bez této úpravy nemusí dojít k ověření nově vydávaných kvalifikovaných certifikátů.

  • Podpora specifikace jazyka v URL nápovědy help?lang=cs-CZ a podpůrného klientského Java Scriptu javascript?lang=cs-CZ pro případy, kdy jazyk není specifikován v hostující web aplikaci formou ASP.NET cookie, typicky pro potřeby API volané z jiných než .NET aplikací.

  • Ošetření interní chyby OS úložiště certifikátů Windows CSP a Mac OSX Keychain, kdy při poškozeném certifikátu či privátního klíče v úložišti došlo k pádu klientské aplikace, například na CryptographicException: ASN1 corrupted data. Nyní aplikace pracuje dál, nejsou ale nabídnuty certifikáty z problémového OS úložiště. Problém je zalogován do souborového chybového logu na klientovi.

  • Oprava chyby při použití DocumentSignerLinkContent, kdy bez nastavení konfigurace byl vždy použit pro podpis default hash algoritmus SHA256, bez ohledu na to, co bylo předáno do konstruktoru SignatureRequest v parametru hashAlgorithm.

  • Oprava chyby na Mac OSX, kdy po otevření dialogu, například pro zadání hesla, nešlo psát od položky, kde byl umístěn kurzor, bylo nutno kliknout myší kamkoliv do plochy dialogu.

  • Zmenšení pomocných informací u popisu certifikátu (vydavatel, platnost) z důvodu zdůraznění názvu certifikátu.

  • Opraveno vertikální ořezání textu s popisem zvoleného certifikátu pro podpis na Linux.

  • Oprava chyby, kdy text s popisem důvodu, proč daný certifikát nelze použít, byl u některých položek zobrazen v jiném, než aktuálně zvoleném jazyce.

  • [Client runtime] Oprava nefunkční automatické aktualizace klienta v případě, kdy z předchozích používání zůstal na klientovi nekompletní či nefunkční/poškozený stav aplikace dané verze.

  • Doplněno logování chyby při ověření kvalifikovaného certifikátu na službě EuTsl.

See Also

Other Resources

Version History


Version 2.2.1

Version 2.2.1 was released on 29.9.2021.

Changes in This Release

  • Zabezpečení citlivých údajů v dočasně ukládané session na serveru, například podepisovaných dokumentů, pomocí šifrování. Jedná se o ochranu proti čtení těchto informací uživateli, kteří mají přístup k serveru, případně čtení těchto informací ze záloh serverů.

  • Dočasné ukládání výsledků validace kvalifikovaných certifikátů z EuTsl v souborovém úložišti pro rychlejší ověření prvního certifikátu od dané CA po restartu web aplikace.

  • Optimalizace práce s velkými dokumenty nebo s velkým počtem dokumentů pro podepsání s využitím streamování na straně serveru. Výsledkem je pro tyto případy zrychlení procesu podepisování, menší nároky na paměť RAM a možnost podpisu extrémně velkých dokumentů, pro které nebylo možno alokovat dostatek paměti RAM.

  • Změna online ověření kvalifikovaného certifikátu vůči EU TSL službě na nové rozhraní esignature.ec.europa.eu. Původní rozhraní nebude od října 2021 dostupné a tím ověření kvalifikovaných certifikátů ve verzi 2.0.0 až 2.2.0 nefunkční! Pro verzi 2.2.0 byl vydán patch 1 knihovny ASDSoft.WebSigner.Server ve verzi 2.2.0.1.

  • Zajištění hodnoty v HttpContext.ApplicationInstance v dlouho trvajícím vlákně pro uložení podpisu pro případné následné použití v implementaci SignerBase. Doposud tato property nabývala hodnoty null.

  • Zrušení knihovny ASDSoft.WebSigner.Server.SignTools a její integrace přímo do knihovny ASDSoft.WebSigner.Server. Pro využití zjednodušeného podpisu dokumentů (PDF, XML, CMS, …) je vyžadována komponenta ASDSoft.SignTools 3.0.1+.

  • [Breaking change] Ukončení podpory .NET Core 2.0 a 3.0 na straně serveru. Dále je podporován jen .NET 4.5+, .NET Core 3.1+ a .NET 5.0+.

  • [Breaking change] Nahrazení metody SignerBase.GetIdentityName implementací prostřednictvím interface IAuthenticationPersistor zavedeného ve verzi 2.2.0, kde byla metoda SignerBase.GetIdentityName označena jako Obsolete.

  • [Breaking change] Nahrazení metody SignerBase.Login implementací prostřednictvím interface ICertificateAuthenticationProvider zavedeného ve verzi 2.2.0, kde byla metoda SignerBase.Login označena jako Obsolete.

  • Oprava chyby vzniklé ve verzi 2.2.0 způsobující nefunkčnost při použití MemoryCachePersistor v konfiguraci startup komponenty. Chyba se projevila ukončením podepisování po stisku na tlačítko "Podepsat" bez vytvoření podpisu. Při default nastavení, tedy použití FileCachePersistor se chyba neprojevila.

  • Oprava chyby v .NET Core prostředí na straně serveru, kdy texty zobrazované v češtině v prohlížeči (status průběhu procesu podpisu) mohly mít chybně kódovanou diakritiku.

  • Oprava chyby v .NET Framework prostředí na straně serveru, kdy při použití await v implementaci SignerBase v hostující aplikaci mohlo dojít ke ztrátě HttpContext a tím k pádu aplikace na NullReferenceException, pokud byl HttpContext k něčemu následně po await využíván.

  • Oprava chyby v .NET Framework prostředí na straně serveru, kdy za specifických okolností mohlo dojít při prvním použití komponenty po startu hostující web aplikace k jejímu pádu. Řešením pak bylo pouze restart celé aplikace. Výjmečně se projevovalo v MS Azure prostředí.

  • Zápis vzniklých chyb na straně serveru do .NET TraceSource s názvem ASDSoft.WebSigner s úrovní Error.

  • Doplněno podrobnější logování informací o důvodu případné neplatnosti licence.

See Also

Other Resources

Version History


Version 2.2.0

Version 2.2.0 was released on 15.4.2021.

Changes in This Release

  • Doplněna podpora klientského prostředí iOS.

  • Podpora .NET 5.0+ v hostující web aplikaci.

  • Doplnění libICASecureStorePkcs11.dylib pro čtečky od I.CA do automatického vyhledání PKCS11 modulů na Mac OSX platformě.

  • Vylepšené zachytávání a popis chyb při podpisu (vylepšená diagnostika případných problémů).

  • Podpora režimu uspávání prohlížečů na mobilní platformě, pokud se během podpisu nachází v pozadí.

  • Kompletní přepracování způsobu synchronizace komunikace mezi prohlížečem a klientskou aplikací přes server. Primární důvod je podpora uspávání prohlížečů na mobilních platformách, sekundární efekt je pak snížení latence při komunikaci klientské aplikace se serverem (není nutno čekat na synchronizaci).

  • [Client runtime] podpora spuštění novější verze klienta, než kterou vyžaduje server, pokud ji má uživatel nainstalovánu a je kompatibilní s verzí požadovanou serverem.

  • [Obsolete] Nahrazení metody SignerBase.GetIdentityName novou implementací prostřednictvím nového interface IAuthenticationPersistor. Implementaci možno ovlivnit v konfiguraci startup aplikace nebo nenastavovat a využít default implementaci.

  • [Obsolete] Metoda SignerBase.Login nahrazena samostatnou implementací ICertificateAuthenticationProvider. Implementaci možno nastavit v konfiguraci startup aplikace, pokud je přihlášení pomocí certifikátu používáno.

  • Ignorování uri schema (http vs. https) při ověřování licence pro případy, kdy je hostující web aplikace za reverzní proxy, která mění schema protokolu.

  • Zobrazení verze klienta v záhlaví hlavního okna desktop klient aplikací.

  • Doplněna podpora PEM certifikátů na Windows prostředí s novějším PBES2 šifrováním pomocí SHA2. Vyžaduje .NET 4.7.2 či vyšší na klientovi. Na ostatních klientských platformách bylo podporováno již dříve.

  • Podpora konfigurace viditelného podpisu v PDF v rámci SignTools komponenty.

  • Použití nejnovější verze SignTools 2.1.0 (nutná licence pro SignTools)

  • Oprava pádu aplikace při zobrazení systémového dialogu pro výběr souboru s certifikátem na některých novějších verzích Linux distribucí (například Arch Linux, jádro 5.11.13).

  • Oprava chyby, kdy po manuálním přidání/odebrání certifikátu se ve výběru seznamu certifikátů původní certifikáty duplikovaly.

  • Oprava chyby, kdy v případě, že již byla spuštěna klientská aplikace pro Android před spuštěním podpisu z prohlížeče, mohlo následně dojít chybě v klientské aplikaci znemožňující podpis.

  • Oprava chyby, kdy klientská aplikace pro Android chybně nabízela k podpisu i certifikáty, kterým byla již ukončena časová platnost.

  • Oprava chyb, uvolňování paměti a optimalizace při paralelním podepisování více dokumentů současně.

  • Oprava chyby, kdy při neúspěšném provedení podpisu zůstala session na serveru dále k dispozici.

  • Oprava chyby, kdy za určitých okolností mohlo dojít k zamrznutí web stránky při případné chybě při zobrazení podepisovaného dokumentu.

  • Ošetření pádu aplikace na chybu NullReferneceException, pokud není nalezen obsah pro podpis při volání z klienta. Nově se zobrazí uživatelská chyba.

  • Ošetření pádu aplikace na chybu NullReferneceException, pokud nebyl na serveru dostupný HttpContext.Current.User.Identity.

  • Drobné interní opravy při použití HW token na Mac OSX a Linux způsobující nefunkčnost ve specifických případech.

See Also

Other Resources

Version History


Version 2.1.0

Version 2.1.0 was released on 27.10.2020.

Changes in This Release

  • Doplněna podpora klientského prostředí Android.

  • [Client runtime] Doplněna podpora novějších verzí Linux (například Ubuntu 20.x), kde klientská aplikace nešla spustit.

  • [Client runtime] Doplněna podpora Mac OSX 10.15 Catalina a novější z důvodu vyžadování notarizace aplikace ze strany společnosti Apple.

  • Ověření kvalifikovaných certifikátů přes EU TSL. Pro tyto certifikáty již tedy nemusí být certifikáty jejich vydávajících CA nainstalovány v důvěryhodných CA na serveru.

  • [Breaking change] Metoda SignerBase.ValidateCertificateQualified byla v souvislosti s kontrolou certifikátů přes EU TSL nahrazena metodou ValidateQualifiedCertificate s jinou signaturou a jiným významem, viz. programátorská dokumentace.

  • [Breaking change] zrušeny obsolete metody z verze 2.0.0, viz bod „Nově je preferováno spuštění podepisování pomocí JS CallBack místo PostBack celé stránky na server….“ z předchozí verze 2.0.0. Z toho důvodu byla také protected metoda SignerBase.CreateSignatureSession změněna z virtual na abstract a public metody SignerBase.CreateSignatureSession na protected.

  • Zamezení zamrznutí okna klientské aplikace při hromadném podpisu pomocí HW Token.

  • Rozpad hlášení v indikátoru činnosti klientské aplikace při provádění podpisu na tři fáze (příprava dokumentů, podepisování, odeslání podpisů na server) pro lepší orientaci, co aplikace při delších časech provádění vlastně dělá.

  • Oprava chyby, kdy v případě, kdy jeden z nakonfigurovaných certifikátů ze souboru nebyl v danou chvíli dostupný nebo byl poškozený, tak došlo k pádu aplikace na chybu NullReferenceException. Chyba ohledně neošetření tohoto stavu vznikla ve verzi 2.0.0.

  • Ošetřen stav, kdy ve specifických verzí serverového prostředí docházelo k nestandardní serializaci dat zasílaných ze serveru na klienta, díky čemuž na klientovi docházelo k chybě ArgumentNullException.

  • Oprava chyby, kdy v případě, že na serveru nebyla nastavena konkrétní CultureInfo (byla nastavena např. InvariantCulture), tak klientská aplikace při spuštění skončila chybou ArgumentNullException. Nově je v takovém případě klientské aplikaci nastavena culture "en-US" (angličtina).

  • Opravena chyba, kdy při zadávání hesla k pfx nebo HW tokenu při použití numerické klávesnice místo zadaných číslic klávesnice prováděla posun kurzoru, jakoby numerická klávesnice byla vypnutá, přestože nebyla. Problém se týkal některých prostředí Linux a Mac OSX.

  • Opravena chyba, kdy docházelo k pádu klientské aplikace při dvou-faktorová autentizace na HW Token v prostředí Mac OSX.

  • [Client runtime] Opravena chyba, kdy instalace klienta na Mac OSX se tvářila ve vlastnostech aplikace stále jako verze 1.0.0.

  • [Client runtime] Změna názvu MSI instalace pro Windows z "ASD Web Signer Client" na "ASD WebSigner Client Runtime".

  • .NET Framework: Global.asax nezachytává chyby z ApiController. Proto do StartupSettings doplněna property ApiControllerExceptionCallback pro možnost registrace callback metody vyvolané při chybě na straně serveru. Jedná se pouze o doplnění možností odchycení chyby z WebSigner k obecnému řešení na úrovni GlobalConfiguration.Configuration.Filters s implementací ExceptionFilterAttribute. .Net Core: žádná změna, lze řešit standardní cestou ve starup pro odchycení chyb.

See Also

Other Resources

Version History


Version 2.0.0

Version 2.0.0 was released on 10.7.2020.

Changes in This Release

  • Napojení na novou komponentu ASDSoft.WebSigner.SignTools pro podporu jednoduššího podepisování dokumentů jako PDF, XML, DOCX, XLSX, atd.. V této souvislosti vznikl nový Content typu DocumentSignerLinkContent, kterému se pouze podhodí binární podoba daného dokumentu a nastavení vlastností podpisu. Po dokončení podpisu se z něj vezme podepsaný dokument. Není tedy nutno řešit přípravu podepisovaného dokumentu ani vkládání podpisu do dokumentu. Komponenta je distribuována jako samostatná serverová komponenta s vlastní licenční politikou.

  • Breaking change: Více-vláknové (paralelní) příprava a zpracování podpisu pro významné zrychlení při podepisování většího počtu dokumentů v rámci jednoho požadavku (hromadný podpis). Příprava dokumentu a vložení podpisu dokumentu musí podporovat více-vláknové zpracování. Z tohoto důvodu v případě použití ASDSoft.PdfSigner je nutno přejít na novější verzi ASDSoft.SignTools.Pdf, která tento paralelismus podporuje. Toto není potřeba, pokud je podepisována pouze jedna položka.

  • Pokud operace podepsání trvá déle jak 200 ms, tak je v klientské aplikaci zobrazen animovaný indikátor prováděné činnosti.

  • Upraveno a optimalizováno spuštění klientské aplikace z web stránky. Nově není vyžadováno povolení iframe elementu.

  • Nově je preferováno spuštění podepisování pomocí JS CallBack místo PostBack celé stránky na server. Na straně serveru je místo původní obsolete metody RegisterSigningStartupScript nově vhodné použít RegisterStartSignatureOnClick nebo RegisterStartSignatureMethod. Pokud si hostující aplikace provádí spuštění sama přímo z Javascript, tak místo původních obsolete JS metod initializeAsdWebSigner a initializeAsdWebSigner2 je nově vhodné použít JS metody startSignatureInProcess nebo startLoginInProcess. V této souvislosti je pak nutno v potomkovi třídy SignerBase naimplementovat (override) metodu CreateSignatureSession, respektive do ní přesunout již naprogramovanou logiku vytvoření obsahu pro podpis. Více viz programátorská dokumentace. Obsolete metody budou v příští verzi zrušeny.

  • Breaking change: Obsolete JS metoda initializeAsdWebSigner2 má na druhé pozici vložen nový parametr statusInfoElementId: string. Týká se pouze při inicializaci podpisu z klienta v JS. Pokud se používají serverové metody, tak je tato změna irelevantní.

  • Windows: doplněna podpora nových CSP poskytovatelů. Certifikáty nainstalovány v těchto nových CSP budou nově k dispozici pro podpis. Původně se tyto certifikáty vůbec nenabízely. Pro tuto funkčnost je nutné mít nainstalován .NET Framework 4.6 nebo vyšší. Běžně stačí verze 4.5, která je součástí Windows 10. V rámci této úpravy je nově dostupná ve Windows mimo jiné i Slovenská eObčanka.

  • Max OSX: možnost přidávat nové HW bezpečnostní zařízení (HW Token) i z knihoven typu *.so. Doposud bylo možno přidávat pouze knihovny typu *.dylib.

  • Mac OSX a Linux: doplněna autodetekce HW bezpečnostních zařízeních (HW Token) založených na OpenSC (onepin-opensc-pkcs11.so).

  • Mac OSX a Linux: doplněna autodetekce HW bezpečnostních zařízeních (HW Token) pro eObčanka ČR (libeopproxyp11.dylib a libeopproxy11.so).

  • Breaking change: Distribuce je nově chráněna licenčním souborem, který je vázán na jednu či více URL aplikace. V případě vývojového prostředí (doména localhost) je ochrana vypnuta a licenční soubor není vyžadován.

  • Přidána podpora více „logických aplikací“ v rámci jedné hostující web aplikace. Připraveno pro budoucí WebApi a jiné situace, kdy v rámci jednoho procesu je hostován WebSigner pro více aplikací.

  • Podpora zobrazení hlavního okna klientské aplikace při chybných vstupních parametrech, například když je aplikace spuštěna přímo, a ne ze stránky. V okně je zobrazena informace o chybném spuštění. Doposud takové spuštění skončilo „tichou chybou“ a z pohledu uživatele se nic nestalo, jako by aplikaci nespustil, což bylo zmatečné.

  • Nově lze v klientské aplikaci spravovat certifikáty i v případě, kdy aplikace není připojena k serveru, ať již z důvodu chyby při komunikaci se serverem, nebo když je aplikace spuštěna bez potřebných parametrů.

  • Oprava stavu, kdy při delším seznamu podepisovaného obsahu s posuvnou lištou bylo oříznuto (schováno) zápatí klientského okna.

  • Oprava ClusterFileCacheSynchronizer, kdy druhý spuštěný souběžný podpis vedl k zamrznutí druhého podpisu při ConnectToSession a po 15 sekundách byl proces ukončen. Bylo distribuováno privátně už jako server patch 1 pro verzi 1.5.0.

  • Oprava v souvislosti s ClusterFileCacheSynchronizer, kdy se díky jeho pomalosti někdy projevilo při Storno v desktop aplikaci falešné hlášení v prohlížeči "Podepisování bylo přerušeno z web aplikace. Podpis nebyl vytvořen.".

  • Pro knihovnu Server přidána distribuce pro .NET Core 3.0. Nově v .NET Core 3.0 není nutno nastavovat AllowSynchronousIO=true.

  • Oprava default cesty pro FileCachePersistor, která byla nefunkční na Linux serveru.

  • Opraveny drobné chyby, které znemožňovali provoz serverové části na Linux/Apache platformě.

  • Upravena (změněna) ikona pro klientskou aplikaci.

  • Změna barvy chybových hlášení v klientské aplikaci z Red na #C00000 pro zajištění lepší čitelnosti.

See Also

Other Resources

Version History


Version 1.5.0

Version 1.5.0 was released on 3.12.2019.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Version 1.4.0

Version 1.4.0 was released on 17.4.2019.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Version 1.3.0

Version 1.3.0 was released on 24.5.2018.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Version 1.2.0

Version 1.2.0 was released on 16.5.2018.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Version 1.1.0

Version 1.1.0 was released on 14.3.2018.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Version 1.0.0

Version 1.0.0 was released on 19.2.2018.

Changes in This Release

  • The content will be added...

See Also

Other Resources

Version History


Add libraries references to server project

In your ASP.NET or ASP.NET Core web application add references and content by one of this possible distributions.

Variant A - NuGet package ASDSoft.WebSigner.Server

It is recomended variant. Use ASDSoft.WebSigner.Server.[version].nupkg file from distribution. Package not distributed by public NuGet server, you must use own local NuGet package source in Visual Studio - menu Tools / NuGet Package Manager / Package Manager Settings / Package Sources.

Variant B - Direct link to assembly ASDSoft.WebSigner.Server.dll and its dependencies

It is alternative variant. Use ASDSoft.WebSigner.Server.[version].zip file from distribution. In ZIP file are two folders:

  • ASDWebSigner
    In root of your web application (project) create folder ASDWebSigner and copy content of distributed folder to it. This folder contains packages for downloading and installing component to client computer.

  • bin
    Select platform specific folder according by your application (for example net45) and copy all DLLs to your project folder where you have all referenced external assemblies. In your web application (project) add reference to ASDSoft.WebSigner.dll and ASDSoft.WebSigner.Server.dll assemblies.

See Also

Other Resources

Welcome to the ASDSoft.WebSigner


Implement SignerBase abstract class

Host Web application must provide own implementation of base class SignerBase. You must create own class inherited from SignerBase and implement or override its methods. Recommended implementation is as async/await.

To sign documents (PDF, XML, DOCX, ...) by the ASDSoft.SignTools library, it is recommended to use DocumentSignerBaseTIdentification as the base class.

Implement abstract methods

  • CreateSignatureSession(CreateSessionRequest)

    This method called by component infrastructure (callback) when invoked any method based on StartSignatureInProcess. Main method for implementation creating signature session by app request.

  • ProcessSigning(X509Certificate2, SignatureInfo)

    This method called by component infrastructure (callback) when signature by the client is created. In this method, you can save signature to your required file, such as PDF, XML, etc...

  • GetDocument(IDocumentLinkContent)

    This method called by component infrastructure (callback) when the user clicks in client window for showing or downloading the signing document in the browser. In this method, you can return the binary content of the required signing document.

  • GetContent(ContentBase, X509Certificate2)

    This method called by component infrastructure (callback) when the user select certificate for signing before signing is creating. In this method, you can return the binary content of signing data or hash.

Override virtual methods (optional)

  • ConfigureX509ChainForValidation(X509Chain, X509Certificate2, SignatureRequest)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can override default implementation of configuration certificate chain validation.

  • ValidateCertificateExtended(X509Certificate2, SignatureRequest, String)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can add your specific custom filtering of accepted certificates.

  • ValidateQualifiedCertificate(X509Certificate2, EuTslStatusInfo, SignatureRequest, String)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can add your specific custom filtering of accepted qualified certificates.

  • OnProcessSigningEnd(String, X509Certificate2, SignatureInfo)

    This method called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). Default implementation is empty.

See Also

Other Resources

Implement DocumentSignerBase abstract class
Welcome to the ASDSoft.WebSigner


Implement DocumentSignerBase abstract class

Host Web application must provide own implementation of base class DocumentSignerBaseTIdentification. You must create own class inherited from DocumentSignerBaseTIdentification and implement or override its methods. Recommended implementation is as async/await.

This is the recommended implementation for document signing using the ASDSoft.SignTools component. For other types of signature, it is necessary to use the base class SignerBase.

Implement abstract methods

  • DeserializeDocumentIdentifications(TIdentification)

    This method called by component infrastructure (callback) when invoked any method based on StartSignatureInProcess. Main method for implementation creating signature session by app request.

  • ProcessSigning(X509Certificate2, SignatureInfo)

    This method called by component infrastructure (callback) when signature by the client is created and stored in document. In this method, you can save signed document do application store.

  • GetDocument(IDocumentLinkContent)

    This method called by component infrastructure (callback) when the user clicks in client window for showing or downloading the signing document in the browser. In this method, you can return the binary content of the required signing document.

Override virtual methods (optional)

  • CreateContentBuilderConfiguration(String, IDocumentSignerConfiguration)

    This method called by component infrastructure (callback) when invoked any method based on StartSignatureInProcess. In this method, you can override default implementation.

  • ConfigureX509ChainForValidation(X509Chain, X509Certificate2, SignatureRequest)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can override default implementation of configuration certificate chain validation.

  • ValidateCertificateExtended(X509Certificate2, SignatureRequest, String)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can add your specific custom filtering of accepted certificates.

  • ValidateQualifiedCertificate(X509Certificate2, EuTslStatusInfo, SignatureRequest, String)

    This method called by component infrastructure (callback) when a client application sends to server list of available client certificates for its filtering to only accepted certificates. In this method, you can add your specific custom filtering of accepted qualified certificates.

  • OnProcessSigningEnd(String, X509Certificate2, SignatureInfo)

    This method called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). Default implementation is empty.

See Also

Other Resources

Welcome to the ASDSoft.WebSigner


Implement SerializedCachePersistorBase abstract class (optional)

The content will be added...

See Also

Other Resources

Welcome to the ASDSoft.WebSigner


Register and configure component on startup application

In your web application startup you must register and configure ASDSoft.WebSigner component.

.NET Framework ASP.NET WebForms or MVC host application

Main two steps for initialization of the component

  1. Configure component

    For configuration component you can create instance of StartupSettings and set a properties.

  2. Register component

    For registration component you can call static method InitializeStatic(StartupSettings) with configuration parameter.

Example
Configure and register component in Global.asax. MySigner is host application implementation of SignerBase, see Implement SignerBase abstract class.
C#
Copy
protected void Application_Start(object sender, EventArgs e)
{
  WebSigner.Server.AspNet.Startup.InitializeStatic(
  new WebSigner.Server.AspNet.StartupSettings("[My app friendly name]", new MySigner())
  {
    CachePersistor = null,
    CertificateAuthenticationProvider = null,
    AuthenticationPersistor = null,
    GlobalConfigurationCallback = null,
    HelpCssUrl = null,
    LogoBitmap = null
  });
}
ASP.NET Core host application
Example
Register and configure component in standard .NET Core Startup.
C#
Copy
public void ConfigureServices(IServiceCollection services)
{
  services
    .AddMvc()
    .AddAsdWebSigner<MySigner>();
}

public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
{
    app.UseStaticFiles();
    app.UseRouting();

    app.UseAsdWebSigner(new StartupSettings("[My app friendly name]", null)
    {
        CachePersistor = null,
        CertificateAuthenticationProvider = null,
        AuthenticationPersistor = null,
        HelpCssUrl = null
    });

    app.UseEndpoints(endpoints =>
    {
        endpoints.MapControllers();
    });
}
See Also

Other Resources

Implement SignerBase abstract class
Welcome to the ASDSoft.WebSigner


Call signing functionality

In host web application on server side you must add code for starting signing process.

.NET Framework ASP.NET WebForms or MVC host application

Steps for start signing process.

  1. Ensure implementation of CreateSignatureSession(CreateSessionRequest)

  2. Check if client browser and OS is supported. If not, disable signing functionality and show user message.

  3. Register javascript to onclick event on Button by method RegisterStartSignatureOnClick(Button, CreateSessionRequest, String, String, String) for starting signing on client.

    or

    Register javascript method by method RegisterStartSignatureMethod(ClientScriptManager, String, CreateSessionRequest, String, String, String) for starting signing on client.

Example
WebForms page for signing list of PDF documents named "doc" on click to signButton in page.
C#
Copy
public partial class SignPdfPage : System.Web.UI.Page
{
  protected async void Page_Load(object sender, EventArgs e)
  {
    pdfGridView.DataSource = await _repository.GetDocumentsAsync();
    pdfGridView.DataBind();

    if (BrowserInfo.Current.IsClientSupported == false)
    {
      this.signButton.Enabled = false;
      this.signingStatus.Text = BrowserInfo.Current.UnsupportedHtml;
      this.signingStatus.ForeColor = Color.Red;
    }
    else
    {
      CreateSessionRequest createSessionRequest = new CreateSessionRequest("doc", "my documents ids");
      this.signButton.RegisterStartSignatureOnClick(createSessionRequest, this.signingStatus.ClientID);
    }
  }
}
ASP.NET Core host application

The content will be added...

See Also

Other Resources

Register and configure component on startup application
Welcome to the ASDSoft.WebSigner


Call login functionality

The content will be added...

See Also

Other Resources

Welcome to the ASDSoft.WebSigner


ASDSoft.SignTools Namespace

The basis for shared document signing functionality across all document types
Classes
 | Class | Description
Public class | DocumentFileExtensions | Podporované typy dokumentů pro podpis
Public class | DocumentSignerBase | Základní třída pro elektronický podpis dokumentů
Public class | DocumentSignerBaseTConfiguration | Základní generická třída pro podpis dokumentů
Public class | DocumentSignerProvider | Základní provider pro poskytování instancí tříd pro podpis dokumentů
Public class | SigningScope | Podepisovací rámec pro hromadný podpis z více instancí implementujících IDocumentSigner
Interfaces
 | Interface | Description
Public interface | IDocumentSigner | Obecné rozhraní pro implementaci podpisu dokumentů
Public interface | IDocumentSignerTConfiguration | Obecné rozhraní pro implementaci podpisu dokumentů s typovou konfigurací
Public interface | IDocumentSignerConfiguration | Rozhraní pro konfiguraci podpisu
Public interface | ILocalDocumentSigner | Rozhraní pro lokální podpis (privátní klíč je dostupný)
Public interface | IRemoteDocumentSigner | Rozhraní pro externí podpis
Enumerations
 | Enumeration | Description
Public enumeration | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES


AdesLevel Enumeration

Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public enum AdesLevel
Members
Member name | Value | Description
None | 0 | Není použít žádný formát dle ETSI (původní jednoduchý podpis bez požadavků eIDAS)
Base | 1 | Použita úroveň Basic B-B (bez časového razítka) nebo B-T (s časovým razítkem)
LtvOcsp | 2 | Použita úroveň Long-Therm B-LT
See Also

Reference

ASDSoft.SignTools Namespace


DocumentFileExtensions Class

Podporované typy dokumentů pro podpis
Inheritance Hierarchy
SystemObject
ASDSoft.SignToolsDocumentFileExtensions

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public static class DocumentFileExtensions

The DocumentFileExtensions type exposes the following members.

Methods
Name | Description
GetMimeType | Získání mime-type pro koncovku souboru s dokumentem
Top
Fields
Name | Description
DOCX | DOCX
P7S | P7S
PDF | PDF
XLSX | XLSX
XML | XML
Top
See Also

Reference

ASDSoft.SignTools Namespace


DocumentFileExtensions Methods

The DocumentFileExtensions type exposes the following members.

Methods
Name | Description
GetMimeType | Získání mime-type pro koncovku souboru s dokumentem
Top
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.GetMimeType Method

ASDSoft.WebSigner API Reference Documentation

DocumentFileExtensionsGetMimeType Method

Získání mime-type pro koncovku souboru s dokumentem

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public static string GetMimeType(
    string fileExtension
)

Parameters

fileExtension
Type: SystemString
Koncovka souboru s dokumentem

Return Value

Type: String
mime-type
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions Fields

The DocumentFileExtensions type exposes the following members.

Fields
Name | Description
DOCX | DOCX
P7S | P7S
PDF | PDF
XLSX | XLSX
XML | XML
Top
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.DOCX Field

DocumentFileExtensionsDOCX Field

DOCX

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string DOCX = "docx"

Field Value

Type: String
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.P7S Field

DocumentFileExtensionsP7S Field

P7S

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string P7S = "p7s"

Field Value

Type: String
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.PDF Field

DocumentFileExtensionsPDF Field

PDF

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string PDF = "pdf"

Field Value

Type: String
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.XLSX Field

DocumentFileExtensionsXLSX Field

XLSX

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string XLSX = "xlsx"

Field Value

Type: String
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentFileExtensions.XML Field

DocumentFileExtensionsXML Field

XML

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string XML = "xml"

Field Value

Type: String
See Also

Reference

DocumentFileExtensions Class
ASDSoft.SignTools Namespace


DocumentSignerBase Class

Základní třída pro elektronický podpis dokumentů
Inheritance Hierarchy
SystemObject
ASDSoft.SignToolsDocumentSignerBase
ASDSoft.SignToolsDocumentSignerBaseTConfiguration

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public abstract class DocumentSignerBase : IDocumentSigner,
    ILocalDocumentSigner, IRemoteDocumentSigner, IDocumentSignerConfiguration

The DocumentSignerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentSignerBase | Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).
Protected method | DocumentSignerBase(IPersonalCertificate) | Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).
Protected method | DocumentSignerBase(X509Certificate2) | Konstruktor pro vložení elektronického podpisu.
Top
Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES
Protected property | PrivateKey | Privátní klíč pro podpis získaný z certifikátu předaného v konstruktoru
Protected property | PublicCertificate | Veřejná část podepisovacího certifikátu předávaní konstruktorem
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo
Top
Methods
 | Name | Description
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalTimestamper | Nastavení externí implementace získávající vlastní časové razítko
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Protected method | VerifyCertificate | Ověří, že byl předán podepisující certifikát pro podpis včetně privátního klíče v konstruktoru
Protected method | VerifyNotNullCertificate | Ověří, že byla předána alepsoň veřejná část podepisujícího certifikátu
Top
Fields
 | Name | Description
Protected field | _externalTimestamper | Pouze pro interní použití
Top
See Also

Reference

ASDSoft.SignTools Namespace


DocumentSignerBase Constructor

Overload List
 | Name | Description
Protected method | DocumentSignerBase | Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).
Protected method | DocumentSignerBase(IPersonalCertificate) | Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).
Protected method | DocumentSignerBase(X509Certificate2) | Konstruktor pro vložení elektronického podpisu.
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase Constructor

Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase()
Remarks
Tento konstruktor lze použít pouze ve spojení s metodami PrepareForExternalSign(Byte, Byte) bez použití PAdES/XAdES/CAdES podpisu.
See Also

Reference

DocumentSignerBase Class
DocumentSignerBase Overload
ASDSoft.SignTools Namespace


DocumentSignerBase Constructor (IPersonalCertificate)

Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase(
    IPersonalCertificate personalCertificate
)

Parameters

personalCertificate
Type: IPersonalCertificate
Informace o veřejné části certifikátu i privátním klíči.
See Also

Reference

DocumentSignerBase Class
DocumentSignerBase Overload
ASDSoft.SignTools Namespace


DocumentSignerBase Constructor (X509Certificate2)

Konstruktor pro vložení elektronického podpisu.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase(
    X509Certificate2 certificate
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Podepisovací certifikát.
Remarks
V případě přímého podpisu musí být certifikát svázán s dostupným privátním klíčem, následně je možné použít metody Sign(Byte). V případě opožděného podpisu (externího podpisu) stačí předat holý certifikát bez privátního klíče, následně je možné použít metody PrepareForExternalSign(Byte, Byte) a SetExternalSign(Byte, Byte).
See Also

Reference

DocumentSignerBase Class
DocumentSignerBase Overload
ASDSoft.SignTools Namespace


DocumentSignerBase Properties

The DocumentSignerBase type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES
Protected property | PrivateKey | Privátní klíč pro podpis získaný z certifikátu předaného v konstruktoru
Protected property | PublicCertificate | Veřejná část podepisovacího certifikátu předávaní konstruktorem
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.AdesLevel Property

DocumentSignerBaseAdesLevel Property

Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public AdesLevel AdesLevel { get; set; }

Property Value

Type: AdesLevel

Implements

IDocumentSignerConfigurationAdesLevel
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.PrivateKey Property

DocumentSignerBasePrivateKey Property

Privátní klíč pro podpis získaný z certifikátu předaného v konstruktoru

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected AsymmetricAlgorithm PrivateKey { get; }

Property Value

Type: AsymmetricAlgorithm
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.PublicCertificate Property

DocumentSignerBasePublicCertificate Property

Veřejná část podepisovacího certifikátu předávaní konstruktorem

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected X509Certificate2 PublicCertificate { get; }

Property Value

Type: X509Certificate2
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.SignatureHashAlgorithm Property

DocumentSignerBaseSignatureHashAlgorithm Property

Specifikace hash algoritmu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public HashOid SignatureHashAlgorithm { get; set; }

Property Value

Type: HashOid

Implements

IDocumentSignerConfigurationSignatureHashAlgorithm
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.TSAInfo Property

DocumentSignerBaseTSAInfo Property

Definice TSA, která má být použita pro vystavení časového razítka

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public GenericTSAInfo TSAInfo { get; set; }

Property Value

Type: GenericTSAInfo

Implements

IDocumentSignerConfigurationTSAInfo
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.UseTimeStamp Property

DocumentSignerBaseUseTimeStamp Property

Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public bool UseTimeStamp { get; set; }

Property Value

Type: Boolean

Implements

IDocumentSignerConfigurationUseTimeStamp
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase Methods

The DocumentSignerBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalTimestamper | Nastavení externí implementace získávající vlastní časové razítko
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Protected method | VerifyCertificate | Ověří, že byl předán podepisující certifikát pro podpis včetně privátního klíče v konstruktoru
Protected method | VerifyNotNullCertificate | Ověří, že byla předána alepsoň veřejná část podepisujícího certifikátu
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.CreateExternalSign Method

DocumentSignerBaseCreateExternalSign Method

Podepíše hash připraveného dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] CreateExternalSign(
    byte[] hashValue
)

Parameters

hashValue
Type: SystemByte
Hash dokumentu připraveného pro podpis

Return Value

Type: Byte
Vytvořený podpis

Implements

ILocalDocumentSignerCreateExternalSign(Byte)
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.PrepareForExternalSign Method

DocumentSignerBasePrepareForExternalSign Method

Overload List
 | Name | Description
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.PrepareForExternalSign Method (Byte[], Byte[])

DocumentSignerBasePrepareForExternalSign Method (Byte, Byte)

Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] PrepareForExternalSign(
    byte[] documentSourceData,
    out byte[] hashValue
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba dokumentu, který má být podepsán
hashValue
Type: SystemByte
Vypočtený hash podepisovaného dokumentu

Return Value

Type: Byte
Binární podoba připraveného dokumentu pro podpis

Implements

IRemoteDocumentSignerPrepareForExternalSign(Byte, Byte)
See Also

Reference

DocumentSignerBase Class
PrepareForExternalSign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.PrepareForExternalSign Method (Stream, Stream, Byte[])

DocumentSignerBasePrepareForExternalSign Method (Stream, Stream, Byte)

Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public abstract void PrepareForExternalSign(
    Stream documentSourceStream,
    Stream documentOutputStream,
    out byte[] hashValue
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu, který má být podepsán
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba připraveného dokumentu pro podpis
hashValue
Type: SystemByte
Vypočtený hash podepisovaného dokumentu

Implements

IRemoteDocumentSignerPrepareForExternalSign(Stream, Stream, Byte)
See Also

Reference

DocumentSignerBase Class
PrepareForExternalSign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.SetExternalSign Method

DocumentSignerBaseSetExternalSign Method

Overload List
 | Name | Description
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.SetExternalSign Method (Byte[], Byte[])

DocumentSignerBaseSetExternalSign Method (Byte, Byte)

Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] SetExternalSign(
    byte[] documentSourceData,
    byte[] signature
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba připraveného dokumentu pro podpis
signature
Type: SystemByte
Externě vytvořený podpis

Return Value

Type: Byte
Binární podoba podepsaného dokumentu

Implements

IRemoteDocumentSignerSetExternalSign(Byte, Byte)
See Also

Reference

DocumentSignerBase Class
SetExternalSign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.SetExternalSign Method (Stream, Stream, Byte[])

DocumentSignerBaseSetExternalSign Method (Stream, Stream, Byte)

Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public abstract void SetExternalSign(
    Stream documentSourceStream,
    Stream documentOutputStream,
    byte[] signature
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu připraveného pro podpis
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba podepsaného dokumentu
signature
Type: SystemByte
Externě vytvořený podpis

Implements

IRemoteDocumentSignerSetExternalSign(Stream, Stream, Byte)
See Also

Reference

DocumentSignerBase Class
SetExternalSign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.SetExternalTimestamper Method

DocumentSignerBaseSetExternalTimestamper Method

Nastavení externí implementace získávající vlastní časové razítko

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void SetExternalTimestamper(
    ITimestamper externalTimestamper
)

Parameters

externalTimestamper
Type: ASDSoft.SignTools.TimestampingITimestamper
Externí implementace získání časového razítka
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.Sign Method

DocumentSignerBaseSign Method

Overload List
 | Name | Description
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.Sign Method (Byte[])

DocumentSignerBaseSign Method (Byte)

Vytvoření podpisu a jeho vložení do dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] Sign(
    byte[] documentSourceData
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba dokumentu, který má být podepsán

Return Value

Type: Byte
Binární podoba podepsaného dokumentu

Implements

ILocalDocumentSignerSign(Byte)
See Also

Reference

DocumentSignerBase Class
Sign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.Sign Method (Stream, Stream)

DocumentSignerBaseSign Method (Stream, Stream)

Vytvoření podpisu a jeho vložení do dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public abstract void Sign(
    Stream documentSourceStream,
    Stream documentOutputStream
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu, který má být podepsán
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba podepsaného dokumentu

Implements

ILocalDocumentSignerSign(Stream, Stream)
See Also

Reference

DocumentSignerBase Class
Sign Overload
ASDSoft.SignTools Namespace


DocumentSignerBase.VerifyCertificate Method

DocumentSignerBaseVerifyCertificate Method

Ověří, že byl předán podepisující certifikát pro podpis včetně privátního klíče v konstruktoru

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected void VerifyCertificate()
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase.VerifyNotNullCertificate Method

DocumentSignerBaseVerifyNotNullCertificate Method

Ověří, že byla předána alepsoň veřejná část podepisujícího certifikátu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected void VerifyNotNullCertificate()
Exceptions
Exception | Condition
InvalidOperationException |
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase Fields

The DocumentSignerBase type exposes the following members.

Fields
 | Name | Description
Protected field | _externalTimestamper | Pouze pro interní použití
Top
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase._externalTimestamper Field

DocumentSignerBase_externalTimestamper Field

Pouze pro interní použití

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected ITimestamper _externalTimestamper

Field Value

Type: ITimestamper
See Also

Reference

DocumentSignerBase Class
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Class

DocumentSignerBaseTConfiguration Class

Základní generická třída pro podpis dokumentů
Inheritance Hierarchy
SystemObject
ASDSoft.SignToolsDocumentSignerBase
ASDSoft.SignToolsDocumentSignerBaseTConfiguration

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public abstract class DocumentSignerBase<TConfiguration> : DocumentSignerBase,
    IDocumentSigner<TConfiguration>, IDocumentSigner, ILocalDocumentSigner, IRemoteDocumentSigner,
    IDocumentSignerConfiguration
where TConfiguration : IDocumentSignerConfiguration

Type Parameters

TConfiguration
Typ konfigurační třídy

The DocumentSignerBaseTConfiguration type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentSignerBaseTConfiguration | Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).
Protected method | DocumentSignerBaseTConfiguration(IPersonalCertificate) | Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).
Protected method | DocumentSignerBaseTConfiguration(X509Certificate2) | Konstruktor pro vložení elektronického podpisu.
Protected method | DocumentSignerBaseTConfiguration(String, StoreLocation) | Konstruktor pro vložení elektronického podpisu.
Top
Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES (Inherited from DocumentSignerBase.)
Protected property | PrivateKey | Privátní klíč pro podpis získaný z certifikátu předaného v konstruktoru (Inherited from DocumentSignerBase.)
Protected property | PublicCertificate | Veřejná část podepisovacího certifikátu předávaní konstruktorem (Inherited from DocumentSignerBase.)
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis (Inherited from DocumentSignerBase.)
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka (Inherited from DocumentSignerBase.)
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo (Inherited from DocumentSignerBase.)
Top
Methods
 | Name | Description
Public method | Configure | Nakonfiguruje podpis
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from DocumentSignerBase.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from DocumentSignerBase.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from DocumentSignerBase.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from DocumentSignerBase.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from DocumentSignerBase.)
Public method | SetExternalTimestamper | Nastavení externí implementace získávající vlastní časové razítko (Inherited from DocumentSignerBase.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from DocumentSignerBase.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from DocumentSignerBase.)
Protected method | VerifyCertificate | Ověří, že byl předán podepisující certifikát pro podpis včetně privátního klíče v konstruktoru (Inherited from DocumentSignerBase.)
Protected method | VerifyNotNullCertificate | Ověří, že byla předána alepsoň veřejná část podepisujícího certifikátu (Inherited from DocumentSignerBase.)
Top
Fields
 | Name | Description
Protected field | _externalTimestamper | Pouze pro interní použití (Inherited from DocumentSignerBase.)
Top
See Also

Reference

ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Constructor

DocumentSignerBaseTConfiguration Constructor

Overload List
 | Name | Description
Protected method | DocumentSignerBaseTConfiguration | Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).
Protected method | DocumentSignerBaseTConfiguration(IPersonalCertificate) | Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).
Protected method | DocumentSignerBaseTConfiguration(X509Certificate2) | Konstruktor pro vložení elektronického podpisu.
Protected method | DocumentSignerBaseTConfiguration(String, StoreLocation) | Konstruktor pro vložení elektronického podpisu.
Top
See Also

Reference

DocumentSignerBaseTConfiguration Class
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Constructor

DocumentSignerBaseTConfiguration Constructor

Konstruktor určený pro přípravu dokumentu pro opožděný podpis (externí podpis).

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase()
Remarks
Tento konstruktor lze použít pouze ve spojení s metodami PrepareForExternalSign(Byte, Byte) bez použití PAdES/XAdES/CAdES podpisu.
See Also

Reference

DocumentSignerBaseTConfiguration Class
DocumentSignerBaseTConfiguration Overload
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Constructor (IPersonalCertificate)

DocumentSignerBaseTConfiguration Constructor (IPersonalCertificate)

Konstruktor pro vložení elektronického podpisu pomocí přímého podpisu metodou Sign(Byte).

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase(
    IPersonalCertificate personalCertificate
)

Parameters

personalCertificate
Type: IPersonalCertificate
Informace o veřejné části certifikátu i privátním klíči.
See Also

Reference

DocumentSignerBaseTConfiguration Class
DocumentSignerBaseTConfiguration Overload
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Constructor (X509Certificate2)

DocumentSignerBaseTConfiguration Constructor (X509Certificate2)

Konstruktor pro vložení elektronického podpisu.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase(
    X509Certificate2 certificate
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Podepisovací certifikát.
Remarks
V případě přímého podpisu musí být certifikát svázán s dostupným privátním klíčem, následně je možné použít metody Sign(Byte). V případě opožděného podpisu (externího podpisu) stačí předat holý certifikát bez privátního klíče, následně je možné použít metody PrepareForExternalSign(Byte, Byte) a SetExternalSign(Byte, Byte).
See Also

Reference

DocumentSignerBaseTConfiguration Class
DocumentSignerBaseTConfiguration Overload
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Constructor (String, StoreLocation)

DocumentSignerBaseTConfiguration Constructor (String, StoreLocation)

Konstruktor pro vložení elektronického podpisu.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
protected DocumentSignerBase(
    string certificateHash,
    StoreLocation storeLocation
)

Parameters

certificateHash
Type: SystemString
Miniatura podepisovacího certifikátu.
storeLocation
Type: System.Security.Cryptography.X509CertificatesStoreLocation
Úložiště, kde se podepisovací certifikát nachází.
Remarks
V případě přímého podpisu musí být certifikát svázán s dostupným privátním klíčem, následně je možné použít metody Sign(Byte). V případě opožděného podpisu (externího podpisu) stačí předat holý certifikát bez privátního klíče, následně je možné použít metody PrepareForExternalSign(Byte, Byte) a SetExternalSign(Byte, Byte).
See Also

Reference

DocumentSignerBaseTConfiguration Class
DocumentSignerBaseTConfiguration Overload
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Properties

DocumentSignerBaseTConfiguration Properties

The DocumentSignerBaseTConfiguration generic type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES (Inherited from DocumentSignerBase.)
Protected property | PrivateKey | Privátní klíč pro podpis získaný z certifikátu předaného v konstruktoru (Inherited from DocumentSignerBase.)
Protected property | PublicCertificate | Veřejná část podepisovacího certifikátu předávaní konstruktorem (Inherited from DocumentSignerBase.)
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis (Inherited from DocumentSignerBase.)
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka (Inherited from DocumentSignerBase.)
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo (Inherited from DocumentSignerBase.)
Top
See Also

Reference

DocumentSignerBaseTConfiguration Class
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Methods

DocumentSignerBaseTConfiguration Methods

The DocumentSignerBaseTConfiguration generic type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Nakonfiguruje podpis
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from DocumentSignerBase.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from DocumentSignerBase.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from DocumentSignerBase.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from DocumentSignerBase.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from DocumentSignerBase.)
Public method | SetExternalTimestamper | Nastavení externí implementace získávající vlastní časové razítko (Inherited from DocumentSignerBase.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from DocumentSignerBase.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from DocumentSignerBase.)
Protected method | VerifyCertificate | Ověří, že byl předán podepisující certifikát pro podpis včetně privátního klíče v konstruktoru (Inherited from DocumentSignerBase.)
Protected method | VerifyNotNullCertificate | Ověří, že byla předána alepsoň veřejná část podepisujícího certifikátu (Inherited from DocumentSignerBase.)
Top
See Also

Reference

DocumentSignerBaseTConfiguration Class
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration).Configure Method

DocumentSignerBaseTConfigurationConfigure Method

Nakonfiguruje podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public virtual void Configure(
    TConfiguration configuration
)

Parameters

configuration
Type: TConfiguration
Typová konfigurace podpisu

Implements

IDocumentSignerTConfigurationConfigure(TConfiguration)
See Also

Reference

DocumentSignerBaseTConfiguration Class
ASDSoft.SignTools Namespace


DocumentSignerBase(TConfiguration) Fields

DocumentSignerBaseTConfiguration Fields

The DocumentSignerBaseTConfiguration generic type exposes the following members.

Fields
 | Name | Description
Protected field | _externalTimestamper | Pouze pro interní použití (Inherited from DocumentSignerBase.)
Top
See Also

Reference

DocumentSignerBaseTConfiguration Class
ASDSoft.SignTools Namespace


DocumentSignerProvider Class

Základní provider pro poskytování instancí tříd pro podpis dokumentů
Inheritance Hierarchy
SystemObject
ASDSoft.SignToolsDocumentSignerProvider

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public sealed class DocumentSignerProvider

The DocumentSignerProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateSigner(String, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(String, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, IPersonalCertificate, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | GetDocumentSignerConfiguration | Získá konfiguraci pro podpis z konfiguračního souboru z elemetu ASDSoft.SignTools/documentSigner
Public method | GetLocalSigner(String, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | GetLocalSigner(Type, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Public method | GetLocalSignerTSigner(String, String, ActionTSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Public method | GetValidRegisteredDocumentFilesExtensions | Získá seznam podporovaných (zaregistrovaných) koncovek souborů s dokumenty
Public method | RegisterSigner(String, String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSigner(String, Type) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSignerTSigner(String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Top
Fields
Name | Description
Instance | Singleton instance s poskytovatelem instancí tříd pro podpis dokumentů
Top
See Also

Reference

ASDSoft.SignTools Namespace


DocumentSignerProvider Methods

The DocumentSignerProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateSigner(String, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(String, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, IPersonalCertificate, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | GetDocumentSignerConfiguration | Získá konfiguraci pro podpis z konfiguračního souboru z elemetu ASDSoft.SignTools/documentSigner
Public method | GetLocalSigner(String, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | GetLocalSigner(Type, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Public method | GetLocalSignerTSigner(String, String, ActionTSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Public method | GetValidRegisteredDocumentFilesExtensions | Získá seznam podporovaných (zaregistrovaných) koncovek souborů s dokumenty
Public method | RegisterSigner(String, String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSigner(String, Type) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSignerTSigner(String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Top
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method

DocumentSignerProviderCreateSigner Method

Overload List
 | Name | Description
Public method | CreateSignerTSigner(IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(String, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSignerTSigner(X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(String, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, IPersonalCertificate, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(String, X509Certificate2, String) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | CreateSigner(Type, IPersonalCertificate, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, IPersonalCertificate, String) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, IDocumentSignerConfiguration) | Vytvoří novou instanci třídy daného typu pro podpis
Public method | CreateSigner(Type, X509Certificate2, String) | Vytvoří novou instanci třídy daného typu pro podpis
Top
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (IDocumentSignerConfiguration)

DocumentSignerProviderCreateSignerTSigner Method (IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    IDocumentSignerConfiguration configuration = null
)
where TSigner : IDocumentSigner

Parameters

configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (String)

DocumentSignerProviderCreateSignerTSigner Method (String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    string configurationName = null
)
where TSigner : IDocumentSigner

Parameters

configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (IPersonalCertificate, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSignerTSigner Method (IPersonalCertificate, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    IPersonalCertificate personalCertificate,
    IDocumentSignerConfiguration configuration = null
)
where TSigner : IDocumentSigner

Parameters

personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (IPersonalCertificate, String)

DocumentSignerProviderCreateSignerTSigner Method (IPersonalCertificate, String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    IPersonalCertificate personalCertificate,
    string configurationName = null
)
where TSigner : IDocumentSigner

Parameters

personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (String, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    IDocumentSignerConfiguration configuration = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, String)

DocumentSignerProviderCreateSigner Method (String, String)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    string configurationName = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (Type, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    IDocumentSignerConfiguration configuration = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, String)

DocumentSignerProviderCreateSigner Method (Type, String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    string configurationName = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
configurationName (Optional)
Type: SystemString

[Missing <param name="configurationName"/> documentation for "M:ASDSoft.SignTools.DocumentSignerProvider.CreateSigner(System.Type,System.String)"]

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (X509Certificate2, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSignerTSigner Method (X509Certificate2, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    X509Certificate2 certificate,
    IDocumentSignerConfiguration configuration = null
)
where TSigner : IDocumentSigner

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner(TSigner) Method (X509Certificate2, String)

DocumentSignerProviderCreateSignerTSigner Method (X509Certificate2, String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner<TSigner>(
    X509Certificate2 certificate,
    string configurationName = null
)
where TSigner : IDocumentSigner

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, IPersonalCertificate, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (String, IPersonalCertificate, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    IPersonalCertificate personalCertificate,
    IDocumentSignerConfiguration configuration = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, IPersonalCertificate, String)

DocumentSignerProviderCreateSigner Method (String, IPersonalCertificate, String)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    IPersonalCertificate personalCertificate,
    string configurationName = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, X509Certificate2, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (String, X509Certificate2, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    X509Certificate2 certificate,
    IDocumentSignerConfiguration configuration = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (String, X509Certificate2, String)

DocumentSignerProviderCreateSigner Method (String, X509Certificate2, String)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    string documentFileExtension,
    X509Certificate2 certificate,
    string configurationName = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, IPersonalCertificate, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (Type, IPersonalCertificate, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    IPersonalCertificate personalCertificate,
    IDocumentSignerConfiguration configuration = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, IPersonalCertificate, String)

DocumentSignerProviderCreateSigner Method (Type, IPersonalCertificate, String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    IPersonalCertificate personalCertificate,
    string configurationName = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
personalCertificate
Type: IPersonalCertificate
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, X509Certificate2, IDocumentSignerConfiguration)

DocumentSignerProviderCreateSigner Method (Type, X509Certificate2, IDocumentSignerConfiguration)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    X509Certificate2 certificate,
    IDocumentSignerConfiguration configuration = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configuration (Optional)
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.CreateSigner Method (Type, X509Certificate2, String)

DocumentSignerProviderCreateSigner Method (Type, X509Certificate2, String)

Vytvoří novou instanci třídy daného typu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSigner CreateSigner(
    Type signerType,
    X509Certificate2 certificate,
    string configurationName = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Certifikát pro podpis
configurationName (Optional)
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner

Return Value

Type: IDocumentSigner
Instance třídy pro podpis
See Also

Reference

DocumentSignerProvider Class
CreateSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetDocumentSignerConfiguration Method

DocumentSignerProviderGetDocumentSignerConfiguration Method

Získá konfiguraci pro podpis z konfiguračního souboru z elemetu ASDSoft.SignTools/documentSigner

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IDocumentSignerConfiguration GetDocumentSignerConfiguration(
    string configurationName
)

Parameters

configurationName
Type: SystemString
Název konfigurace v atributu name

Return Value

Type: IDocumentSignerConfiguration
Konfigurace podpisu
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetLocalSigner Method

DocumentSignerProviderGetLocalSigner Method

Overload List
 | Name | Description
Public method | GetLocalSignerTSigner(String, String, ActionTSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Public method | GetLocalSigner(String, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy pro podpis daného typu dokumentu
Public method | GetLocalSigner(Type, String, String, ActionIDocumentSigner) | Vytvoří novou instanci třídy daného typu pro lokální podpis
Top
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetLocalSigner(TSigner) Method (String, String, Action(TSigner))

DocumentSignerProviderGetLocalSignerTSigner Method (String, String, ActionTSigner)

Vytvoří novou instanci třídy daného typu pro lokální podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public ILocalDocumentSigner GetLocalSigner<TSigner>(
    string certificateName,
    string signerName,
    Action<TSigner> advancedConfigureAction = null
)
where TSigner : IDocumentSigner

Parameters

certificateName
Type: SystemString
Název certifikátu pro podpis z konfiguračního souboru z elementu ASDSoft.SignTools/storeCertificate nebo ASDSoft.SignTools/pfxCertificate
signerName
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner
advancedConfigureAction (Optional)
Type: SystemAction TSigner
Doplňkova akce pro konfiguraci podpisu z kódu

Type Parameters

TSigner
Typ podepisující třídy

Return Value

Type: ILocalDocumentSigner

[Missing <returns> documentation for "M:ASDSoft.SignTools.DocumentSignerProvider.GetLocalSigner``1(System.String,System.String,System.Action{``0})"]

See Also

Reference

DocumentSignerProvider Class
GetLocalSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetLocalSigner Method (String, String, String, Action(IDocumentSigner))

DocumentSignerProviderGetLocalSigner Method (String, String, String, ActionIDocumentSigner)

Vytvoří novou instanci třídy pro podpis daného typu dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public ILocalDocumentSigner GetLocalSigner(
    string documentFileExtension,
    string certificateName,
    string signerName,
    Action<IDocumentSigner> advancedConfigureAction = null
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru podepisovaného dokumentu
certificateName
Type: SystemString
Název certifikátu pro podpis z konfiguračního souboru z elementu ASDSoft.SignTools/storeCertificate nebo ASDSoft.SignTools/pfxCertificate
signerName
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner
advancedConfigureAction (Optional)
Type: SystemAction IDocumentSigner
Doplňkova akce pro konfiguraci podpisu z kódu

Return Value

Type: ILocalDocumentSigner

[Missing <returns> documentation for "M:ASDSoft.SignTools.DocumentSignerProvider.GetLocalSigner(System.String,System.String,System.String,System.Action{ASDSoft.SignTools.IDocumentSigner})"]

See Also

Reference

DocumentSignerProvider Class
GetLocalSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetLocalSigner Method (Type, String, String, Action(IDocumentSigner))

DocumentSignerProviderGetLocalSigner Method (Type, String, String, ActionIDocumentSigner)

Vytvoří novou instanci třídy daného typu pro lokální podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public ILocalDocumentSigner GetLocalSigner(
    Type signerType,
    string certificateName,
    string signerName,
    Action<IDocumentSigner> advancedConfigureAction = null
)

Parameters

signerType
Type: SystemType
Typ podepisující třídy
certificateName
Type: SystemString
Název certifikátu pro podpis z konfiguračního souboru z elementu ASDSoft.SignTools/storeCertificate nebo ASDSoft.SignTools/pfxCertificate
signerName
Type: SystemString
Název konfigurace podpisu z konfiguračního souboru z elementu ASDSoft.SignTools/documentSigner
advancedConfigureAction (Optional)
Type: SystemAction IDocumentSigner
Doplňkova akce pro konfiguraci podpisu z kódu

Return Value

Type: ILocalDocumentSigner

[Missing <returns> documentation for "M:ASDSoft.SignTools.DocumentSignerProvider.GetLocalSigner(System.Type,System.String,System.String,System.Action{ASDSoft.SignTools.IDocumentSigner})"]

See Also

Reference

DocumentSignerProvider Class
GetLocalSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.GetValidRegisteredDocumentFilesExtensions Method

DocumentSignerProviderGetValidRegisteredDocumentFilesExtensions Method

Získá seznam podporovaných (zaregistrovaných) koncovek souborů s dokumenty

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IEnumerable<string> GetValidRegisteredDocumentFilesExtensions()

Return Value

Type: IEnumerable String
Seznam podporovaných (zaregistrovaných) koncovek souborů s dokumenty
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.RegisterSigner Method

DocumentSignerProviderRegisterSigner Method

Overload List
 | Name | Description
Public method | RegisterSignerTSigner(String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSigner(String, String) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Public method | RegisterSigner(String, Type) | Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu
Top
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.RegisterSigner(TSigner) Method (String)

DocumentSignerProviderRegisterSignerTSigner Method (String)

Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterSigner<TSigner>(
    string documentFileExtension
)
where TSigner : IDocumentSigner

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru pro nový typ dokumentu

Type Parameters

TSigner
Typ třídy implementují IDocumentSigner
See Also

Reference

DocumentSignerProvider Class
RegisterSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.RegisterSigner Method (String, String)

DocumentSignerProviderRegisterSigner Method (String, String)

Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterSigner(
    string documentFileExtension,
    string documentSignerTypeName
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru pro nový typ dokumentu
documentSignerTypeName
Type: SystemString
Plný název typu třídy implementují IDocumentSigner
See Also

Reference

DocumentSignerProvider Class
RegisterSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider.RegisterSigner Method (String, Type)

DocumentSignerProviderRegisterSigner Method (String, Type)

Zaregistruje typ třídy implementující podepisování pro nový typ dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterSigner(
    string documentFileExtension,
    Type documentSignerType
)

Parameters

documentFileExtension
Type: SystemString
Koncovka souboru pro nový typ dokumentu
documentSignerType
Type: SystemType
Typ třídy implementují IDocumentSigner
See Also

Reference

DocumentSignerProvider Class
RegisterSigner Overload
ASDSoft.SignTools Namespace


DocumentSignerProvider Fields

The DocumentSignerProvider type exposes the following members.

Fields
Name | Description
Instance | Singleton instance s poskytovatelem instancí tříd pro podpis dokumentů
Top
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


DocumentSignerProvider.Instance Field

DocumentSignerProviderInstance Field

Singleton instance s poskytovatelem instancí tříd pro podpis dokumentů

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public static readonly DocumentSignerProvider Instance

Field Value

Type: DocumentSignerProvider
See Also

Reference

DocumentSignerProvider Class
ASDSoft.SignTools Namespace


IDocumentSigner Interface

Obecné rozhraní pro implementaci podpisu dokumentů

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface IDocumentSigner : ILocalDocumentSigner,
    IRemoteDocumentSigner

The IDocumentSigner type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Nakonfiguruje podpis
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from ILocalDocumentSigner.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Top
See Also

Reference

ASDSoft.SignTools Namespace


IDocumentSigner Methods

The IDocumentSigner type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Nakonfiguruje podpis
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from ILocalDocumentSigner.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Top
See Also

Reference

IDocumentSigner Interface
ASDSoft.SignTools Namespace


IDocumentSigner.Configure Method

IDocumentSignerConfigure Method

Nakonfiguruje podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
void Configure(
    IDocumentSignerConfiguration configuration
)

Parameters

configuration
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Konfigurace podpisu
See Also

Reference

IDocumentSigner Interface
ASDSoft.SignTools Namespace


IDocumentSigner(TConfiguration) Interface

IDocumentSignerTConfiguration Interface

Obecné rozhraní pro implementaci podpisu dokumentů s typovou konfigurací

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface IDocumentSigner<in TConfiguration> : IDocumentSigner,
    ILocalDocumentSigner, IRemoteDocumentSigner
where TConfiguration : IDocumentSignerConfiguration

Type Parameters

TConfiguration

The IDocumentSignerTConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Configure(TConfiguration) | Nakonfiguruje podpis
Public method | Configure(IDocumentSignerConfiguration) | Nakonfiguruje podpis (Inherited from IDocumentSigner.)
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from ILocalDocumentSigner.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Top
See Also

Reference

ASDSoft.SignTools Namespace


IDocumentSigner(TConfiguration) Methods

IDocumentSignerTConfiguration Methods

The IDocumentSignerTConfiguration generic type exposes the following members.

Methods
 | Name | Description
Public method | Configure(TConfiguration) | Nakonfiguruje podpis
Public method | Configure(IDocumentSignerConfiguration) | Nakonfiguruje podpis (Inherited from IDocumentSigner.)
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu (Inherited from ILocalDocumentSigner.)
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis. (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte) (Inherited from IRemoteDocumentSigner.)
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu (Inherited from ILocalDocumentSigner.)
Top
See Also

Reference

IDocumentSignerTConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSigner(TConfiguration).Configure Method

IDocumentSignerTConfigurationConfigure Method

Overload List
 | Name | Description
Public method | Configure(TConfiguration) | Nakonfiguruje podpis
Public method | Configure(IDocumentSignerConfiguration) | Nakonfiguruje podpis (Inherited from IDocumentSigner.)
Top
See Also

Reference

IDocumentSignerTConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSigner(TConfiguration).Configure Method (TConfiguration)

IDocumentSignerTConfigurationConfigure Method (TConfiguration)

Nakonfiguruje podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
void Configure(
    TConfiguration configuration
)

Parameters

configuration
Type: TConfiguration
Typová konfigurace podpisu
See Also

Reference

IDocumentSignerTConfiguration Interface
Configure Overload
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration Interface

Rozhraní pro konfiguraci podpisu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface IDocumentSignerConfiguration

The IDocumentSignerConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES
Public property | Name | Unikátní název konfigurační položky
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo
Top
See Also

Reference

ASDSoft.SignTools Namespace


IDocumentSignerConfiguration Properties

The IDocumentSignerConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES
Public property | Name | Unikátní název konfigurační položky
Public property | SignatureHashAlgorithm | Specifikace hash algoritmu pro podpis
Public property | TSAInfo | Definice TSA, která má být použita pro vystavení časového razítka
Public property | UseTimeStamp | Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo
Top
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration.AdesLevel Property

IDocumentSignerConfigurationAdesLevel Property

Definice použití úrovně dle specifikace ETSI dle eIDAS pro formáty CAdES, XAdES, PAdES

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
AdesLevel AdesLevel { get; }

Property Value

Type: AdesLevel
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration.Name Property

IDocumentSignerConfigurationName Property

Unikátní název konfigurační položky

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration.SignatureHashAlgorithm Property

IDocumentSignerConfigurationSignatureHashAlgorithm Property

Specifikace hash algoritmu pro podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
HashOid SignatureHashAlgorithm { get; }

Property Value

Type: HashOid
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration.TSAInfo Property

IDocumentSignerConfigurationTSAInfo Property

Definice TSA, která má být použita pro vystavení časového razítka

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
GenericTSAInfo TSAInfo { get; }

Property Value

Type: GenericTSAInfo
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


IDocumentSignerConfiguration.UseTimeStamp Property

IDocumentSignerConfigurationUseTimeStamp Property

Nastavení, zda má být k podpisu vloženo časové razítko z TSA definované v TSAInfo

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
bool UseTimeStamp { get; }

Property Value

Type: Boolean
See Also

Reference

IDocumentSignerConfiguration Interface
ASDSoft.SignTools Namespace


ILocalDocumentSigner Interface

Rozhraní pro lokální podpis (privátní klíč je dostupný)

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface ILocalDocumentSigner

The ILocalDocumentSigner type exposes the following members.

Methods
 | Name | Description
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Top
See Also

Reference

ASDSoft.SignTools Namespace


ILocalDocumentSigner Methods

The ILocalDocumentSigner type exposes the following members.

Methods
 | Name | Description
Public method | CreateExternalSign | Podepíše hash připraveného dokumentu
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Top
See Also

Reference

ILocalDocumentSigner Interface
ASDSoft.SignTools Namespace


ILocalDocumentSigner.CreateExternalSign Method

ILocalDocumentSignerCreateExternalSign Method

Podepíše hash připraveného dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] CreateExternalSign(
    byte[] hashValue
)

Parameters

hashValue
Type: SystemByte
Hash dokumentu připraveného pro podpis

Return Value

Type: Byte
Vytvořený podpis
See Also

Reference

ILocalDocumentSigner Interface
ASDSoft.SignTools Namespace


ILocalDocumentSigner.Sign Method

ILocalDocumentSignerSign Method

Overload List
 | Name | Description
Public method | Sign(Byte) | Vytvoření podpisu a jeho vložení do dokumentu
Public method | Sign(Stream, Stream) | Vytvoření podpisu a jeho vložení do dokumentu
Top
See Also

Reference

ILocalDocumentSigner Interface
ASDSoft.SignTools Namespace


ILocalDocumentSigner.Sign Method (Byte[])

ILocalDocumentSignerSign Method (Byte)

Vytvoření podpisu a jeho vložení do dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] Sign(
    byte[] documentSourceData
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba dokumentu, který má být podepsán

Return Value

Type: Byte
Binární podoba podepsaného dokumentu
See Also

Reference

ILocalDocumentSigner Interface
Sign Overload
ASDSoft.SignTools Namespace


ILocalDocumentSigner.Sign Method (Stream, Stream)

ILocalDocumentSignerSign Method (Stream, Stream)

Vytvoření podpisu a jeho vložení do dokumentu

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
void Sign(
    Stream documentSourceStream,
    Stream documentOutputStream
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu, který má být podepsán
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba podepsaného dokumentu
See Also

Reference

ILocalDocumentSigner Interface
Sign Overload
ASDSoft.SignTools Namespace


IRemoteDocumentSigner Interface

Rozhraní pro externí podpis

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface IRemoteDocumentSigner
Methods
 | Name | Description
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Top
See Also

Reference

ASDSoft.SignTools Namespace


IRemoteDocumentSigner Methods

Methods
 | Name | Description
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Top
See Also

Reference

IRemoteDocumentSigner Interface
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.PrepareForExternalSign Method

IRemoteDocumentSignerPrepareForExternalSign Method

Overload List
 | Name | Description
Public method | PrepareForExternalSign(Byte, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Public method | PrepareForExternalSign(Stream, Stream, Byte) | Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.
Top
See Also

Reference

IRemoteDocumentSigner Interface
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.PrepareForExternalSign Method (Byte[], Byte[])

IRemoteDocumentSignerPrepareForExternalSign Method (Byte, Byte)

Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] PrepareForExternalSign(
    byte[] documentSourceData,
    out byte[] hashValue
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba dokumentu, který má být podepsán
hashValue
Type: SystemByte
Vypočtený hash podepisovaného dokumentu

Return Value

Type: Byte
Binární podoba připraveného dokumentu pro podpis
See Also

Reference

IRemoteDocumentSigner Interface
PrepareForExternalSign Overload
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.PrepareForExternalSign Method (Stream, Stream, Byte[])

IRemoteDocumentSignerPrepareForExternalSign Method (Stream, Stream, Byte)

Příprava dokumentu pro vytvoření podpisu včetně výpočtu hash pro podpis.

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
void PrepareForExternalSign(
    Stream documentSourceStream,
    Stream documentOutputStream,
    out byte[] hashValue
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu, který má být podepsán
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba připraveného dokumentu pro podpis
hashValue
Type: SystemByte
Vypočtený hash podepisovaného dokumentu
See Also

Reference

IRemoteDocumentSigner Interface
PrepareForExternalSign Overload
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.SetExternalSign Method

IRemoteDocumentSignerSetExternalSign Method

Overload List
 | Name | Description
Public method | SetExternalSign(Byte, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Public method | SetExternalSign(Stream, Stream, Byte) | Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)
Top
See Also

Reference

IRemoteDocumentSigner Interface
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.SetExternalSign Method (Byte[], Byte[])

IRemoteDocumentSignerSetExternalSign Method (Byte, Byte)

Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] SetExternalSign(
    byte[] documentSourceData,
    byte[] signature
)

Parameters

documentSourceData
Type: SystemByte
Binární podoba připraveného dokumentu pro podpis
signature
Type: SystemByte
Externě vytvořený podpis

Return Value

Type: Byte
Binární podoba podepsaného dokumentu
See Also

Reference

IRemoteDocumentSigner Interface
SetExternalSign Overload
ASDSoft.SignTools Namespace


IRemoteDocumentSigner.SetExternalSign Method (Stream, Stream, Byte[])

IRemoteDocumentSignerSetExternalSign Method (Stream, Stream, Byte)

Vložení externě vytvořeného podpisu do dokumentu připraveníého pomocí PrepareForExternalSign(Byte, Byte)

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
void SetExternalSign(
    Stream documentSourceStream,
    Stream documentOutputStream,
    byte[] signature
)

Parameters

documentSourceStream
Type: System.IOStream
Stream s binární podobou dokumentu připraveného pro podpis
documentOutputStream
Type: System.IOStream
Stream, do kterého bude zapsána binární podoba podepsaného dokumentu
signature
Type: SystemByte
Externě vytvořený podpis
See Also

Reference

IRemoteDocumentSigner Interface
SetExternalSign Overload
ASDSoft.SignTools Namespace


SigningScope Class

Podepisovací rámec pro hromadný podpis z více instancí implementujících IDocumentSigner
Inheritance Hierarchy
SystemObject
ASDSoft.SignToolsSigningScope

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public sealed class SigningScope : IDisposable

The SigningScope type exposes the following members.

Constructors
 | Name | Description
Public method | SigningScope | Základní konstrukor pro vytvoření podepisovacího rámce pro jeden podepisující certifikát
Top
Methods
 | Name | Description
Public method | Dispose | Uvolní prostředky alokované touto instancí a ukončí podepisovací rámec
Top
See Also

Reference

ASDSoft.SignTools Namespace


SigningScope Constructor

Základní konstrukor pro vytvoření podepisovacího rámce pro jeden podepisující certifikát

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public SigningScope(
    X509Certificate2 publicCertificate
)

Parameters

publicCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

SigningScope Class
ASDSoft.SignTools Namespace


SigningScope Methods

The SigningScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Uvolní prostředky alokované touto instancí a ukončí podepisovací rámec
Top
See Also

Reference

SigningScope Class
ASDSoft.SignTools Namespace


SigningScope.Dispose Method

SigningScopeDispose Method

Uvolní prostředky alokované touto instancí a ukončí podepisovací rámec

Namespace: ASDSoft.SignTools
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

SigningScope Class
ASDSoft.SignTools Namespace


ASDSoft.SignTools.Timestamping Namespace

Issuing and validating time stamps
Classes
 | Class | Description
Public class | Timestamp | Časové razítko
Public class | TSAClient | Klient pro získání časového razítka z TSA
Interfaces
 | Interface | Description
Public interface | ITimestamper | Rozhraní pro vytvoření časového razítka


ITimestamper Interface

Rozhraní pro vytvoření časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public interface ITimestamper

The ITimestamper type exposes the following members.

Properties
 | Name | Description
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB
Top
Methods
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka
Public method | TimestampData(Stream) | Vytvoření časového razítka
Top
See Also

Reference

ASDSoft.SignTools.Timestamping Namespace


ITimestamper Properties

The ITimestamper type exposes the following members.

Properties
 | Name | Description
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB
Top
See Also

Reference

ITimestamper Interface
ASDSoft.SignTools.Timestamping Namespace


ITimestamper.TimestampBufferSizeInKb Property

ITimestamperTimestampBufferSizeInKb Property

Očekávaná velikost vydávaných časových razítek v kB

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
int TimestampBufferSizeInKb { get; }

Property Value

Type: Int32
See Also

Reference

ITimestamper Interface
ASDSoft.SignTools.Timestamping Namespace


ITimestamper Methods

Methods
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka
Public method | TimestampData(Stream) | Vytvoření časového razítka
Top
See Also

Reference

ITimestamper Interface
ASDSoft.SignTools.Timestamping Namespace


ITimestamper.TimestampData Method

ITimestamperTimestampData Method

Overload List
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka
Public method | TimestampData(Stream) | Vytvoření časového razítka
Top
See Also

Reference

ITimestamper Interface
ASDSoft.SignTools.Timestamping Namespace


ITimestamper.TimestampData Method (Byte[])

ITimestamperTimestampData Method (Byte)

Vytvoření časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] TimestampData(
    byte[] message
)

Parameters

message
Type: SystemByte
Binární data, pro která má být vytvořeno časové razítko

Return Value

Type: Byte
Časové razítko
See Also

Reference

ITimestamper Interface
TimestampData Overload
ASDSoft.SignTools.Timestamping Namespace


ITimestamper.TimestampData Method (Stream)

ITimestamperTimestampData Method (Stream)

Vytvoření časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
byte[] TimestampData(
    Stream messageStream
)

Parameters

messageStream
Type: System.IOStream
Stream s binárními daty, pro která má být vytvořeno časové razítko

Return Value

Type: Byte
Časové razítko
See Also

Reference

ITimestamper Interface
TimestampData Overload
ASDSoft.SignTools.Timestamping Namespace


Timestamp Class

Časové razítko
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.TimestampingTimestamp

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
[SerializableAttribute]
public sealed class Timestamp

The Timestamp type exposes the following members.

Constructors
 | Name | Description
Public method | Timestamp | Základní konstruktor
Top
Properties
 | Name | Description
Public property | Accuracy | Přesnost časového razítka
Public property | GenTime | Čas vygenerování časového razítka
Public property | MessageHash | Hash, pro který bylo vytvořeno časové razítko
Public property | MessageHashAlgorithm | Hash algoritmus použitý pro vytvoření hash pro časové razítko
Public property | MessageHashString | Hash, pro který bylo vytvořeno časové razítko naformátovaný jako HEX text
Public property | RawData | Binární podoba časového razítka
Public property | SerialNumber | Seriové číslo certifikátu TSA, která časové razítko vydala
Public property | TSACertificate | Certifikát TSA, která časové razítko vydala
Public property | ValidityStatus | Status ověření časového razítka
Public property | ValidTo | Platnost časového razítka do
Top
Methods
 | Name | Description
Public method | Verify | Ověří časové razítko
Top
See Also

Reference

ASDSoft.SignTools.Timestamping Namespace


Timestamp Constructor

Základní konstruktor

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public Timestamp(
    byte[] rawData
)

Parameters

rawData
Type: SystemByte
Binární podoba časového razítka
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp Properties

The Timestamp type exposes the following members.

Properties
 | Name | Description
Public property | Accuracy | Přesnost časového razítka
Public property | GenTime | Čas vygenerování časového razítka
Public property | MessageHash | Hash, pro který bylo vytvořeno časové razítko
Public property | MessageHashAlgorithm | Hash algoritmus použitý pro vytvoření hash pro časové razítko
Public property | MessageHashString | Hash, pro který bylo vytvořeno časové razítko naformátovaný jako HEX text
Public property | RawData | Binární podoba časového razítka
Public property | SerialNumber | Seriové číslo certifikátu TSA, která časové razítko vydala
Public property | TSACertificate | Certifikát TSA, která časové razítko vydala
Public property | ValidityStatus | Status ověření časového razítka
Public property | ValidTo | Platnost časového razítka do
Top
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.Accuracy Property

TimestampAccuracy Property

Přesnost časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public TimeSpan Accuracy { get; }

Property Value

Type: TimeSpan
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.GenTime Property

TimestampGenTime Property

Čas vygenerování časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public DateTime GenTime { get; }

Property Value

Type: DateTime
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.MessageHash Property

TimestampMessageHash Property

Hash, pro který bylo vytvořeno časové razítko

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] MessageHash { get; }

Property Value

Type: Byte
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.MessageHashAlgorithm Property

TimestampMessageHashAlgorithm Property

Hash algoritmus použitý pro vytvoření hash pro časové razítko

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public HashOid MessageHashAlgorithm { get; }

Property Value

Type: HashOid
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.MessageHashString Property

TimestampMessageHashString Property

Hash, pro který bylo vytvořeno časové razítko naformátovaný jako HEX text

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string MessageHashString { get; }

Property Value

Type: String
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.RawData Property

TimestampRawData Property

Binární podoba časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public byte[] RawData { get; }

Property Value

Type: Byte
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.SerialNumber Property

TimestampSerialNumber Property

Seriové číslo certifikátu TSA, která časové razítko vydala

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string SerialNumber { get; }

Property Value

Type: String
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.TSACertificate Property

TimestampTSACertificate Property

Certifikát TSA, která časové razítko vydala

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public X509Certificate2 TSACertificate { get; }

Property Value

Type: X509Certificate2
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.ValidityStatus Property

TimestampValidityStatus Property

Status ověření časového razítka

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string ValidityStatus { get; }

Property Value

Type: String
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.ValidTo Property

TimestampValidTo Property

Platnost časového razítka do

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public DateTime ValidTo { get; }

Property Value

Type: DateTime
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp Methods

The Timestamp type exposes the following members.

Methods
 | Name | Description
Public method | Verify | Ověří časové razítko
Top
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


Timestamp.Verify Method

TimestampVerify Method

Ověří časové razítko

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public bool Verify()

Return Value

Type: Boolean
True, jestliže je časové razítko v čase ověření platné.
See Also

Reference

Timestamp Class
ASDSoft.SignTools.Timestamping Namespace


TSAClient Class

Klient pro získání časového razítka z TSA
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.TimestampingTSAClient

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public class TSAClient : ITimestamper

The TSAClient type exposes the following members.

Constructors
 | Name | Description
Public method | TSAClient | Základní konstruktor
Top
Methods
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka na požadované TSA
Public method | TimestampData(Stream) | Vytvoření časového razítka na požadované TSA
Top
See Also

Reference

ASDSoft.SignTools.Timestamping Namespace


TSAClient Constructor

Základní konstruktor

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public TSAClient(
    GenericTSAInfo tsaInfo
)

Parameters

tsaInfo
Type: ASDSoft.SignTools.Timestamping.TSAInfoGenericTSAInfo
Definice TSA, která má být pro vystavení časového razítka použita
See Also

Reference

TSAClient Class
ASDSoft.SignTools.Timestamping Namespace


TSAClient Methods

Methods
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka na požadované TSA
Public method | TimestampData(Stream) | Vytvoření časového razítka na požadované TSA
Top
See Also

Reference

TSAClient Class
ASDSoft.SignTools.Timestamping Namespace


TSAClient.TimestampData Method

TSAClientTimestampData Method

Overload List
 | Name | Description
Public method | TimestampData(Byte) | Vytvoření časového razítka na požadované TSA
Public method | TimestampData(Stream) | Vytvoření časového razítka na požadované TSA
Top
See Also

Reference

TSAClient Class
ASDSoft.SignTools.Timestamping Namespace


TSAClient.TimestampData Method (Byte[])

TSAClientTimestampData Method (Byte)

Vytvoření časového razítka na požadované TSA

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public Timestamp TimestampData(
    byte[] message
)

Parameters

message
Type: SystemByte
Binární data, pro která má být vytvořeno časové razítko

Return Value

Type: Timestamp
Časové razítko
See Also

Reference

TSAClient Class
TimestampData Overload
ASDSoft.SignTools.Timestamping Namespace


TSAClient.TimestampData Method (Stream)

TSAClientTimestampData Method (Stream)

Vytvoření časového razítka na požadované TSA

Namespace: ASDSoft.SignTools.Timestamping
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public Timestamp TimestampData(
    Stream messageStream
)

Parameters

messageStream
Type: System.IOStream
Stream s binárními daty, pro která má být vytvořeno časové razítko

Return Value

Type: Timestamp
Časové razítko
See Also

Reference

TSAClient Class
TimestampData Overload
ASDSoft.SignTools.Timestamping Namespace


ASDSoft.SignTools.Timestamping.TSAInfo Namespace

Definition of Time Stamp Issuers (TSA)
Classes
 | Class | Description
Public class | CertumTSAInfo | Definice TSA pro http://time.certum.pl
Public class | DigiCertTSAInfo | Definice TSA pro http://timestamp.digicert.com
Public class | GenericTSAInfo | Základní třída pro definici TSA poskytovatele
Public class | TSAInfoProvider | Základní provider pro poskytování nakonfigurovaných definic TSA


CertumTSAInfo Class

Definice TSA pro http://time.certum.pl
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.Timestamping.TSAInfoGenericTSAInfo
ASDSoft.SignTools.Timestamping.TSAInfoCertumTSAInfo

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public sealed class CertumTSAInfo : GenericTSAInfo

The CertumTSAInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CertumTSAInfo | Základní konstruktor
Top
Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url (Inherited from GenericTSAInfo.)
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko (Inherited from GenericTSAInfo.)
Public property | Name | Název TSA: Certum PL (Overrides GenericTSAInfoName.)
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL (Inherited from GenericTSAInfo.)
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA (Inherited from GenericTSAInfo.)
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB (Inherited from GenericTSAInfo.)
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka (Inherited from GenericTSAInfo.)
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován (Inherited from GenericTSAInfo.)
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Top
Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Inherited from GenericTSAInfo.)
Top
Fields
Name | Description
NAME | Název TSA: Certum PL
Top
See Also

Reference

ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo Constructor

Základní konstruktor

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public CertumTSAInfo()
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo Properties

The CertumTSAInfo type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url (Inherited from GenericTSAInfo.)
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko (Inherited from GenericTSAInfo.)
Public property | Name | Název TSA: Certum PL (Overrides GenericTSAInfoName.)
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL (Inherited from GenericTSAInfo.)
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA (Inherited from GenericTSAInfo.)
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB (Inherited from GenericTSAInfo.)
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka (Inherited from GenericTSAInfo.)
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován (Inherited from GenericTSAInfo.)
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Top
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo.Name Property

CertumTSAInfoName Property

Název TSA: Certum PL

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public override string Name { get; }

Property Value

Type: String
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo Methods

The CertumTSAInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Inherited from GenericTSAInfo.)
Top
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo Fields

The CertumTSAInfo type exposes the following members.

Fields
Name | Description
NAME | Název TSA: Certum PL
Top
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


CertumTSAInfo.NAME Field

CertumTSAInfoNAME Field

Název TSA: Certum PL

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string NAME = "Certum PL"

Field Value

Type: String
See Also

Reference

CertumTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo Class

Definice TSA pro http://timestamp.digicert.com
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.Timestamping.TSAInfoGenericTSAInfo
ASDSoft.SignTools.Timestamping.TSAInfoDigiCertTSAInfo

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public sealed class DigiCertTSAInfo : GenericTSAInfo

The DigiCertTSAInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DigiCertTSAInfo | Základní konstruktor
Top
Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url (Inherited from GenericTSAInfo.)
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko (Inherited from GenericTSAInfo.)
Public property | Name | Název TSA: DigiCert (Overrides GenericTSAInfoName.)
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL (Inherited from GenericTSAInfo.)
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA (Inherited from GenericTSAInfo.)
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB (Inherited from GenericTSAInfo.)
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka (Inherited from GenericTSAInfo.)
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován (Inherited from GenericTSAInfo.)
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Top
Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Inherited from GenericTSAInfo.)
Top
Fields
Name | Description
NAME | Název TSA: DigiCert
Top
See Also

Reference

ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo Constructor

Základní konstruktor

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public DigiCertTSAInfo()
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo Properties

The DigiCertTSAInfo type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url (Inherited from GenericTSAInfo.)
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko (Inherited from GenericTSAInfo.)
Public property | Name | Název TSA: DigiCert (Overrides GenericTSAInfoName.)
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL (Inherited from GenericTSAInfo.)
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA (Inherited from GenericTSAInfo.)
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB (Inherited from GenericTSAInfo.)
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka (Inherited from GenericTSAInfo.)
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován (Inherited from GenericTSAInfo.)
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno (Inherited from GenericTSAInfo.)
Top
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo.Name Property

DigiCertTSAInfoName Property

Název TSA: DigiCert

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public override string Name { get; }

Property Value

Type: String
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo Methods

The DigiCertTSAInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Inherited from GenericTSAInfo.)
Top
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo Fields

The DigiCertTSAInfo type exposes the following members.

Fields
Name | Description
NAME | Název TSA: DigiCert
Top
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


DigiCertTSAInfo.NAME Field

DigiCertTSAInfoNAME Field

Název TSA: DigiCert

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public const string NAME = "DigiCert"

Field Value

Type: String
See Also

Reference

DigiCertTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Class

Základní třída pro definici TSA poskytovatele
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.Timestamping.TSAInfoGenericTSAInfo
ASDSoft.SignTools.Timestamping.TSAInfoCertumTSAInfo
ASDSoft.SignTools.Timestamping.TSAInfoDigiCertTSAInfo

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public class GenericTSAInfo

The GenericTSAInfo type exposes the following members.

Constructors
 | Name | Description
Public method | GenericTSAInfo(Uri) | Základní konstruktor
Public method | GenericTSAInfo(Uri, String) | Rozšířený konstruktor
Top
Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko
Public property | Name | Základní unikátní popisný název TSA
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno
Top
Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Overrides ObjectToString.)
Top
See Also

Reference

ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Constructor

Overload List
 | Name | Description
Public method | GenericTSAInfo(Uri) | Základní konstruktor
Public method | GenericTSAInfo(Uri, String) | Rozšířený konstruktor
Top
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Constructor (Uri)

Základní konstruktor

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public GenericTSAInfo(
    Uri url
)

Parameters

url
Type: SystemUri
URL, na kterém poskytovatel TSA vydává časová razítka
See Also

Reference

GenericTSAInfo Class
GenericTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Constructor (Uri, String)

Rozšířený konstruktor

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public GenericTSAInfo(
    Uri url,
    string requestPolicy
)

Parameters

url
Type: SystemUri
URL, na kterém poskytovatel TSA vydává časová razítka
requestPolicy
Type: SystemString
Identifikace policy, podle které je požadováno vystavení časového razítka
See Also

Reference

GenericTSAInfo Class
GenericTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Properties

The GenericTSAInfo type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Plná název TSA složený z hodnoty z Name a Url
Public property | HashAlgorithm | Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko
Public property | Name | Základní unikátní popisný název TSA
Public property | Password | Heslo pro přihlášení k TSA, pokud je vyžadováno
Public property | RequestPolicy | Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL
Public property | SupportedHashAlgorithms | Podporované hash algoritmy danou TSA
Public property | TimestampBufferSizeInKb | Očekávaná velikost vydávaných časových razítek v kB
Public property | Url | URL, na kterém poskytovatel TSA vydává časová razítka
Public property | UserCertificate | X509 certifikát pro přihlášení k TSA, pokud je vyžadován
Public property | UserName | Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno
Top
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.FullName Property

GenericTSAInfoFullName Property

Plná název TSA složený z hodnoty z Name a Url

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string FullName { get; }

Property Value

Type: String
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.HashAlgorithm Property

GenericTSAInfoHashAlgorithm Property

Hash algoritmus, pomocí kterého je požadováno vystavit časové razítko

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public HashOid HashAlgorithm { get; set; }

Property Value

Type: HashOid
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.Name Property

GenericTSAInfoName Property

Základní unikátní popisný název TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public virtual string Name { get; }

Property Value

Type: String
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.Password Property

GenericTSAInfoPassword Property

Heslo pro přihlášení k TSA, pokud je vyžadováno

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string Password { set; }

Property Value

Type: String
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.RequestPolicy Property

GenericTSAInfoRequestPolicy Property

Identifikace policy, podle které je požadováno vystavení časového razítka, pokud byla specifikována, jinak NULL

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string RequestPolicy { get; }

Property Value

Type: String
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.SupportedHashAlgorithms Property

GenericTSAInfoSupportedHashAlgorithms Property

Podporované hash algoritmy danou TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public virtual HashOid[] SupportedHashAlgorithms { get; }

Property Value

Type: HashOid
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.TimestampBufferSizeInKb Property

GenericTSAInfoTimestampBufferSizeInKb Property

Očekávaná velikost vydávaných časových razítek v kB

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public int TimestampBufferSizeInKb { get; set; }

Property Value

Type: Int32
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.Url Property

GenericTSAInfoUrl Property

URL, na kterém poskytovatel TSA vydává časová razítka

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public Uri Url { get; }

Property Value

Type: Uri
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.UserCertificate Property

GenericTSAInfoUserCertificate Property

X509 certifikát pro přihlášení k TSA, pokud je vyžadován

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public X509Certificate2 UserCertificate { get; set; }

Property Value

Type: X509Certificate2
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.UserName Property

GenericTSAInfoUserName Property

Uživatelské jméno pro přihlášení k TSA, pokud je vyžadováno

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public string UserName { get; set; }

Property Value

Type: String
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo Methods

The GenericTSAInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Převede instanci na text (Overrides ObjectToString.)
Top
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


GenericTSAInfo.ToString Method

GenericTSAInfoToString Method

Převede instanci na text

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
Hodnota property FullName
See Also

Reference

GenericTSAInfo Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider Class

Základní provider pro poskytování nakonfigurovaných definic TSA
Inheritance Hierarchy
SystemObject
ASDSoft.SignTools.Timestamping.TSAInfoTSAInfoProvider

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public sealed class TSAInfoProvider

The TSAInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetRegisteredTSAInfos | Získá seznam názvů nakonfigurovaných TSA v elementu ASDSoft.SignTools/tsa
Public method | GetTSAInfo | Záská definici TSA z konfiguračního souboru z elemetu ASDSoft.SignTools/tsa
Public method | RegisterTSAInfo(GenericTSAInfo) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(String) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(Type) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfoTTSAInfo | Zaregistruje novou definici TSA
Top
Fields
Name | Description
Instance | Singleton instance s poskytovatelem nakonfigurovaných definic TSA
Top
See Also

Reference

ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider Methods

The TSAInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetRegisteredTSAInfos | Získá seznam názvů nakonfigurovaných TSA v elementu ASDSoft.SignTools/tsa
Public method | GetTSAInfo | Záská definici TSA z konfiguračního souboru z elemetu ASDSoft.SignTools/tsa
Public method | RegisterTSAInfo(GenericTSAInfo) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(String) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(Type) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfoTTSAInfo | Zaregistruje novou definici TSA
Top
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.GetRegisteredTSAInfos Method

TSAInfoProviderGetRegisteredTSAInfos Method

Získá seznam názvů nakonfigurovaných TSA v elementu ASDSoft.SignTools/tsa

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public IEnumerable<string> GetRegisteredTSAInfos()

Return Value

Type: IEnumerable String
Seznam názvů nakonfigurovaných TSA v elementu ASDSoft.SignTools/tsa
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.GetTSAInfo Method

TSAInfoProviderGetTSAInfo Method

Záská definici TSA z konfiguračního souboru z elemetu ASDSoft.SignTools/tsa

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public GenericTSAInfo GetTSAInfo(
    string name
)

Parameters

name
Type: SystemString
Název konfigurace v atributu name

Return Value

Type: GenericTSAInfo
Definice TSA
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.RegisterTSAInfo Method

TSAInfoProviderRegisterTSAInfo Method

Overload List
 | Name | Description
Public method | RegisterTSAInfoTTSAInfo | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(GenericTSAInfo) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(String) | Zaregistruje novou definici TSA
Public method | RegisterTSAInfo(Type) | Zaregistruje novou definici TSA
Top
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.RegisterTSAInfo(TTSAInfo) Method

TSAInfoProviderRegisterTSAInfoTTSAInfo Method

Zaregistruje novou definici TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterTSAInfo<TTSAInfo>()
where TTSAInfo : new(), GenericTSAInfo

Type Parameters

TTSAInfo
Typ třídy implementující definici TSA
See Also

Reference

TSAInfoProvider Class
RegisterTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.RegisterTSAInfo Method (GenericTSAInfo)

TSAInfoProviderRegisterTSAInfo Method (GenericTSAInfo)

Zaregistruje novou definici TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterTSAInfo(
    GenericTSAInfo tsaInfo
)

Parameters

tsaInfo
Type: ASDSoft.SignTools.Timestamping.TSAInfoGenericTSAInfo
Instance třídy implementující definici TSA
See Also

Reference

TSAInfoProvider Class
RegisterTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.RegisterTSAInfo Method (String)

TSAInfoProviderRegisterTSAInfo Method (String)

Zaregistruje novou definici TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterTSAInfo(
    string tsaInfoTypeName
)

Parameters

tsaInfoTypeName
Type: SystemString
Úplná název typu třídy implementující definici TSA
See Also

Reference

TSAInfoProvider Class
RegisterTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.RegisterTSAInfo Method (Type)

TSAInfoProviderRegisterTSAInfo Method (Type)

Zaregistruje novou definici TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public void RegisterTSAInfo(
    Type tsaInfoType
)

Parameters

tsaInfoType
Type: SystemType
Typ třídy implementující definici TSA
See Also

Reference

TSAInfoProvider Class
RegisterTSAInfo Overload
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider Fields

The TSAInfoProvider type exposes the following members.

Fields
Name | Description
Instance | Singleton instance s poskytovatelem nakonfigurovaných definic TSA
Top
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


TSAInfoProvider.Instance Field

TSAInfoProviderInstance Field

Singleton instance s poskytovatelem nakonfigurovaných definic TSA

Namespace: ASDSoft.SignTools.Timestamping.TSAInfo
Assembly: ASDSoft.SignTools (in ASDSoft.SignTools.dll) Version: 4.3.1
Syntax
C#
Copy
public static readonly TSAInfoProvider Instance

Field Value

Type: TSAInfoProvider
See Also

Reference

TSAInfoProvider Class
ASDSoft.SignTools.Timestamping.TSAInfo Namespace


ASDSoft.WebSigner Namespace

Root namespace for common objects.
Classes
 | Class | Description
Public class | SignatureBase | Base class for transport signature request and response between server and client.
Public class | SignatureRequest | Request data for content signing.
Public class | SignatureResponse | Response data with created signatures on client sended to server.
Public class | SignatureSessionBase | Base class for implementation signature session.
Structures
 | Structure | Description
Public structure | HashAlgorithmName | Definition of supported hash algorithms.
Enumerations
 | Enumeration | Description
Public enumeration | SignatureType | Method type of signing.


HashAlgorithmName Structure

Definition of supported hash algorithms.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[ObfuscationAttribute(Exclude = true)]
public struct HashAlgorithmName

The HashAlgorithmName type exposes the following members.

Constructors
 | Name | Description
Public method | HashAlgorithmName | Initializes a new instance of the HashAlgorithmName structure with a custom name.
Top
Properties
 | Name | Description
Public property | Name | Gets the underlying string representation of the algorithm name.
 | SHA1 | Gets a hash algorithm name that represents "SHA1".
 | SHA256 | Gets a hash algorithm name that represents "SHA256".
 | SHA384 | Gets a hash algorithm name that represents "SHA384".
 | SHA512 | Gets a hash algorithm name that represents "SHA512".
Top
Methods
 | Name | Description
Public method | Equals(HashAlgorithmName) | Returns a value that indicates whether two HashAlgorithmName instances are equal.
Public method | Equals(Object) | Returns a value that indicates whether the current instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns the hash code for the current instance. (Overrides ValueTypeGetHashCode.)
Public method | ToString | Returns the string representation of the current HashAlgorithmName instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Determines whether two specified HashAlgorithmName objects are equal.
Inequality | Determines whether two specified HashAlgorithmName objects are not equal.
Top
See Also

Reference

ASDSoft.WebSigner Namespace


HashAlgorithmName Constructor

Initializes a new instance of the HashAlgorithmName structure with a custom name.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public HashAlgorithmName(
    string name
)

Parameters

name
Type: SystemString
The custom hash algorithm name.
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName Properties

The HashAlgorithmName type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the underlying string representation of the algorithm name.
 | SHA1 | Gets a hash algorithm name that represents "SHA1".
 | SHA256 | Gets a hash algorithm name that represents "SHA256".
 | SHA384 | Gets a hash algorithm name that represents "SHA384".
 | SHA512 | Gets a hash algorithm name that represents "SHA512".
Top
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.Name Property

HashAlgorithmNameName Property

Gets the underlying string representation of the algorithm name.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public string Name { get; }

Return Value

Type: String
The string representation of the algorithm name, or or Empty if no hash algorithm is available.
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.SHA1 Property

HashAlgorithmNameSHA1 Property

Gets a hash algorithm name that represents "SHA1".

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static HashAlgorithmName SHA1 { get; }

Return Value

Type: HashAlgorithmName
A hash algorithm name that represents "SHA1".
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.SHA256 Property

HashAlgorithmNameSHA256 Property

Gets a hash algorithm name that represents "SHA256".

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static HashAlgorithmName SHA256 { get; }

Return Value

Type: HashAlgorithmName
A hash algorithm name that represents "SHA256".
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.SHA384 Property

HashAlgorithmNameSHA384 Property

Gets a hash algorithm name that represents "SHA384".

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static HashAlgorithmName SHA384 { get; }

Return Value

Type: HashAlgorithmName
A hash algorithm name that represents "SHA384".
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.SHA512 Property

HashAlgorithmNameSHA512 Property

Gets a hash algorithm name that represents "SHA512".

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static HashAlgorithmName SHA512 { get; }

Return Value

Type: HashAlgorithmName
A hash algorithm name that represents "SHA512".
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName Methods

The HashAlgorithmName type exposes the following members.

Methods
 | Name | Description
Public method | Equals(HashAlgorithmName) | Returns a value that indicates whether two HashAlgorithmName instances are equal.
Public method | Equals(Object) | Returns a value that indicates whether the current instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns the hash code for the current instance. (Overrides ValueTypeGetHashCode.)
Public method | ToString | Returns the string representation of the current HashAlgorithmName instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.Equals Method

HashAlgorithmNameEquals Method

Overload List
 | Name | Description
Public method | Equals(HashAlgorithmName) | Returns a value that indicates whether two HashAlgorithmName instances are equal.
Public method | Equals(Object) | Returns a value that indicates whether the current instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Top
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.Equals Method (HashAlgorithmName)

HashAlgorithmNameEquals Method (HashAlgorithmName)

Returns a value that indicates whether two HashAlgorithmName instances are equal.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public bool Equals(
    HashAlgorithmName other
)

Parameters

other
Type: ASDSoft.WebSignerHashAlgorithmName
The object to compare with the current instance.

Return Value

Type: Boolean
if the Name property of other is equal to that of the current instance. The comparison is ordinal and case-sensitive.
See Also

Reference

HashAlgorithmName Structure
Equals Overload
ASDSoft.WebSigner Namespace


HashAlgorithmName.Equals Method (Object)

HashAlgorithmNameEquals Method (Object)

Returns a value that indicates whether the current instance and a specified object are equal.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current instance.

Return Value

Type: Boolean
if obj is a HashAlgorithmName object and its Name property is equal to that of the current instance. The comparison is ordinal and case-sensitive.
See Also

Reference

HashAlgorithmName Structure
Equals Overload
ASDSoft.WebSigner Namespace


HashAlgorithmName.GetHashCode Method

HashAlgorithmNameGetHashCode Method

Returns the hash code for the current instance.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
The hash code for the current instance, or 0 if no Name value was supplied to the HashAlgorithmName constructor.
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.ToString Method

HashAlgorithmNameToString Method

Returns the string representation of the current HashAlgorithmName instance.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
The string representation of the current HashAlgorithmName instance.
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName Operators

The HashAlgorithmName type exposes the following members.

Operators
Name | Description
Equality | Determines whether two specified HashAlgorithmName objects are equal.
Inequality | Determines whether two specified HashAlgorithmName objects are not equal.
Top
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.Equality Operator

HashAlgorithmNameEquality Operator

Determines whether two specified HashAlgorithmName objects are equal.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static bool operator ==(
    HashAlgorithmName left,
    HashAlgorithmName right
)

Parameters

left
Type: ASDSoft.WebSignerHashAlgorithmName
The first object to compare.
right
Type: ASDSoft.WebSignerHashAlgorithmName
The second object to compare.

Return Value

Type: Boolean
if both left and right have the same Name value; otherwise, .
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


HashAlgorithmName.Inequality Operator

HashAlgorithmNameInequality Operator

Determines whether two specified HashAlgorithmName objects are not equal.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public static bool operator !=(
    HashAlgorithmName left,
    HashAlgorithmName right
)

Parameters

left
Type: ASDSoft.WebSignerHashAlgorithmName
The first object to compare.
right
Type: ASDSoft.WebSignerHashAlgorithmName
The second object to compare.

Return Value

Type: Boolean
if both left and right do not have the same Name value; otherwise, .
See Also

Reference

HashAlgorithmName Structure
ASDSoft.WebSigner Namespace


SignatureBase Class

Base class for transport signature request and response between server and client.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureBase
ASDSoft.WebSigner.ServerSignatureInfo
ASDSoft.WebSignerSignatureRequest
ASDSoft.WebSignerSignatureResponse

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
public abstract class SignatureBase

The SignatureBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SignatureBase | Base constructor for inherited classes.
Top
Properties
 | Name | Description
Public property | Id | Unique ID for request and response.
Top
See Also

Reference

ASDSoft.WebSigner Namespace


SignatureBase Constructor

Base constructor for inherited classes.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureBase(
    Guid id
)

Parameters

id
Type: SystemGuid
Unique ID for request and response.
See Also

Reference

SignatureBase Class
ASDSoft.WebSigner Namespace


SignatureBase Properties

The SignatureBase type exposes the following members.

Properties
 | Name | Description
Public property | Id | Unique ID for request and response.
Top
See Also

Reference

SignatureBase Class
ASDSoft.WebSigner Namespace


SignatureBase.Id Property

SignatureBaseId Property

Unique ID for request and response.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
public Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

SignatureBase Class
ASDSoft.WebSigner Namespace


SignatureRequest Class

Request data for content signing.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureBase
ASDSoft.WebSignerSignatureRequest

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
[ObfuscationAttribute(Exclude = true)]
public class SignatureRequest : SignatureBase

The SignatureRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SignatureRequest(LoginContent) | Special constructor for create request with login message text for user login by certificate signing.
Public method | SignatureRequest(ContentBase, HashAlgorithmName) | Base constructor for create request data for content signing.
Top
Properties
 | Name | Description
Public property | Content | Content for signing.
Public property | HashAlgorithm | Hash algorithm name used for signing.
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Top
Remarks
You can add one or more instances of SignatureRequest to ASDSoft.WebSigner.Server.SignatureSession for the signing of one or more contents. All requests sended to client for signing.
See Also

Reference

ASDSoft.WebSigner Namespace


SignatureRequest Constructor

Overload List
 | Name | Description
Public method | SignatureRequest(LoginContent) | Special constructor for create request with login message text for user login by certificate signing.
Public method | SignatureRequest(ContentBase, HashAlgorithmName) | Base constructor for create request data for content signing.
Top
See Also

Reference

SignatureRequest Class
ASDSoft.WebSigner Namespace


SignatureRequest Constructor (LoginContent)

Special constructor for create request with login message text for user login by certificate signing.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureRequest(
    LoginContent content
)

Parameters

content
Type: ASDSoft.WebSigner.ContentLoginContent
Message text for user login.
See Also

Reference

SignatureRequest Class
SignatureRequest Overload
ASDSoft.WebSigner Namespace


SignatureRequest Constructor (ContentBase, HashAlgorithmName)

Base constructor for create request data for content signing.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureRequest(
    ContentBase content,
    HashAlgorithmName hashAlgorithm
)

Parameters

content
Type: ASDSoft.WebSigner.ContentContentBase
Content for signing.
hashAlgorithm
Type: ASDSoft.WebSignerHashAlgorithmName
Hash algorithm name used for signing.
See Also

Reference

SignatureRequest Class
SignatureRequest Overload
ASDSoft.WebSigner Namespace


SignatureRequest Properties

The SignatureRequest type exposes the following members.

Properties
 | Name | Description
Public property | Content | Content for signing.
Public property | HashAlgorithm | Hash algorithm name used for signing.
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Top
See Also

Reference

SignatureRequest Class
ASDSoft.WebSigner Namespace


SignatureRequest.Content Property

SignatureRequestContent Property

Content for signing.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public ContentBase Content { get; set; }

Property Value

Type: ContentBase
See Also

Reference

SignatureRequest Class
ASDSoft.WebSigner Namespace


SignatureRequest.HashAlgorithm Property

SignatureRequestHashAlgorithm Property

Hash algorithm name used for signing.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public HashAlgorithmName HashAlgorithm { get; }

Property Value

Type: HashAlgorithmName
See Also

Reference

SignatureRequest Class
ASDSoft.WebSigner Namespace


SignatureResponse Class

Response data with created signatures on client sended to server.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureBase
ASDSoft.WebSignerSignatureResponse

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
[ObfuscationAttribute(Exclude = true)]
public class SignatureResponse : SignatureBase

The SignatureResponse type exposes the following members.

Constructors
 | Name | Description
Public method | SignatureResponse | Only for internal use.
Top
Properties
 | Name | Description
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Public property | Signature | Created RSA signature.
Top
See Also

Reference

ASDSoft.WebSigner Namespace


SignatureResponse Constructor

Only for internal use.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureResponse(
    Guid id,
    byte[] signature
)

Parameters

id
Type: SystemGuid
Unique ID for response.
signature
Type: SystemByte
Created signature.
See Also

Reference

SignatureResponse Class
ASDSoft.WebSigner Namespace


SignatureResponse Properties

The SignatureResponse type exposes the following members.

Properties
 | Name | Description
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Public property | Signature | Created RSA signature.
Top
See Also

Reference

SignatureResponse Class
ASDSoft.WebSigner Namespace


SignatureResponse.Signature Property

SignatureResponseSignature Property

Created RSA signature.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
public byte[] Signature { get; }

Property Value

Type: Byte
See Also

Reference

SignatureResponse Class
ASDSoft.WebSigner Namespace


SignatureSessionBase Class

Base class for implementation signature session.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureSessionBase
ASDSoft.WebSigner.ServerSignatureSession

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
public abstract class SignatureSessionBase

The SignatureSessionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SignatureSessionBase | Base socnstructor.
Top
Properties
 | Name | Description
Public property | SessionId | Unique session ID.
Top
See Also

Reference

ASDSoft.WebSigner Namespace


SignatureSessionBase Constructor

Base socnstructor.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSessionBase(
    string sessionId
)

Parameters

sessionId
Type: SystemString
Unique session ID.
See Also

Reference

SignatureSessionBase Class
ASDSoft.WebSigner Namespace


SignatureSessionBase Properties

The SignatureSessionBase type exposes the following members.

Properties
 | Name | Description
Public property | SessionId | Unique session ID.
Top
See Also

Reference

SignatureSessionBase Class
ASDSoft.WebSigner Namespace


SignatureSessionBase.SessionId Property

SignatureSessionBaseSessionId Property

Unique session ID.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
public string SessionId { get; }

Property Value

Type: String
See Also

Reference

SignatureSessionBase Class
ASDSoft.WebSigner Namespace


SignatureType Enumeration

Method type of signing.

Namespace: ASDSoft.WebSigner
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public enum SignatureType
Members
Member name | Value | Description
Data | 1 | For signing will be used method SignData(Byte, Object).
Hash | 2 | For signing will be used method SignHash(Byte, String).
See Also

Reference

ASDSoft.WebSigner Namespace


ASDSoft.WebSigner.Content Namespace

Base definitions of content for signing.
Classes
 | Class | Description
Public class | ContentBase | Base class for implementation of individual types of signing content.
Public class | ContentBaseT | Base typed class for implementation of individual types of signing content.
Public class | LoginContent | Represent login message text for user login by certificate signing.
Public class | TextContent | Represent plain text for signing by Data


ContentBase Class

Base class for implementation of individual types of signing content.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBaseT

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
[ObfuscationAttribute(Exclude = true)]
public abstract class ContentBase

The ContentBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ContentBase | Base constructor for inherited classes.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document).
Public property | HasContent | Only for internal use.
Protected property | HasLazyContent | Only for internal use.
Public property | IsLink | Indicate, if interface IDocumentLinkContent is implemented in inherited class on server-side.
Public property | NeedResetLazyContent | Only for internal use.
Public property | SignatureType | Signature type (Data or Hash).
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing.
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate.
Public method | SetContent | Lazy setting of content if not set in constructor.
Top
Remarks
All inherited classes must be marked by SerializableAttribute.
See Also

Reference

ASDSoft.WebSigner.Content Namespace


ContentBase Constructor

Base constructor for inherited classes.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected ContentBase(
    SignatureType signatureType,
    Object applicationContentId = null
)

Parameters

signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase Properties

The ContentBase type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document).
Public property | HasContent | Only for internal use.
Protected property | HasLazyContent | Only for internal use.
Public property | IsLink | Indicate, if interface IDocumentLinkContent is implemented in inherited class on server-side.
Public property | NeedResetLazyContent | Only for internal use.
Public property | SignatureType | Signature type (Data or Hash).
Top
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.ApplicationContentId Property

ContentBaseApplicationContentId Property

Unique ID generated by hosting application identified content in hosting application (for example ID of document).

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public Object ApplicationContentId { get; }

Property Value

Type: Object
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.HasContent Property

ContentBaseHasContent Property

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract bool HasContent { get; }

Property Value

Type: Boolean
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.HasLazyContent Property

ContentBaseHasLazyContent Property

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
protected bool HasLazyContent { get; set; }

Property Value

Type: Boolean
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.IsLink Property

ContentBaseIsLink Property

Indicate, if interface IDocumentLinkContent is implemented in inherited class on server-side.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract bool IsLink { get; }

Property Value

Type: Boolean
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.NeedResetLazyContent Property

ContentBaseNeedResetLazyContent Property

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public bool NeedResetLazyContent { get; }

Property Value

Type: Boolean
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.SignatureType Property

ContentBaseSignatureType Property

Signature type (Data or Hash).

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
public SignatureType SignatureType { get; }

Property Value

Type: SignatureType
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase Methods

The ContentBase type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing.
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate.
Public method | SetContent | Lazy setting of content if not set in constructor.
Top
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.GetContentData Method

ContentBaseGetContentData Method

Return binary data or hash of content for signing.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract byte[] GetContentData()

Return Value

Type: Byte
Binary data or hash for signing.
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.GetContentTitle Method

ContentBaseGetContentTitle Method

Return text description of content for display in client window for selecting a certificate.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract string GetContentTitle()

Return Value

Type: String
Description text of content.
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase.SetContent Method

ContentBaseSetContent Method

Lazy setting of content if not set in constructor.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract void SetContent(
    Object content
)

Parameters

content
Type: SystemObject
Content for signing, for example, text, byte array, ...
Remarks
Use for the signing of the document, that requires certificate included in signing content.
See Also

Reference

ContentBase Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T) Class

ContentBaseT Class

Base typed class for implementation of individual types of signing content.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBaseT
ASDSoft.WebSigner.ContentTextContent
ASDSoft.WebSigner.Server.ContentBinaryContent

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
[ObfuscationAttribute(Exclude = true)]
public abstract class ContentBase<T> : ContentBase
where T : class

Type Parameters

T
Type of content data, form example string, byte[], ...

The ContentBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ContentBaseT(SignatureType, Object) | Base constructor for inherited classes without known content at instance creation time.
Protected method | ContentBaseT(T, SignatureType, Object) | Base constructor for inherited classes with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ...
Public property | HasContent | Only for internal use. (Overrides ContentBaseHasContent.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Indicate, if interface IDocumentLinkContent is implemented in inherited class on server-side. (Inherited from ContentBase.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from ContentBase.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from ContentBase.)
Protected method | ResetLazyContent | Only for internal use.
Public method | SetContent | Lazy setting of content if not set in constructor. (Overrides ContentBaseSetContent(Object).)
Top
See Also

Reference

ASDSoft.WebSigner.Content Namespace


ContentBase(T) Constructor

ContentBaseT Constructor

Overload List
 | Name | Description
Protected method | ContentBaseT(SignatureType, Object) | Base constructor for inherited classes without known content at instance creation time.
Protected method | ContentBaseT(T, SignatureType, Object) | Base constructor for inherited classes with known content at instance creation time.
Top
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T) Constructor (SignatureType, Object)

ContentBaseT Constructor (SignatureType, Object)

Base constructor for inherited classes without known content at instance creation time.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected ContentBase(
    SignatureType signatureType,
    Object applicationContentId = null
)

Parameters

signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
Remarks
Use for the signing of the document, that requires certificate included in signing content. In this case must be implemented lazy obtain data content in inhertited implementation of method ASDSoft.WebSigner.Server.SignerBase.GetContent.
See Also

Reference

ContentBaseT Class
ContentBaseT Overload
ASDSoft.WebSigner.Content Namespace


ContentBase(T) Constructor (T, SignatureType, Object)

ContentBaseT Constructor (T, SignatureType, Object)

Base constructor for inherited classes with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected ContentBase(
    T content,
    SignatureType signatureType,
    Object applicationContentId = null
)

Parameters

content
Type: T
Content for signing, for example, text, byte array, ...
signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

ContentBaseT Class
ContentBaseT Overload
ASDSoft.WebSigner.Content Namespace


ContentBase(T) Properties

ContentBaseT Properties

The ContentBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ...
Public property | HasContent | Only for internal use. (Overrides ContentBaseHasContent.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Indicate, if interface IDocumentLinkContent is implemented in inherited class on server-side. (Inherited from ContentBase.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T).Content Property

ContentBaseTContent Property

Content for signing, for example, text, byte array, ...

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute]
public T Content { get; }

Property Value

Type: T
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T).HasContent Property

ContentBaseTHasContent Property

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool HasContent { get; }

Property Value

Type: Boolean
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T) Methods

ContentBaseT Methods

The ContentBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from ContentBase.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from ContentBase.)
Protected method | ResetLazyContent | Only for internal use.
Public method | SetContent | Lazy setting of content if not set in constructor. (Overrides ContentBaseSetContent(Object).)
Top
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T).ResetLazyContent Method

ContentBaseTResetLazyContent Method

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual void ResetLazyContent()
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


ContentBase(T).SetContent Method

ContentBaseTSetContent Method

Lazy setting of content if not set in constructor.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override void SetContent(
    Object content
)

Parameters

content
Type: SystemObject
Content for signing, for example, text, byte array, ...
Remarks
Use for the signing of the document, that requires certificate included in signing content.
See Also

Reference

ContentBaseT Class
ASDSoft.WebSigner.Content Namespace


LoginContent Class

Represent login message text for user login by certificate signing.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase String
ASDSoft.WebSigner.ContentTextContent
ASDSoft.WebSigner.ContentLoginContent

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[ObfuscationAttribute(Exclude = true)]
public class LoginContent : TextContent

The LoginContent type exposes the following members.

Constructors
 | Name | Description
Public method | LoginContent | Only for internal use.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from TextContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
Methods
 | Name | Description
Public method | GetContentData | Only for internal use. (Inherited from TextContent.)
Public method | GetContentTitle | Only for internal use. (Inherited from TextContent.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
Remarks
For create loging content with default text you can use method ASDSoft.WebSigner.Server.SignerBase.CreateLoginSignatureSession

Default login message text is: By signing this text electronically, I log in to application {0} at {1}.

See Also

Reference

ASDSoft.WebSigner.Content Namespace


LoginContent Constructor

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public LoginContent(
    string loginMessage
)

Parameters

loginMessage
Type: SystemString
Login message text for user login by certificate signing
See Also

Reference

LoginContent Class
ASDSoft.WebSigner.Content Namespace


LoginContent Properties

The LoginContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from TextContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
See Also

Reference

LoginContent Class
ASDSoft.WebSigner.Content Namespace


LoginContent Methods

The LoginContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Only for internal use. (Inherited from TextContent.)
Public method | GetContentTitle | Only for internal use. (Inherited from TextContent.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

LoginContent Class
ASDSoft.WebSigner.Content Namespace


TextContent Class

Represent plain text for signing by Data
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase String
ASDSoft.WebSigner.ContentTextContent
ASDSoft.WebSigner.ContentLoginContent

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[ObfuscationAttribute(Exclude = true)]
public class TextContent : ContentBase<string>

The TextContent type exposes the following members.

Constructors
 | Name | Description
Public method | TextContent | Base constructor.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides ContentBaseIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
Methods
 | Name | Description
Public method | GetContentData | Only for internal use. (Overrides ContentBaseGetContentData.)
Public method | GetContentTitle | Only for internal use. (Overrides ContentBaseGetContentTitle.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
Remarks
Before signing, the text will be converted to a byte array by UTF8 encoding.
See Also

Reference

ASDSoft.WebSigner.Content Namespace


TextContent Constructor

Base constructor.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public TextContent(
    string content,
    Object applicationContentId = null
)

Parameters

content
Type: SystemString
Plain text for signing.
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified text in hosting application.
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


TextContent Properties

The TextContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides ContentBaseIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Top
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


TextContent.IsLink Property

TextContentIsLink Property

Always return .

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool IsLink { get; }

Property Value

Type: Boolean
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


TextContent Methods

The TextContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Only for internal use. (Overrides ContentBaseGetContentData.)
Public method | GetContentTitle | Only for internal use. (Overrides ContentBaseGetContentTitle.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


TextContent.GetContentData Method

TextContentGetContentData Method

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override byte[] GetContentData()

Return Value

Type: Byte
Byte array converted from plain text by UTF8 encoding.
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


TextContent.GetContentTitle Method

TextContentGetContentTitle Method

Only for internal use.

Namespace: ASDSoft.WebSigner.Content
Assembly: ASDSoft.WebSigner (in ASDSoft.WebSigner.dll) Version: 2.5.0
Syntax
C#
Copy
public override string GetContentTitle()

Return Value

Type: String
Plain text for signing
See Also

Reference

TextContent Class
ASDSoft.WebSigner.Content Namespace


ASDSoft.WebSigner.Server Namespace

Root namespace for server side objects.
Classes
 | Class | Description
Public class | ClientScriptManagerExtension | Extension for ClientScriptManager for register required signing client javascript to page in .NET Framework ASP.NET WebForms or MVC.
Public class | DocumentSignerBaseTIdentification | Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures for documents with typed Identification.
Public class | PathProvider | Provides a URLs for resources signing process.
Public class | SignatureInfo | Information about signed content created in SignatureSession.
Public class | SignatureSession | The main object for store information about signing contents, created signatures and status (progress) of signing.
Public class | SignerBase | Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures.
Public class | SignerBaseTIdentification | Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures with typed Identification.
Public class | StartupTStartupSettings | Base class for implementation of configuration WebSigner module during initializing web application in platform specific.
Public class | StartupSettingsBase | Information for configuration WebSigner module during initializing web application.
Structures
 | Structure | Description
Protected structure | DocumentSignerBaseTIdentificationDocumentIdentification |
Interfaces
 | Interface | Description
Public interface | ICertificateAuthenticationProvider | Interface for authenticate user to hosted application by certificate signing text.


ClientScriptManagerExtension Class

Extension for ClientScriptManager for register required signing client javascript to page in .NET Framework ASP.NET WebForms or MVC.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerClientScriptManagerExtension

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class ClientScriptManagerExtension

The ClientScriptManagerExtension type exposes the following members.

Methods
Name | Description
RegisterSigningClientScriptInclude | Register common client javascript to page for use signing in WebForms page on client side.
RegisterSigningStartupScript | Obsolete. Register client javascript to page for run signing on client immediately after page loaded to browser.
RegisterStartSignatureMethod | Register javascript method for start signing in application host process.
RegisterStartSignatureOnClick | Register javascript to onclick event on Button for start signing in application host process.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


ClientScriptManagerExtension Methods

The ClientScriptManagerExtension type exposes the following members.

Methods
Name | Description
RegisterSigningClientScriptInclude | Register common client javascript to page for use signing in WebForms page on client side.
RegisterSigningStartupScript | Obsolete. Register client javascript to page for run signing on client immediately after page loaded to browser.
RegisterStartSignatureMethod | Register javascript method for start signing in application host process.
RegisterStartSignatureOnClick | Register javascript to onclick event on Button for start signing in application host process.
Top
See Also

Reference

ClientScriptManagerExtension Class
ASDSoft.WebSigner.Server Namespace


ClientScriptManagerExtension.RegisterSigningClientScriptInclude Method

ClientScriptManagerExtensionRegisterSigningClientScriptInclude Method

Register common client javascript to page for use signing in WebForms page on client side.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static void RegisterSigningClientScriptInclude(
    this ClientScriptManager clientScript
)

Parameters

clientScript
Type: System.Web.UIClientScriptManager
Instance of ClientScriptManager in ClientScript property.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ClientScriptManager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientScriptManagerExtension Class
ASDSoft.WebSigner.Server Namespace


ClientScriptManagerExtension.RegisterSigningStartupScript Method

ClientScriptManagerExtensionRegisterSigningStartupScript Method

Note: This API is now obsolete.

Register client javascript to page for run signing on client immediately after page loaded to browser.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[ObsoleteAttribute("Use Button.RegisterStartSignatureOnClick or ClientScriptManager.RegisterStartSignatureMethod.",
    true)]
public static void RegisterSigningStartupScript(
    this ClientScriptManager clientScript,
    string sessionId,
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

clientScript
Type: System.Web.UIClientScriptManager
Instance of ClientScriptManager in ClientScript property.
sessionId
Type: SystemString
Signing SessionId from SignatureSession
statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ClientScriptManager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Within this method is called RegisterSigningClientScriptInclude(ClientScriptManager) for registering common client javascript for use signing.
See Also

Reference

ClientScriptManagerExtension Class
ASDSoft.WebSigner.Server Namespace


ClientScriptManagerExtension.RegisterStartSignatureMethod Method

ClientScriptManagerExtensionRegisterStartSignatureMethod Method

Register javascript method for start signing in application host process.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static void RegisterStartSignatureMethod(
    this ClientScriptManager clientScript,
    string methodName,
    CreateSessionRequest request,
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

clientScript
Type: System.Web.UIClientScriptManager
Instance of ClientScriptManager in ClientScript property.
methodName
Type: SystemString
Name of javascript parameter-less method.
request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
Content identification for signing.
statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ClientScriptManager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Within this method is called RegisterSigningClientScriptInclude(ClientScriptManager) for registering common client javascript for use signing.
See Also

Reference

ClientScriptManagerExtension Class
ASDSoft.WebSigner.Server Namespace


ClientScriptManagerExtension.RegisterStartSignatureOnClick Method

ClientScriptManagerExtensionRegisterStartSignatureOnClick Method

Register javascript to onclick event on Button for start signing in application host process.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static void RegisterStartSignatureOnClick(
    this Button button,
    CreateSessionRequest request,
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

button
Type: System.Web.UI.WebControlsButton
Button in Page for start signing.
request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
Content identification for signing.
statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Button. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Within this method is called RegisterSigningClientScriptInclude(ClientScriptManager) for registering common client javascript for use signing.
See Also

Reference

ClientScriptManagerExtension Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification) Class

DocumentSignerBaseTIdentification Class

Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures for documents with typed Identification.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerSignerBase
ASDSoft.WebSigner.ServerSignerBase TIdentification
ASDSoft.WebSigner.ServerDocumentSignerBaseTIdentification

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class DocumentSignerBase<TIdentification> : SignerBase<TIdentification>

Type Parameters

TIdentification
See SignerBaseTIdentification

The DocumentSignerBaseTIdentification type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentSignerBaseTIdentification | Initializes a new instance of the DocumentSignerBaseTIdentification class
Top
Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates. (Inherited from SignerBase.)
Protected method | CreateContentBuilderConfiguration | Create document type specific content builder configuration. For example for PDF document instance of PdfSignerLinkContentBuilderConfiguration class allow configuring visible signature.
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Inherited from SignerBaseTIdentification.)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | See CreateSignatureSession(TIdentification, String) (Overrides SignerBaseTIdentificationCreateSignatureSession(TIdentification, String).)
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Protected method | DeserializeDocumentIdentifications | Deserialize identification object sended from client.
Protected method | GetContent | For implementation of DocumentSignerBaseTIdentification not used. (Overrides SignerBaseGetContent(ContentBase, X509Certificate2).)
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document. (Inherited from SignerBase.)
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName (Inherited from SignerBase.)
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login (Inherited from SignerBase.)
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). (Inherited from SignerBase.)
Protected method | ProcessSigning | Callback for saving created signature. (Inherited from SignerBase.)
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate. (Inherited from SignerBase.)
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate. (Inherited from SignerBase.)
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification) Constructor

DocumentSignerBaseTIdentification Constructor

Initializes a new instance of the DocumentSignerBaseTIdentification class

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected DocumentSignerBase()
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification) Methods

DocumentSignerBaseTIdentification Methods

The DocumentSignerBaseTIdentification generic type exposes the following members.

Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates. (Inherited from SignerBase.)
Protected method | CreateContentBuilderConfiguration | Create document type specific content builder configuration. For example for PDF document instance of PdfSignerLinkContentBuilderConfiguration class allow configuring visible signature.
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Inherited from SignerBaseTIdentification.)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | See CreateSignatureSession(TIdentification, String) (Overrides SignerBaseTIdentificationCreateSignatureSession(TIdentification, String).)
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Protected method | DeserializeDocumentIdentifications | Deserialize identification object sended from client.
Protected method | GetContent | For implementation of DocumentSignerBaseTIdentification not used. (Overrides SignerBaseGetContent(ContentBase, X509Certificate2).)
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document. (Inherited from SignerBase.)
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName (Inherited from SignerBase.)
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login (Inherited from SignerBase.)
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). (Inherited from SignerBase.)
Protected method | ProcessSigning | Callback for saving created signature. (Inherited from SignerBase.)
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate. (Inherited from SignerBase.)
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate. (Inherited from SignerBase.)
Top
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).CreateContentBuilderConfiguration Method

DocumentSignerBaseTIdentificationCreateContentBuilderConfiguration Method

Create document type specific content builder configuration. For example for PDF document instance of PdfSignerLinkContentBuilderConfiguration class allow configuring visible signature.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual DocumentSignerLinkContentBuilderConfiguration CreateContentBuilderConfiguration(
    string category,
    IDocumentSignerConfiguration configuration
)

Parameters

category
Type: SystemString
Signing category name
configuration
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Signer configuration

Return Value

Type: DocumentSignerLinkContentBuilderConfiguration
Configured document content builder configuration. Default implementation return new instance of DocumentSignerLinkContentBuilderConfiguration
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).CreateSignatureSession Method

DocumentSignerBaseTIdentificationCreateSignatureSession Method

Overload List
 | Name | Description
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Inherited from SignerBaseTIdentification.)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | See CreateSignatureSession(TIdentification, String) (Overrides SignerBaseTIdentificationCreateSignatureSession(TIdentification, String).)
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Top
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).CreateSignatureSession Method (TIdentification[], String)

DocumentSignerBaseTIdentificationCreateSignatureSession Method (TIdentification, String)

See CreateSignatureSession(TIdentification, String)

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override Task<SignatureSession> CreateSignatureSession(
    TIdentification[] identifications,
    string category
)

Parameters

identifications
Type: TIdentification
Typed array of deserialized Identification required signing data.
category
Type: SystemString
Name of category configuration from element ASDSoft.WebSigner/SigningCategories

Return Value

Type: Task SignatureSession
Signature session.
See Also

Reference

DocumentSignerBaseTIdentification Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DeserializeDocumentIdentifications Method

DocumentSignerBaseTIdentificationDeserializeDocumentIdentifications Method

Deserialize identification object sended from client.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task<DocumentSignerBaseTIdentificationDocumentIdentification[]> DeserializeDocumentIdentifications(
    TIdentification[] identifications
)

Parameters

identifications
Type: TIdentification
Identification data sended by client

Return Value

Type: Task DocumentSignerBaseTIdentificationDocumentIdentification
Deserialized document identification
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).GetContent Method

DocumentSignerBaseTIdentificationGetContent Method

For implementation of DocumentSignerBaseTIdentification not used.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override Task<Object> GetContent(
    ContentBase content,
    X509Certificate2 certificate
)

Parameters

content
Type: ASDSoft.WebSigner.ContentContentBase

[Missing <param name="content"/> documentation for "M:ASDSoft.WebSigner.Server.DocumentSignerBase`1.GetContent(ASDSoft.WebSigner.Content.ContentBase,System.Security.Cryptography.X509Certificates.X509Certificate2)"]

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2

[Missing <param name="certificate"/> documentation for "M:ASDSoft.WebSigner.Server.DocumentSignerBase`1.GetContent(ASDSoft.WebSigner.Content.ContentBase,System.Security.Cryptography.X509Certificates.X509Certificate2)"]

Return Value

Type: Task Object

[Missing <returns> documentation for "M:ASDSoft.WebSigner.Server.DocumentSignerBase`1.GetContent(ASDSoft.WebSigner.Content.ContentBase,System.Security.Cryptography.X509Certificates.X509Certificate2)"]

Exceptions
Exception | Condition
NotSupportedException |
See Also

Reference

DocumentSignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DocumentIdentification Structure

DocumentSignerBaseTIdentificationDocumentIdentification Structure

[Missing <summary> documentation for "T:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification"]

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected readonly struct DocumentIdentification

The DocumentSignerBaseTIdentificationDocumentIdentification generic type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSignerBaseTIdentificationDocumentIdentification | Initializes a new instance of the DocumentSignerBaseTIdentificationDocumentIdentification class
Top
Properties
 | Name | Description
Public property | DocumentFileExtension |
Public property | DocumentFileFullName |
Public property | DocumentId |
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DocumentIdentification Constructor

DocumentSignerBaseTIdentificationDocumentIdentification Constructor

Initializes a new instance of the DocumentSignerBaseTIdentificationDocumentIdentification class

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentIdentification(
    string documentFileFullName,
    Object documentId
)

Parameters

documentFileFullName
Type: SystemString

[Missing <param name="documentFileFullName"/> documentation for "M:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification.#ctor(System.String,System.Object)"]

documentId
Type: SystemObject

[Missing <param name="documentId"/> documentation for "M:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification.#ctor(System.String,System.Object)"]

See Also

Reference

DocumentSignerBaseTIdentificationDocumentIdentification Structure
ASDSoft.WebSigner.Server Namespace


DocumentIdentification Properties

The DocumentSignerBaseTIdentificationDocumentIdentification type exposes the following members.

Properties
 | Name | Description
Public property | DocumentFileExtension |
Public property | DocumentFileFullName |
Public property | DocumentId |
Top
See Also

Reference

DocumentSignerBaseTIdentificationDocumentIdentification Structure
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DocumentIdentification.DocumentFileExtension Property

DocumentSignerBaseTIdentificationDocumentIdentificationDocumentFileExtension Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification.DocumentFileExtension"]

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string DocumentFileExtension { get; }

Property Value

Type: String
See Also

Reference

DocumentSignerBaseTIdentificationDocumentIdentification Structure
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DocumentIdentification.DocumentFileFullName Property

DocumentSignerBaseTIdentificationDocumentIdentificationDocumentFileFullName Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification.DocumentFileFullName"]

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string DocumentFileFullName { get; }

Property Value

Type: String
See Also

Reference

DocumentSignerBaseTIdentificationDocumentIdentification Structure
ASDSoft.WebSigner.Server Namespace


DocumentSignerBase(TIdentification).DocumentIdentification.DocumentId Property

DocumentSignerBaseTIdentificationDocumentIdentificationDocumentId Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.DocumentSignerBase`1.DocumentIdentification.DocumentId"]

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Object DocumentId { get; }

Property Value

Type: Object
See Also

Reference

DocumentSignerBaseTIdentificationDocumentIdentification Structure
ASDSoft.WebSigner.Server Namespace


ICertificateAuthenticationProvider Interface

Interface for authenticate user to hosted application by certificate signing text.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface ICertificateAuthenticationProvider

The ICertificateAuthenticationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Implementor must authenticate user by certificate in own application authentication mechanizm.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


ICertificateAuthenticationProvider Methods

The ICertificateAuthenticationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Implementor must authenticate user by certificate in own application authentication mechanizm.
Top
See Also

Reference

ICertificateAuthenticationProvider Interface
ASDSoft.WebSigner.Server Namespace


ICertificateAuthenticationProvider.Authenticate Method

ICertificateAuthenticationProviderAuthenticate Method

Implementor must authenticate user by certificate in own application authentication mechanizm.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Task<bool> Authenticate(
    X509Certificate2 certificate,
    SignatureInfo signatureInfo
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Personal certificate used for signing authentication text.
signatureInfo
Type: ASDSoft.WebSigner.ServerSignatureInfo
Information about signing request and response.

Return Value

Type: Task Boolean
True, if authentication is success, otherwise false.
Remarks
If authentication success, implementor must create and store user principal, for example in HttpContext.Current.User. Method called by infrastructure after success signing LoginContent type content.
See Also

Reference

ICertificateAuthenticationProvider Interface
ASDSoft.WebSigner.Server Namespace


PathProvider Class

Provides a URLs for resources signing process.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerPathProvider

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class PathProvider

The PathProvider type exposes the following members.

Properties
Name | Description
HelpUrl | URL for download HTML page with user help document.
InstallerUrl | URL for download installer package according to client OS platform.
JavaScriptUrl | URL for download common javascript for process signing in the browser.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


PathProvider Properties

The PathProvider type exposes the following members.

Properties
Name | Description
HelpUrl | URL for download HTML page with user help document.
InstallerUrl | URL for download installer package according to client OS platform.
JavaScriptUrl | URL for download common javascript for process signing in the browser.
Top
See Also

Reference

PathProvider Class
ASDSoft.WebSigner.Server Namespace


PathProvider.HelpUrl Property

PathProviderHelpUrl Property

URL for download HTML page with user help document.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static Uri HelpUrl { get; }

Property Value

Type: Uri
See Also

Reference

PathProvider Class
ASDSoft.WebSigner.Server Namespace


PathProvider.InstallerUrl Property

PathProviderInstallerUrl Property

URL for download installer package according to client OS platform.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static Uri InstallerUrl { get; }

Property Value

Type: Uri
See Also

Reference

PathProvider Class
ASDSoft.WebSigner.Server Namespace


PathProvider.JavaScriptUrl Property

PathProviderJavaScriptUrl Property

URL for download common javascript for process signing in the browser.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static Uri JavaScriptUrl { get; }

Property Value

Type: Uri
See Also

Reference

PathProvider Class
ASDSoft.WebSigner.Server Namespace


SignatureInfo Class

Information about signed content created in SignatureSession.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureBase
ASDSoft.WebSigner.ServerSignatureInfo

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class SignatureInfo : SignatureBase

The SignatureInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Public property | SignatureRequest | Information about content for signing.
Public property | SignatureResponse | Information about created signature.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


SignatureInfo Properties

The SignatureInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | Unique ID for request and response. (Inherited from SignatureBase.)
Public property | SignatureRequest | Information about content for signing.
Public property | SignatureResponse | Information about created signature.
Top
See Also

Reference

SignatureInfo Class
ASDSoft.WebSigner.Server Namespace


SignatureInfo.SignatureRequest Property

SignatureInfoSignatureRequest Property

Information about content for signing.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureRequest SignatureRequest { get; }

Property Value

Type: SignatureRequest
See Also

Reference

SignatureInfo Class
ASDSoft.WebSigner.Server Namespace


SignatureInfo.SignatureResponse Property

SignatureInfoSignatureResponse Property

Information about created signature.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureResponse SignatureResponse { get; }

Property Value

Type: SignatureResponse
See Also

Reference

SignatureInfo Class
ASDSoft.WebSigner.Server Namespace


SignatureSession Class

The main object for store information about signing contents, created signatures and status (progress) of signing.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSignerSignatureSessionBase
ASDSoft.WebSigner.ServerSignatureSession

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class SignatureSession : SignatureSessionBase

The SignatureSession type exposes the following members.

Properties
 | Name | Description
Public property | SessionId | Unique session ID. (Inherited from SignatureSessionBase.)
Top
Methods
 | Name | Description
Public method | GetClientStartupParams | Return client startup parameters for curent signarture session.
Public method | GetJsonClientStartupParams | Return client startup parameters for curent signarture session in JSON encoding.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


SignatureSession Properties

The SignatureSession type exposes the following members.

Properties
 | Name | Description
Public property | SessionId | Unique session ID. (Inherited from SignatureSessionBase.)
Top
See Also

Reference

SignatureSession Class
ASDSoft.WebSigner.Server Namespace


SignatureSession Methods

The SignatureSession type exposes the following members.

Methods
 | Name | Description
Public method | GetClientStartupParams | Return client startup parameters for curent signarture session.
Public method | GetJsonClientStartupParams | Return client startup parameters for curent signarture session in JSON encoding.
Top
See Also

Reference

SignatureSession Class
ASDSoft.WebSigner.Server Namespace


SignatureSession.GetClientStartupParams Method

SignatureSessionGetClientStartupParams Method

Return client startup parameters for curent signarture session.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public ClientStartupParams GetClientStartupParams(
    Uri host = null
)

Parameters

host (Optional)
Type: SystemUri
Host for override current request host. If null, use current request host.

Return Value

Type: ClientStartupParams
Client startup parameters for a current signature session.
Remarks
This method can be called for prepare run signature in javascript in browser client logic.
See Also

Reference

SignatureSession Class
ASDSoft.WebSigner.Server Namespace


SignatureSession.GetJsonClientStartupParams Method

SignatureSessionGetJsonClientStartupParams Method

Return client startup parameters for curent signarture session in JSON encoding.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string GetJsonClientStartupParams(
    Uri host = null
)

Parameters

host (Optional)
Type: SystemUri
Host for override current request host. If null, use current request host.

Return Value

Type: String
Client startup parameters for a current signature session in JSON encoding.
Remarks
This method can be called for prepare run signature in javascript in browser client logic.
See Also

Reference

SignatureSession Class
ASDSoft.WebSigner.Server Namespace


SignerBase Class

Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerSignerBase
ASDSoft.WebSigner.ServerSignerBaseTIdentification

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class SignerBase

The SignerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SignerBase | Initializes a new instance of the SignerBase class
Top
Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates.
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate.
 | CreateSignatureSession(CreateSessionRequest) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use.
Protected method | GetContent | Callback for obtaining all contents for signing, if not provide during creating of signature context.
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document.
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo).
Protected method | ProcessSigning | Callback for saving created signature.
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate.
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


SignerBase Constructor

Initializes a new instance of the SignerBase class

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignerBase()
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase Methods

The SignerBase type exposes the following members.

Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates.
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate.
 | CreateSignatureSession(CreateSessionRequest) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use.
Protected method | GetContent | Callback for obtaining all contents for signing, if not provide during creating of signature context.
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document.
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo).
Protected method | ProcessSigning | Callback for saving created signature.
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate.
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate.
Top
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.ConfigureX509ChainForValidation Method

SignerBaseConfigureX509ChainForValidation Method

Configure certificate chain for validation accepted certificates.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual void ConfigureX509ChainForValidation(
    X509Chain chain,
    X509Certificate2 certificate,
    SignatureRequest[] signatureRequests
)

Parameters

chain
Type: System.Security.Cryptography.X509CertificatesX509Chain
Certificate chain for configuration.
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate for signing.
signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
Signature requests for signing.
Remarks
This method is called by the infrastructure for filtering accepted certificate and during validation of created signature.

Default implementation is:

Copy
chain.ChainPolicy.RevocationFlag = X509RevocationFlag.EndCertificateOnly;
chain.ChainPolicy.RevocationMode = X509RevocationMode.Online;
chain.ChainPolicy.VerificationFlags = X509VerificationFlags.NoFlag;
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateLoginSignatureSession Method

SignerBaseCreateLoginSignatureSession Method

Create new session for login user by client certificate.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateLoginSignatureSession(
    bool qualifiedCertificateRequired = false
)

Parameters

qualifiedCertificateRequired (Optional)
Type: SystemBoolean
if need filtering user certificates only for qualified certificates. Filtering is doing in method ValidateCertificateQualified(X509Certificate2, SignatureRequest, String).

Return Value

Type: SignatureSession
Signature session with LoginContent
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method

SignerBaseCreateSignatureSession Method

Overload List
 | Name | Description
 | CreateSignatureSession(CreateSessionRequest) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate.
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use.
Top
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (CreateSessionRequest)

SignerBaseCreateSignatureSession Method (CreateSessionRequest)

Create new session for signing customized by host application.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task<SignatureSession> CreateSignatureSession(
    CreateSessionRequest request
)

Parameters

request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
Request with identification required signing data.

Return Value

Type: Task SignatureSession
Signature session.
Remarks
Called from service invoked by client JavaScript method AsdWebSigner.ClientFasade.startSignatureInProcess. Implementation must provide authorization for request!!!
Examples
Steps for create signing process.

  • Obtain data or hash for signing one or more content.

  • Create instance of implementation ContentBase for each signing content.

  • Create instance of SignatureRequest for each signing content.

  • Create instance of SignatureSession with list of SignatureRequest.

C#
Copy
protected override async Task<SignatureSession> CreateSignatureSession(CreateSessionRequest request)
{
    if (request == CreateSessionRequest.Login)
        return CreateLoginSignatureSession();

    switch (request.Category.ToLower())
    {
        case "doc":
            Document[] documents = await new DocumentRepository().GetDocumentsAsync(request.Identification);
            return this.CreateSignatureSession(documents.Select(document => d.CreateSignatureRequestFromDocument(document)).ToArray());
        default:
            throw new ArgumentException($"Unknown category {request.Category}.", nameof(request.Category));
    }
}

private SignatureRequest CreateSignatureRequestFromDocument(Document document)
{
    byte[] documentHash = document.ComputeHash(HashAlgorithmName.SHA256);
    DocumentLinkContent documentLinkContent = new DocumentLinkContent(document.Id, document.Name, documentHash, SignatureType.Hash);
    return new SignatureRequest(documentLinkContent, HashAlgorithmName.SHA256);
}
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (IContentBuilder[])

SignerBaseCreateSignatureSession Method (IContentBuilder)

Create new session for signing in default web application with not required qualified certificate.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateSignatureSession(
    params IContentBuilder[] buildableContents
)

Parameters

buildableContents
Type: ASDSoft.WebSigner.Server.ContentIContentBuilder
One or more buildable contents for signing.

Return Value

Type: SignatureSession
Signature session.
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (SignatureRequest[])

SignerBaseCreateSignatureSession Method (SignatureRequest)

Create new session for signing in default web application with not required qualified certificate.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateSignatureSession(
    params SignatureRequest[] signatureRequests
)

Parameters

signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
One or more signature requests for signing.

Return Value

Type: SignatureSession
Signature session.
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (Boolean, IContentBuilder[])

SignerBaseCreateSignatureSession Method (Boolean, IContentBuilder)

Create new session for signing in default web application.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateSignatureSession(
    bool qualifiedCertificateRequired,
    params IContentBuilder[] buildableContents
)

Parameters

qualifiedCertificateRequired
Type: SystemBoolean
if need filtering user certificates only for qualified certificates. Filtering is doing in method ValidateCertificateQualified(X509Certificate2, SignatureRequest, String).
buildableContents
Type: ASDSoft.WebSigner.Server.ContentIContentBuilder
One or more buildable contents for signing.

Return Value

Type: SignatureSession
Signature session.
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (Boolean, SignatureRequest[])

SignerBaseCreateSignatureSession Method (Boolean, SignatureRequest)

Create new session for signing in default web application.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateSignatureSession(
    bool qualifiedCertificateRequired,
    params SignatureRequest[] signatureRequests
)

Parameters

qualifiedCertificateRequired
Type: SystemBoolean
if need filtering user certificates only for qualified certificates. Filtering is doing in method ValidateCertificateQualified(X509Certificate2, SignatureRequest, String).
signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
One or more signature requests for signing.

Return Value

Type: SignatureSession
Signature session.
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.CreateSignatureSession Method (String, Boolean, SignatureRequest[])

SignerBaseCreateSignatureSession Method (String, Boolean, SignatureRequest)

Create new session for signing in specific web application. Only for internal use.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignatureSession CreateSignatureSession(
    string applicationName,
    bool qualifiedCertificateRequired,
    params SignatureRequest[] signatureRequests
)

Parameters

applicationName
Type: SystemString
Only for internal use.
qualifiedCertificateRequired
Type: SystemBoolean
if need filtering user certificates only for qualified certificates. Filtering is doing in method ValidateCertificateQualified(X509Certificate2, SignatureRequest, String).
signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
One or more signature requests for signing.

Return Value

Type: SignatureSession
Signature session.
See Also

Reference

SignerBase Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase.GetContent Method

SignerBaseGetContent Method

Callback for obtaining all contents for signing, if not provide during creating of signature context.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task<Object> GetContent(
    ContentBase content,
    X509Certificate2 certificate
)

Parameters

content
Type: ASDSoft.WebSigner.ContentContentBase
Content without data.
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate for signing.

Return Value

Type: Task Object
The task for async calling with data content for signing.
Remarks
This method is called by the infrastructure for example when a signed document requires certificate included in signing content. Othervise can implement only NotSupportedException. Implementation must be thread safe, when sign more than one content per session.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.GetDocument Method

SignerBaseGetDocument Method

Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task<DocumentInfo> GetDocument(
    IDocumentLinkContent content
)

Parameters

content
Type: ASDSoft.WebSigner.Server.ContentIDocumentLinkContent
Identification of the document.

Return Value

Type: Task DocumentInfo
The task for async calling with full document.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.GetIdentityName Method

SignerBaseGetIdentityName Method

Note: This API is now obsolete.

This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[ObsoleteAttribute("Use IAuthenticationPersistor instead GetIdentityName",
    true)]
protected string GetIdentityName()

Return Value

Type: String
Throw NotSupportedException.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.Login Method

SignerBaseLogin Method

Note: This API is now obsolete.

This method is no longer used. Use ICertificateAuthenticationProvider instead Login

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[ObsoleteAttribute("Use ICertificateAuthenticationProvider instead Login",
    true)]
protected Task<bool> Login(
    X509Certificate2 certificate
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate used for login.

Return Value

Type: Task Boolean
Throw NotSupportedException.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.OnProcessSigningEnd Method

SignerBaseOnProcessSigningEnd Method

Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo).

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual void OnProcessSigningEnd(
    string sessionId,
    X509Certificate2 certificate,
    SignatureInfo[] signatures
)

Parameters

sessionId
Type: SystemString
Session ID
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate used for signing.
signatures
Type: ASDSoft.WebSigner.ServerSignatureInfo
Information about cretaed signatures.
Remarks
Default implementation is empty.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.ProcessSigning Method

SignerBaseProcessSigning Method

Callback for saving created signature.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task ProcessSigning(
    X509Certificate2 certificate,
    SignatureInfo signatureInfo
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate used for signing.
signatureInfo
Type: ASDSoft.WebSigner.ServerSignatureInfo
Information of created signatures and signed contents.

Return Value

Type: Task
The task for async calling without a return value.
Remarks
Implementation must be thread safe, when sign more than one content per session.
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.ValidateCertificateExtended Method

SignerBaseValidateCertificateExtended Method

Custom filtering of the acceptable certificate.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual bool ValidateCertificateExtended(
    X509Certificate2 certificate,
    SignatureRequest[] signatureRequests,
    out string verificationStatus
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Client certificate for signing.
signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
Signature requests for signing.
verificationStatus
Type: SystemString
Description of validation error, othewise string.Empty. Default implementation return always string.Empty.

Return Value

Type: Boolean
if the certificate is accepted. Default implementation return always .
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase.ValidateQualifiedCertificate Method

SignerBaseValidateQualifiedCertificate Method

Custom filtering of the certificate qualified certificate.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual bool ValidateQualifiedCertificate(
    X509Certificate2 certificate,
    EuTslStatusInfo euTslStatus,
    SignatureRequest[] signatureRequests,
    out string verificationStatus
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Qualified client certificate for signing.
euTslStatus
Type: EuTslStatusInfo
Success result of EU TSL validation.
signatureRequests
Type: ASDSoft.WebSignerSignatureRequest
Signature requests for signing.
verificationStatus
Type: SystemString
Description of validation error, othewise string.Empty. Default implementation return always string.Empty.

Return Value

Type: Boolean
if the certificate is accepted. Default implementation return always .
See Also

Reference

SignerBase Class
ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification) Class

SignerBaseTIdentification Class

Base class for inherited implementation in hosting web application provide methods and callbacks for prepare and save signatures with typed Identification.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerSignerBase
ASDSoft.WebSigner.ServerSignerBaseTIdentification
ASDSoft.WebSigner.ServerDocumentSignerBaseTIdentification

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class SignerBase<TIdentification> : SignerBase

Type Parameters

TIdentification
Target data type for deserialize Identification string. Can by value type, string type or class serializable from JSON.

The SignerBaseTIdentification type exposes the following members.

Constructors
 | Name | Description
Protected method | SignerBaseTIdentification | Initializes a new instance of the SignerBaseTIdentification class
Top
Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates. (Inherited from SignerBase.)
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Overrides SignerBaseCreateSignatureSession(CreateSessionRequest).)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Protected method | GetContent | Callback for obtaining all contents for signing, if not provide during creating of signature context. (Inherited from SignerBase.)
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document. (Inherited from SignerBase.)
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName (Inherited from SignerBase.)
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login (Inherited from SignerBase.)
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). (Inherited from SignerBase.)
Protected method | ProcessSigning | Callback for saving created signature. (Inherited from SignerBase.)
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate. (Inherited from SignerBase.)
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate. (Inherited from SignerBase.)
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification) Constructor

SignerBaseTIdentification Constructor

Initializes a new instance of the SignerBaseTIdentification class

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SignerBase()
See Also

Reference

SignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification) Methods

SignerBaseTIdentification Methods

The SignerBaseTIdentification generic type exposes the following members.

Methods
 | Name | Description
Protected method | ConfigureX509ChainForValidation | Configure certificate chain for validation accepted certificates. (Inherited from SignerBase.)
Protected method | CreateLoginSignatureSession | Create new session for login user by client certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Overrides SignerBaseCreateSignatureSession(CreateSessionRequest).)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Protected method | GetContent | Callback for obtaining all contents for signing, if not provide during creating of signature context. (Inherited from SignerBase.)
Protected method | GetDocument | Callback for obtaining the full document for showing or downloading in browser based on a user request for showing the document. (Inherited from SignerBase.)
Protected method | GetIdentityName | Obsolete. This method is no longer used. Use IAuthenticationPersistor instead GetIdentityName (Inherited from SignerBase.)
Protected method | Login | Obsolete. This method is no longer used. Use ICertificateAuthenticationProvider instead Login (Inherited from SignerBase.)
Protected method | OnProcessSigningEnd | Called when all signatures in session processed by ProcessSigning(X509Certificate2, SignatureInfo). (Inherited from SignerBase.)
Protected method | ProcessSigning | Callback for saving created signature. (Inherited from SignerBase.)
Protected method | ValidateCertificateExtended | Custom filtering of the acceptable certificate. (Inherited from SignerBase.)
Protected method | ValidateQualifiedCertificate | Custom filtering of the certificate qualified certificate. (Inherited from SignerBase.)
Top
See Also

Reference

SignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification).CreateSignatureSession Method

SignerBaseTIdentificationCreateSignatureSession Method

Overload List
 | Name | Description
Protected method | CreateSignatureSession(CreateSessionRequest) | See CreateSignatureSession(CreateSessionRequest) (Overrides SignerBaseCreateSignatureSession(CreateSessionRequest).)
Protected method | CreateSignatureSession(IContentBuilder) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(SignatureRequest) | Create new session for signing in default web application with not required qualified certificate. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, IContentBuilder) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(Boolean, SignatureRequest) | Create new session for signing in default web application. (Inherited from SignerBase.)
Protected method | CreateSignatureSession(TIdentification, String) | Create new session for signing customized by host application.
Protected method | CreateSignatureSession(String, Boolean, SignatureRequest) | Create new session for signing in specific web application. Only for internal use. (Inherited from SignerBase.)
Top
See Also

Reference

SignerBaseTIdentification Class
ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification).CreateSignatureSession Method (CreateSessionRequest)

SignerBaseTIdentificationCreateSignatureSession Method (CreateSessionRequest)

See CreateSignatureSession(CreateSessionRequest)

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override Task<SignatureSession> CreateSignatureSession(
    CreateSessionRequest request
)

Parameters

request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest

[Missing <param name="request"/> documentation for "M:ASDSoft.WebSigner.Server.SignerBase`1.CreateSignatureSession(ASDSoft.WebSigner.Server.Browser.CreateSessionRequest)"]

Return Value

Type: Task SignatureSession

[Missing <returns> documentation for "M:ASDSoft.WebSigner.Server.SignerBase`1.CreateSignatureSession(ASDSoft.WebSigner.Server.Browser.CreateSessionRequest)"]

See Also

Reference

SignerBaseTIdentification Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


SignerBase(TIdentification).CreateSignatureSession Method (TIdentification[], String)

SignerBaseTIdentificationCreateSignatureSession Method (TIdentification, String)

Create new session for signing customized by host application.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Task<SignatureSession> CreateSignatureSession(
    TIdentification[] identifications,
    string category
)

Parameters

identifications
Type: TIdentification
Typed array of deserialized Identification required signing data.
category
Type: SystemString
See Category

Return Value

Type: Task SignatureSession
Signature session.
Remarks
Called from service invoked by client JavaScript method AsdWebSigner.ClientFasade.startSignatureInProcess. Implementation must provide authorization for request!!!
See Also

Reference

SignerBaseTIdentification Class
CreateSignatureSession Overload
ASDSoft.WebSigner.Server Namespace


Startup(TStartupSettings) Class

StartupTStartupSettings Class

Base class for implementation of configuration WebSigner module during initializing web application in platform specific.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerStartupTStartupSettings
ASDSoft.WebSigner.Server.AspNetStartup

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class Startup<TStartupSettings>
where TStartupSettings : StartupSettingsBase

Type Parameters

TStartupSettings
Type of settings.

The StartupTStartupSettings type exposes the following members.

Constructors
 | Name | Description
Protected method | StartupTStartupSettings | Initializes a new instance of the StartupTStartupSettings class
Top
Methods
 | Name | Description
Public method | Initialize | Only for internal use.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


Startup(TStartupSettings) Constructor

StartupTStartupSettings Constructor

Initializes a new instance of the StartupTStartupSettings class

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected Startup()
See Also

Reference

StartupTStartupSettings Class
ASDSoft.WebSigner.Server Namespace


Startup(TStartupSettings) Methods

StartupTStartupSettings Methods

The StartupTStartupSettings generic type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Only for internal use.
Top
See Also

Reference

StartupTStartupSettings Class
ASDSoft.WebSigner.Server Namespace


Startup(TStartupSettings).Initialize Method

StartupTStartupSettingsInitialize Method

Only for internal use.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public virtual void Initialize(
    TStartupSettings settings,
    SignerBase signer,
    ISignResultPersistor signResultPersistor = null
)

Parameters

settings
Type: TStartupSettings
Information for configuration WebSigner module during initializing web application.
signer
Type: ASDSoft.WebSigner.ServerSignerBase
Instance of implementation SignerBase
signResultPersistor (Optional)
Type: ASDSoft.WebSigner.Server.Api.CacheISignResultPersistor
Instance of implementation ISignResultPersistor for pesrsist result for API interface calling.
See Also

Reference

StartupTStartupSettings Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Class

Information for configuration WebSigner module during initializing web application.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerStartupSettingsBase
ASDSoft.WebSigner.Server.AspNetStartupSettings
ASDSoft.WebSigner.Server.AspNetCoreStartupSettings

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class StartupSettingsBase

The StartupSettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | StartupSettingsBase(IApiApplicationConfiguration) | Constructor for setting applications used by REST API.
Protected method | StartupSettingsBase(String, Byte) | Constructor for setting default application
Protected method | StartupSettingsBase(IApiApplicationConfiguration, String, Byte) | Constructor for combine settings of default application and applications used by REST API.
Top
Properties
 | Name | Description
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it.
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing.
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo)
Public property | HelpCssUrl | Custom CSS style for the help page.
Top
See Also

Reference

ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Constructor

Overload List
 | Name | Description
Protected method | StartupSettingsBase(IApiApplicationConfiguration) | Constructor for setting applications used by REST API.
Protected method | StartupSettingsBase(String, Byte) | Constructor for setting default application
Protected method | StartupSettingsBase(IApiApplicationConfiguration, String, Byte) | Constructor for combine settings of default application and applications used by REST API.
Top
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Constructor (IApiApplicationConfiguration[])

StartupSettingsBase Constructor (IApiApplicationConfiguration)

Constructor for setting applications used by REST API.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected StartupSettingsBase(
    IApiApplicationConfiguration[] apiApplications
)

Parameters

apiApplications
Type: ASDSoft.WebSigner.Server.Api.ConfigurationIApiApplicationConfiguration
Avaible applications.
See Also

Reference

StartupSettingsBase Class
StartupSettingsBase Overload
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Constructor (String, Byte[])

StartupSettingsBase Constructor (String, Byte)

Constructor for setting default application

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected StartupSettingsBase(
    string applicationName,
    byte[] logoBitmap = null
)

Parameters

applicationName
Type: SystemString
Name of application that is displayed in client window for selecting a certificate.
logoBitmap (Optional)
Type: SystemByte
Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate.
Remarks
Ideal height is 35px because logo no need resize.

Default is ASD logo, if this property is set to . For hide logo (no logo) set this property to empty byte array new byte[0].

See Also

Reference

StartupSettingsBase Class
StartupSettingsBase Overload
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Constructor (IApiApplicationConfiguration[], String, Byte[])

StartupSettingsBase Constructor (IApiApplicationConfiguration, String, Byte)

Constructor for combine settings of default application and applications used by REST API.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected StartupSettingsBase(
    IApiApplicationConfiguration[] apiApplications,
    string applicationName,
    byte[] logoBitmap = null
)

Parameters

apiApplications
Type: ASDSoft.WebSigner.Server.Api.ConfigurationIApiApplicationConfiguration
Avaible REST API applications.
applicationName
Type: SystemString
Name of default application that is displayed in client window for selecting a certificate.
logoBitmap (Optional)
Type: SystemByte
Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate in default application.
See Also

Reference

StartupSettingsBase Class
StartupSettingsBase Overload
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase Properties

The StartupSettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it.
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing.
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo)
Public property | HelpCssUrl | Custom CSS style for the help page.
Top
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase.AuthenticationPersistor Property

StartupSettingsBaseAuthenticationPersistor Property

Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IAuthenticationPersistor AuthenticationPersistor { get; set; }

Property Value

Type: IAuthenticationPersistor
Remarks
If not specified (is null), use default implementation, see description of GetCurrentUserIdentification and RestoreUser(String).
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase.CachePersistor Property

StartupSettingsBaseCachePersistor Property

Custom implementation of cache persistor for store SignatureSession during process signing.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public CachePersistorBase CachePersistor { get; set; }

Property Value

Type: CachePersistorBase
Remarks
Default implementation is FileCachePersistor, if this property is set to . Another prepared implementations are MemoryCachePersistor and ClusterFileCachePersistor. For custom implementation of own cache persistor you can inherit from SerializedCachePersistorBase too.
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase.CertificateAuthenticationProvider Property

StartupSettingsBaseCertificateAuthenticationProvider Property

Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo)

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public ICertificateAuthenticationProvider CertificateAuthenticationProvider { get; set; }

Property Value

Type: ICertificateAuthenticationProvider
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


StartupSettingsBase.HelpCssUrl Property

StartupSettingsBaseHelpCssUrl Property

Custom CSS style for the help page.

Namespace: ASDSoft.WebSigner.Server
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string HelpCssUrl { get; set; }

Property Value

Type: String
Remarks
Default style if this property is set to .
CSS
Copy
body {
    font-family: "Trebuchet MS", Arial, Helvetica, sans-serif;
    font-size: small;
    margin: 0 1em;
    padding: 0 1em;
}
h1 {
    color: #004289;
    margin-bottom: 5px;
}
h2 {
    color: #004289;
    margin-bottom: 5px;
    margin-top: 1em;
}
h3 {
    margin-top: 5px;
    margin-bottom: 1px;
}
p {
    padding-top: 0;
    margin-top: 0;
    margin-bottom: 5px;
}
ol, ul {
    margin-top: 5px;
}
See Also

Reference

StartupSettingsBase Class
ASDSoft.WebSigner.Server Namespace


ASDSoft.WebSigner.Server.Api Namespace

Communication objects for API services.
Classes
 | Class | Description
Public class | DocumentSigningInfo | Configuration for signing document.
Public class | SignRequest | Information for creating signature session.
Public class | SignRequestItem | Signing definitions and content for signing.
Public class | SignResult | Result data of signing process.
Public class | SignResultItem | Result data of signing process item.


DocumentSigningInfo Class

Configuration for signing document.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ApiDocumentSigningInfo

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public sealed class DocumentSigningInfo : IContentBuilderConfiguration

The DocumentSigningInfo type exposes the following members.

Properties
Name | Description
AdesLevelName | PAdES/XAdES/CAdES level for signature. Valid values are None, Base, LtvOcsp.
TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api Namespace


DocumentSigningInfo Properties

The DocumentSigningInfo type exposes the following members.

Properties
Name | Description
AdesLevelName | PAdES/XAdES/CAdES level for signature. Valid values are None, Base, LtvOcsp.
TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
See Also

Reference

DocumentSigningInfo Class
ASDSoft.WebSigner.Server.Api Namespace


DocumentSigningInfo.AdesLevelName Property

DocumentSigningInfoAdesLevelName Property

PAdES/XAdES/CAdES level for signature. Valid values are None, Base, LtvOcsp.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "adesLevelName")]
public string AdesLevelName { get; set; }

Property Value

Type: String

Implements

IContentBuilderConfigurationAdesLevelName
Examples
None
See Also

Reference

DocumentSigningInfo Class
ASDSoft.WebSigner.Server.Api Namespace


DocumentSigningInfo.TSAName Property

DocumentSigningInfoTSAName Property

The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "tsaName")]
public string TSAName { get; set; }

Property Value

Type: String

Implements

IContentBuilderConfigurationTSAName
Examples
DigiCert
See Also

Reference

DocumentSigningInfo Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequest Class

Information for creating signature session.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.BrowserClientStartupParamsBase
ASDSoft.WebSigner.Server.ApiSignRequest

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public sealed class SignRequest : ClientStartupParamsBase

The SignRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SignRequest | Initializes a new instance of the SignRequest class
Top
Properties
 | Name | Description
 | CultureInfo | Current user language. (Inherited from ClientStartupParamsBase.)
Public property | Items | Requests data for signing.
Public property | QualifiedCertificateRequired | Set true, if using qualified certificate required.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api Namespace


SignRequest Constructor

Initializes a new instance of the SignRequest class

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignRequest()
See Also

Reference

SignRequest Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequest Properties

The SignRequest type exposes the following members.

Properties
 | Name | Description
 | CultureInfo | Current user language. (Inherited from ClientStartupParamsBase.)
Public property | Items | Requests data for signing.
Public property | QualifiedCertificateRequired | Set true, if using qualified certificate required.
Top
See Also

Reference

SignRequest Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequest.Items Property

SignRequestItems Property

Requests data for signing.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "items")]
[RequiredAttribute]
public SignRequestItem[] Items { get; set; }

Property Value

Type: SignRequestItem
See Also

Reference

SignRequest Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequest.QualifiedCertificateRequired Property

SignRequestQualifiedCertificateRequired Property

Set true, if using qualified certificate required.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "qualifiedCertificateRequired")]
public bool QualifiedCertificateRequired { get; set; }

Property Value

Type: Boolean
See Also

Reference

SignRequest Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem Class

Signing definitions and content for signing.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ApiSignRequestItem

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public sealed class SignRequestItem

The SignRequestItem type exposes the following members.

Constructors
 | Name | Description
Public method | SignRequestItem | Initializes a new instance of the SignRequestItem class
Top
Properties
 | Name | Description
 | ApplicationContentId | Unique application ID of content.
 | Content | Content for signing encoded to text presentation.
 | ContentType | Content type (e.g. Text, Hash-Base64, BinaryData-Base64, Pdf-Base64, Xml-Base64, ...). Use API method GetSupportedContentTypes for getting possible values.
Public property | DocumentSigning | Configuration for signing content of type document.
 | HashAlgorithm | Hash algorithm name used for signing.
 | Title | Content title for display in client window for selecting a certificate
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem Constructor

Initializes a new instance of the SignRequestItem class

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignRequestItem()
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem Properties

The SignRequestItem type exposes the following members.

Properties
 | Name | Description
 | ApplicationContentId | Unique application ID of content.
 | Content | Content for signing encoded to text presentation.
 | ContentType | Content type (e.g. Text, Hash-Base64, BinaryData-Base64, Pdf-Base64, Xml-Base64, ...). Use API method GetSupportedContentTypes for getting possible values.
Public property | DocumentSigning | Configuration for signing content of type document.
 | HashAlgorithm | Hash algorithm name used for signing.
 | Title | Content title for display in client window for selecting a certificate
Top
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.ApplicationContentId Property

SignRequestItemApplicationContentId Property

Unique application ID of content.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "applicationContentId")]
[RequiredAttribute]
public string ApplicationContentId { get; set; }

Property Value

Type: String
Examples
12345
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.Content Property

SignRequestItemContent Property

Content for signing encoded to text presentation.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "content")]
[RequiredAttribute]
public string Content { get; set; }

Property Value

Type: String
Examples
Text for signing
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.ContentType Property

SignRequestItemContentType Property

Content type (e.g. Text, Hash-Base64, BinaryData-Base64, Pdf-Base64, Xml-Base64, ...). Use API method GetSupportedContentTypes for getting possible values.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "contentType")]
[RequiredAttribute]
public string ContentType { get; set; }

Property Value

Type: String
Examples
Text
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.DocumentSigning Property

SignRequestItemDocumentSigning Property

Configuration for signing content of type document.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "documentSigning")]
public DocumentSigningInfo DocumentSigning { get; set; }

Property Value

Type: DocumentSigningInfo
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.HashAlgorithm Property

SignRequestItemHashAlgorithm Property

Hash algorithm name used for signing.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "hashAlgorithm")]
[RequiredAttribute]
public string HashAlgorithm { get; set; }

Property Value

Type: String
Examples
SHA256
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignRequestItem.Title Property

SignRequestItemTitle Property

Content title for display in client window for selecting a certificate

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "title")]
public string Title { get; set; }

Property Value

Type: String
Examples
Text for signing showed in client window, for example file name.
See Also

Reference

SignRequestItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignResult Class

Result data of signing process.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ApiSignResult

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
public sealed class SignResult

The SignResult type exposes the following members.

Constructors
 | Name | Description
Public method | SignResult | Only for internal use from ApiHost.
Top
Properties
 | Name | Description
Public property | Items | Result data of signing process item.
Public property | X509Certificate | Base64 encoded client certificate used for signing.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api Namespace


SignResult Constructor

Only for internal use from ApiHost.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignResult(
    X509Certificate2 certificate,
    SignatureInfo[] signatures
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
X509 client certificate used for signing.
signatures
Type: ASDSoft.WebSigner.ServerSignatureInfo
Result data of signing process item.
See Also

Reference

SignResult Class
ASDSoft.WebSigner.Server.Api Namespace


SignResult Properties

The SignResult type exposes the following members.

Properties
 | Name | Description
Public property | Items | Result data of signing process item.
Public property | X509Certificate | Base64 encoded client certificate used for signing.
Top
See Also

Reference

SignResult Class
ASDSoft.WebSigner.Server.Api Namespace


SignResult.Items Property

SignResultItems Property

Result data of signing process item.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "items")]
[RequiredAttribute]
public SignResultItem[] Items { get; }

Property Value

Type: SignResultItem
See Also

Reference

SignResult Class
ASDSoft.WebSigner.Server.Api Namespace


SignResult.X509Certificate Property

SignResultX509Certificate Property

Base64 encoded client certificate used for signing.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "x509Certificate")]
[RequiredAttribute]
public string X509Certificate { get; }

Property Value

Type: String
See Also

Reference

SignResult Class
ASDSoft.WebSigner.Server.Api Namespace


SignResultItem Class

Result data of signing process item.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ApiSignResultItem

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
[DataContractAttribute]
public sealed class SignResultItem

The SignResultItem type exposes the following members.

Properties
 | Name | Description
 | ApplicationContentId | Unique application ID of signed content.
Public property | Signature | Base64 encoded RSA signature.
Public property | SignedDocument | Base64 encoded binarz data of signed document, if request content has document such as PDF, XML, .... Otherwise null/empty.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api Namespace


SignResultItem Properties

The SignResultItem type exposes the following members.

Properties
 | Name | Description
 | ApplicationContentId | Unique application ID of signed content.
Public property | Signature | Base64 encoded RSA signature.
Public property | SignedDocument | Base64 encoded binarz data of signed document, if request content has document such as PDF, XML, .... Otherwise null/empty.
Top
See Also

Reference

SignResultItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignResultItem.ApplicationContentId Property

SignResultItemApplicationContentId Property

Unique application ID of signed content.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "applicationContentId")]
[RequiredAttribute]
public string ApplicationContentId { get; }

Property Value

Type: String
Examples
12345
See Also

Reference

SignResultItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignResultItem.Signature Property

SignResultItemSignature Property

Base64 encoded RSA signature.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "signature")]
[RequiredAttribute]
public string Signature { get; }

Property Value

Type: String
See Also

Reference

SignResultItem Class
ASDSoft.WebSigner.Server.Api Namespace


SignResultItem.SignedDocument Property

SignResultItemSignedDocument Property

Base64 encoded binarz data of signed document, if request content has document such as PDF, XML, .... Otherwise null/empty.

Namespace: ASDSoft.WebSigner.Server.Api
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "signedDocument")]
public string SignedDocument { get; }

Property Value

Type: String
See Also

Reference

SignResultItem Class
ASDSoft.WebSigner.Server.Api Namespace


ASDSoft.WebSigner.Server.Api.Cache Namespace

[Missing <summary> documentation for "N:ASDSoft.WebSigner.Server.Api.Cache"]

Classes
 | Class | Description
Public class | FileSignResultPersistor | Implementation for store result in file system.
Interfaces
 | Interface | Description
Public interface | ISignResultPersistor | Interface for imeplementation of store SignResult


FileSignResultPersistor Class

Implementation for store result in file system.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.Api.CacheFileSignResultPersistor

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public sealed class FileSignResultPersistor : ISignResultPersistor

The FileSignResultPersistor type exposes the following members.

Constructors
 | Name | Description
Public method | FileSignResultPersistor | Default costructor for store results in default temp folder
Public method | FileSignResultPersistor(DirectoryInfo) | Constructor for change default folder for store results.
Top
Methods
 | Name | Description
Public method | Add |
Public method | Remove |
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor Constructor

Overload List
 | Name | Description
Public method | FileSignResultPersistor | Default costructor for store results in default temp folder
Public method | FileSignResultPersistor(DirectoryInfo) | Constructor for change default folder for store results.
Top
See Also

Reference

FileSignResultPersistor Class
ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor Constructor

Default costructor for store results in default temp folder

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public FileSignResultPersistor()
See Also

Reference

FileSignResultPersistor Class
FileSignResultPersistor Overload
ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor Constructor (DirectoryInfo)

Constructor for change default folder for store results.

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public FileSignResultPersistor(
    DirectoryInfo cacheFolder
)

Parameters

cacheFolder
Type: System.IODirectoryInfo
Folder for store.
See Also

Reference

FileSignResultPersistor Class
FileSignResultPersistor Overload
ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor Methods

The FileSignResultPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Remove |
Top
See Also

Reference

FileSignResultPersistor Class
ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor.Add Method

FileSignResultPersistorAdd Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Add(System.String,ASDSoft.WebSigner.Server.Api.SignResult)"]

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public void Add(
    string sessionId,
    SignResult signResult
)

Parameters

sessionId
Type: SystemString

[Missing <param name="sessionId"/> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Add(System.String,ASDSoft.WebSigner.Server.Api.SignResult)"]

signResult
Type: ASDSoft.WebSigner.Server.ApiSignResult

[Missing <param name="signResult"/> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Add(System.String,ASDSoft.WebSigner.Server.Api.SignResult)"]

Implements

ISignResultPersistorAdd(String, SignResult)
See Also

Reference

FileSignResultPersistor Class
ASDSoft.WebSigner.Server.Api.Cache Namespace


FileSignResultPersistor.Remove Method

FileSignResultPersistorRemove Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Remove(System.String)"]

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignResult Remove(
    string sessionId
)

Parameters

sessionId
Type: SystemString

[Missing <param name="sessionId"/> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Remove(System.String)"]

Return Value

Type: SignResult

[Missing <returns> documentation for "M:ASDSoft.WebSigner.Server.Api.Cache.FileSignResultPersistor.Remove(System.String)"]

Implements

ISignResultPersistorRemove(String)
See Also

Reference

FileSignResultPersistor Class
ASDSoft.WebSigner.Server.Api.Cache Namespace


ISignResultPersistor Interface

Interface for imeplementation of store SignResult

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface ISignResultPersistor

The ISignResultPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add new sign result of ended signature session to store.
Public method | Remove | Get and remove sign result for ended signature session
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api.Cache Namespace


ISignResultPersistor Methods

The ISignResultPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add new sign result of ended signature session to store.
Public method | Remove | Get and remove sign result for ended signature session
Top
See Also

Reference

ISignResultPersistor Interface
ASDSoft.WebSigner.Server.Api.Cache Namespace


ISignResultPersistor.Add Method

ISignResultPersistorAdd Method

Add new sign result of ended signature session to store.

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void Add(
    string sessionId,
    SignResult signResult
)

Parameters

sessionId
Type: SystemString
Session ID
signResult
Type: ASDSoft.WebSigner.Server.ApiSignResult
Sign result
See Also

Reference

ISignResultPersistor Interface
ASDSoft.WebSigner.Server.Api.Cache Namespace


ISignResultPersistor.Remove Method

ISignResultPersistorRemove Method

Get and remove sign result for ended signature session

Namespace: ASDSoft.WebSigner.Server.Api.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
SignResult Remove(
    string sessionId
)

Parameters

sessionId
Type: SystemString
Session ID of ended signature session.

Return Value

Type: SignResult
Sign result. Null if sessionId not found.
See Also

Reference

ISignResultPersistor Interface
ASDSoft.WebSigner.Server.Api.Cache Namespace


ASDSoft.WebSigner.Server.Api.Configuration Namespace

[Missing <summary> documentation for "N:ASDSoft.WebSigner.Server.Api.Configuration"]

Interfaces
 | Interface | Description
Public interface | IApiApplicationConfiguration | Only for internal use.


IApiApplicationConfiguration Interface

Only for internal use.

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IApiApplicationConfiguration

The IApiApplicationConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AppHost | Calling application server host (protocol+domain) for allow CORS, if WebSigner API using different host than calling application.
Public property | AuthToken | Authentication token for identified application.
Public property | LogoBitmap | Specific logo. See ASDSoft.WebSigner.Server.AspNet.StartupSettings.LogoBitmap
Public property | Name | Unique name of application.
Public property | WebSignerHost | Target WebSigner API server host (protocol+domain) used from client/browser, if diferent than host used for calling ApiController.CreateSignatureSession.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration Properties

The IApiApplicationConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AppHost | Calling application server host (protocol+domain) for allow CORS, if WebSigner API using different host than calling application.
Public property | AuthToken | Authentication token for identified application.
Public property | LogoBitmap | Specific logo. See ASDSoft.WebSigner.Server.AspNet.StartupSettings.LogoBitmap
Public property | Name | Unique name of application.
Public property | WebSignerHost | Target WebSigner API server host (protocol+domain) used from client/browser, if diferent than host used for calling ApiController.CreateSignatureSession.
Top
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration.AppHost Property

IApiApplicationConfigurationAppHost Property

Calling application server host (protocol+domain) for allow CORS, if WebSigner API using different host than calling application.

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string AppHost { get; }

Property Value

Type: String
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration.AuthToken Property

IApiApplicationConfigurationAuthToken Property

Authentication token for identified application.

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string AuthToken { get; }

Property Value

Type: String
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration.LogoBitmap Property

IApiApplicationConfigurationLogoBitmap Property

Specific logo. See ASDSoft.WebSigner.Server.AspNet.StartupSettings.LogoBitmap

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
byte[] LogoBitmap { get; }

Property Value

Type: Byte
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration.Name Property

IApiApplicationConfigurationName Property

Unique name of application.

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


IApiApplicationConfiguration.WebSignerHost Property

IApiApplicationConfigurationWebSignerHost Property

Target WebSigner API server host (protocol+domain) used from client/browser, if diferent than host used for calling ApiController.CreateSignatureSession.

Namespace: ASDSoft.WebSigner.Server.Api.Configuration
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string WebSignerHost { get; }

Property Value

Type: String
See Also

Reference

IApiApplicationConfiguration Interface
ASDSoft.WebSigner.Server.Api.Configuration Namespace


ASDSoft.WebSigner.Server.AspNet Namespace

Specific implementation for .NET Framework ASP.NET WebForms and MVC.
Classes
 | Class | Description
Public class | Startup | Main class for configuration WebSigner module during initializing web application.
Public class | StartupSettings | Extended information for configuration WebSigner module during initializing web application in .NET Framework ASP.NET WebForms or MVC.


Startup Class

Main class for configuration WebSigner module during initializing web application.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerStartup StartupSettings
ASDSoft.WebSigner.Server.AspNetStartup

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public sealed class Startup : Startup<StartupSettings>

The Startup type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Only for internal use. (Overrides StartupTStartupSettingsInitialize(TStartupSettings, SignerBase, ISignResultPersistor).)
 | InitializeStatic | Main method for configuration WebSigner module during initializing web application.
Top
Remarks
For initializing call static method InitializeStatic(StartupSettings).
See Also

Reference

ASDSoft.WebSigner.Server.AspNet Namespace


Startup Methods

The Startup type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Only for internal use. (Overrides StartupTStartupSettingsInitialize(TStartupSettings, SignerBase, ISignResultPersistor).)
 | InitializeStatic | Main method for configuration WebSigner module during initializing web application.
Top
See Also

Reference

Startup Class
ASDSoft.WebSigner.Server.AspNet Namespace


Startup.Initialize Method

StartupInitialize Method

Only for internal use.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override void Initialize(
    StartupSettings settings,
    SignerBase signer,
    ISignResultPersistor signResultPersistor = null
)

Parameters

settings
Type: ASDSoft.WebSigner.Server.AspNetStartupSettings
Information for configuration WebSigner module during initializing web application.
signer
Type: ASDSoft.WebSigner.ServerSignerBase
Instance of implementation SignerBase
signResultPersistor (Optional)
Type: ASDSoft.WebSigner.Server.Api.CacheISignResultPersistor
Instance of implementation ISignResultPersistor
See Also

Reference

Startup Class
ASDSoft.WebSigner.Server.AspNet Namespace


Startup.InitializeStatic Method

StartupInitializeStatic Method

Main method for configuration WebSigner module during initializing web application.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static void InitializeStatic(
    StartupSettings settings
)

Parameters

settings
Type: ASDSoft.WebSigner.Server.AspNetStartupSettings
Information for configuration WebSigner module during initializing web application.
Remarks
During startup web application you must call this method for configuration WebSigner module during initializing web application, for example in Global.asax in Application_Start method of HttpApplication).
See Also

Reference

Startup Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings Class

Extended information for configuration WebSigner module during initializing web application in .NET Framework ASP.NET WebForms or MVC.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerStartupSettingsBase
ASDSoft.WebSigner.Server.AspNetStartupSettings

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class StartupSettings : StartupSettingsBase

The StartupSettings type exposes the following members.

Constructors
 | Name | Description
Public method | StartupSettings | Base constructor.
Top
Properties
 | Name | Description
Public property | ApiControllerExceptionCallback |
Public property | ApplicationName | Name of application that is displayed in client window for selecting a certificate.
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it. (Inherited from StartupSettingsBase.)
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing. (Inherited from StartupSettingsBase.)
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo) (Inherited from StartupSettingsBase.)
Public property | GlobalConfigurationCallback | Custom delegate for configure host web application by method Configure(ActionHttpConfiguration).
Public property | HelpCssUrl | Custom CSS style for the help page. (Inherited from StartupSettingsBase.)
Public property | LogoBitmap | Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate.
Public property | Signer | Host application implementation for callback functions.
Top
See Also

Reference

ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings Constructor

Base constructor.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public StartupSettings(
    string applicationName,
    SignerBase signer
)

Parameters

applicationName
Type: SystemString
Name of application that is displayed in client window for selecting a certificate.
signer
Type: ASDSoft.WebSigner.ServerSignerBase
Host application implementation for callback functions.
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings Properties

The StartupSettings type exposes the following members.

Properties
 | Name | Description
Public property | ApiControllerExceptionCallback |
Public property | ApplicationName | Name of application that is displayed in client window for selecting a certificate.
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it. (Inherited from StartupSettingsBase.)
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing. (Inherited from StartupSettingsBase.)
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo) (Inherited from StartupSettingsBase.)
Public property | GlobalConfigurationCallback | Custom delegate for configure host web application by method Configure(ActionHttpConfiguration).
Public property | HelpCssUrl | Custom CSS style for the help page. (Inherited from StartupSettingsBase.)
Public property | LogoBitmap | Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate.
Public property | Signer | Host application implementation for callback functions.
Top
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings.ApiControllerExceptionCallback Property

StartupSettingsApiControllerExceptionCallback Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.AspNet.StartupSettings.ApiControllerExceptionCallback"]

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Action<HttpActionExecutedContext> ApiControllerExceptionCallback { get; set; }

Property Value

Type: Action HttpActionExecutedContext
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings.ApplicationName Property

StartupSettingsApplicationName Property

Name of application that is displayed in client window for selecting a certificate.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string ApplicationName { get; }

Property Value

Type: String
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings.GlobalConfigurationCallback Property

StartupSettingsGlobalConfigurationCallback Property

Custom delegate for configure host web application by method Configure(ActionHttpConfiguration).

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Action<HttpConfiguration> GlobalConfigurationCallback { get; set; }

Property Value

Type: Action HttpConfiguration
Remarks
If host application has own configuration, than set delegate for calling Configure(ActionHttpConfiguration) to this property instead direct call method Configure(ActionHttpConfiguration).
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings.LogoBitmap Property

StartupSettingsLogoBitmap Property

Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public byte[] LogoBitmap { get; set; }

Property Value

Type: Byte
Remarks
Ideal height is 35px because logo no need resize.

Default is ASD logo, if this property is set to . For hide logo (no logo) set this property to empty byte array new byte[0].

See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


StartupSettings.Signer Property

StartupSettingsSigner Property

Host application implementation for callback functions.

Namespace: ASDSoft.WebSigner.Server.AspNet
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignerBase Signer { get; }

Property Value

Type: SignerBase
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNet Namespace


ASDSoft.WebSigner.Server.AspNetCore Namespace

Specific implementation for ASP.NET Core Web Applications.
Classes
 | Class | Description
Public class | AsdWebSignerHtmlHelper | Helper for register required signing client javascript to page in ASP.NET Core.
Public class | HtmlHelperExtensions | Extension for providing instance of AsdWebSignerHtmlHelper in IHtmlHelper in page.
Public class | StartupSettings | Extended information for configuration WebSigner module during initializing web application in ASP.NET Core.


AsdWebSignerHtmlHelper Class

Helper for register required signing client javascript to page in ASP.NET Core.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.AspNetCoreAsdWebSignerHtmlHelper

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class AsdWebSignerHtmlHelper

The AsdWebSignerHtmlHelper type exposes the following members.

Constructors
 | Name | Description
Public method | AsdWebSignerHtmlHelper | Initializes a new instance of the AsdWebSignerHtmlHelper class
Top
Methods
 | Name | Description
Public method | RegisterSigningClientScriptInclude | Register common client javascript to page for use signing in ASP.NET Core page on client side.
Public method | RegisterStartLoginOnClick | Register javascript to onclick event on Button for start login by certificate in application host process.
Public method | RegisterStartSignatureMethod | Return call javascript method for start signing in application host process.
Public method | RegisterStartSignatureOnClick | Register javascript to onclick event on Button for start signing in application host process.
Top
See Also

Reference

ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper Constructor

Initializes a new instance of the AsdWebSignerHtmlHelper class

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public AsdWebSignerHtmlHelper()
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper Methods

The AsdWebSignerHtmlHelper type exposes the following members.

Methods
 | Name | Description
Public method | RegisterSigningClientScriptInclude | Register common client javascript to page for use signing in ASP.NET Core page on client side.
Public method | RegisterStartLoginOnClick | Register javascript to onclick event on Button for start login by certificate in application host process.
Public method | RegisterStartSignatureMethod | Return call javascript method for start signing in application host process.
Public method | RegisterStartSignatureOnClick | Register javascript to onclick event on Button for start signing in application host process.
Top
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper.RegisterSigningClientScriptInclude Method

AsdWebSignerHtmlHelperRegisterSigningClientScriptInclude Method

Register common client javascript to page for use signing in ASP.NET Core page on client side.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IHtmlContent RegisterSigningClientScriptInclude()

Return Value

Type: IHtmlContent
HTML element with link javascript file for singning.
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper.RegisterStartLoginOnClick Method

AsdWebSignerHtmlHelperRegisterStartLoginOnClick Method

Register javascript to onclick event on Button for start login by certificate in application host process.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IHtmlContent RegisterStartLoginOnClick(
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Return Value

Type: IHtmlContent
HTML onclick attribute.
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper.RegisterStartSignatureMethod Method

AsdWebSignerHtmlHelperRegisterStartSignatureMethod Method

Return call javascript method for start signing in application host process.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IHtmlContent RegisterStartSignatureMethod(
    CreateSessionRequest request,
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
Content identification for signing.
statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Return Value

Type: IHtmlContent
HTML javascript call method.
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


AsdWebSignerHtmlHelper.RegisterStartSignatureOnClick Method

AsdWebSignerHtmlHelperRegisterStartSignatureOnClick Method

Register javascript to onclick event on Button for start signing in application host process.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IHtmlContent RegisterStartSignatureOnClick(
    CreateSessionRequest request,
    string statusInfoControlClientId = null,
    string onSessionStatusTextChangedClientMethodName = null,
    string onSessionEndClientMethodName = null
)

Parameters

request
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
Content identification for signing.
statusInfoControlClientId (Optional)
Type: SystemString
Optional Client ID of Html Element for show signing status (progress) message. For example SPAN or DIV element.
onSessionStatusTextChangedClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom show signing status (progress) message. Signature of the method must be: (statusText: string, isError: boolean): void;
onSessionEndClientMethodName (Optional)
Type: SystemString
Optional javascript method name for custom handle ending signing, for example for redirecting to another page. Signature of the method must be: (sesionStatus: AsdWebSigner.SessionStatus): void;

Return Value

Type: IHtmlContent
HTML onclick attribute.
See Also

Reference

AsdWebSignerHtmlHelper Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


HtmlHelperExtensions Class

Extension for providing instance of AsdWebSignerHtmlHelper in IHtmlHelper in page.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.AspNetCoreHtmlHelperExtensions

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class HtmlHelperExtensions

The HtmlHelperExtensions type exposes the following members.

Methods
Name | Description
AsdWebSigner | Provide instance of AsdWebSignerHtmlHelper in IHtmlHelper in page.
Top
See Also

Reference

ASDSoft.WebSigner.Server.AspNetCore Namespace


HtmlHelperExtensions Methods

The HtmlHelperExtensions type exposes the following members.

Methods
Name | Description
AsdWebSigner | Provide instance of AsdWebSignerHtmlHelper in IHtmlHelper in page.
Top
See Also

Reference

HtmlHelperExtensions Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


HtmlHelperExtensions.AsdWebSigner Method

HtmlHelperExtensionsAsdWebSigner Method

Provide instance of AsdWebSignerHtmlHelper in IHtmlHelper in page.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static AsdWebSignerHtmlHelper AsdWebSigner(
    this IHtmlHelper html
)

Parameters

html
Type: IHtmlHelper
Instance of implementation of interface IHtmlHelper.

Return Value

Type: AsdWebSignerHtmlHelper
HTML element with link javascript file for singning.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IHtmlHelper. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

HtmlHelperExtensions Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Class

Extended information for configuration WebSigner module during initializing web application in ASP.NET Core.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ServerStartupSettingsBase
ASDSoft.WebSigner.Server.AspNetCoreStartupSettings

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class StartupSettings : StartupSettingsBase

The StartupSettings type exposes the following members.

Constructors
 | Name | Description
Public method | StartupSettings(IApiApplicationConfiguration) | Constructor for setting applications used by REST API.
Public method | StartupSettings(String, Byte) | Constructor for setting default application
Public method | StartupSettings(IApiApplicationConfiguration, String, Byte) | Constructor for combine settings of default application and applications used by REST API.
Top
Properties
 | Name | Description
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it. (Inherited from StartupSettingsBase.)
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing. (Inherited from StartupSettingsBase.)
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo) (Inherited from StartupSettingsBase.)
Public property | HelpCssUrl | Custom CSS style for the help page. (Inherited from StartupSettingsBase.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Constructor

Overload List
 | Name | Description
Public method | StartupSettings(IApiApplicationConfiguration) | Constructor for setting applications used by REST API.
Public method | StartupSettings(String, Byte) | Constructor for setting default application
Public method | StartupSettings(IApiApplicationConfiguration, String, Byte) | Constructor for combine settings of default application and applications used by REST API.
Top
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Constructor (IApiApplicationConfiguration[])

StartupSettings Constructor (IApiApplicationConfiguration)

Constructor for setting applications used by REST API.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public StartupSettings(
    IApiApplicationConfiguration[] apiApplications
)

Parameters

apiApplications
Type: ASDSoft.WebSigner.Server.Api.ConfigurationIApiApplicationConfiguration
Avaible REST API applications.
See Also

Reference

StartupSettings Class
StartupSettings Overload
ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Constructor (String, Byte[])

StartupSettings Constructor (String, Byte)

Constructor for setting default application

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public StartupSettings(
    string applicationName,
    byte[] logoBitmap = null
)

Parameters

applicationName
Type: SystemString
Name of application that is displayed in client window for selecting a certificate.
logoBitmap (Optional)
Type: SystemByte
Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate.
Remarks
Ideal height is 35px because logo no need resize.

Default is ASD logo, if this property is set to . For hide logo (no logo) set this property to empty byte array new byte[0].

See Also

Reference

StartupSettings Class
StartupSettings Overload
ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Constructor (IApiApplicationConfiguration[], String, Byte[])

StartupSettings Constructor (IApiApplicationConfiguration, String, Byte)

Constructor for combine settings of default application and applications used by REST API.

Namespace: ASDSoft.WebSigner.Server.AspNetCore
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public StartupSettings(
    IApiApplicationConfiguration[] apiApplications,
    string applicationName,
    byte[] logoBitmap = null
)

Parameters

apiApplications
Type: ASDSoft.WebSigner.Server.Api.ConfigurationIApiApplicationConfiguration
Avaible REST API applications.
applicationName
Type: SystemString
Name of default application that is displayed in client window for selecting a certificate.
logoBitmap (Optional)
Type: SystemByte
Custom bitmap logo (for example in PNG format) for display in client window for selecting a certificate in default application.
See Also

Reference

StartupSettings Class
StartupSettings Overload
ASDSoft.WebSigner.Server.AspNetCore Namespace


StartupSettings Properties

The StartupSettings type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationPersistor | Custom implementation of IAuthenticationPersistor for persist user identification in SignatureSession and restore it. (Inherited from StartupSettingsBase.)
Public property | CachePersistor | Custom implementation of cache persistor for store SignatureSession during process signing. (Inherited from StartupSettingsBase.)
Public property | CertificateAuthenticationProvider | Implementation of ICertificateAuthenticationProvider, see description of Authenticate(X509Certificate2, SignatureInfo) (Inherited from StartupSettingsBase.)
Public property | HelpCssUrl | Custom CSS style for the help page. (Inherited from StartupSettingsBase.)
Top
See Also

Reference

StartupSettings Class
ASDSoft.WebSigner.Server.AspNetCore Namespace


ASDSoft.WebSigner.Server.AspNetCore.Authorization Namespace

[Missing <summary> documentation for "N:ASDSoft.WebSigner.Server.AspNetCore.Authorization"]

Classes
 | Class | Description
Public class | ApplicationAutorizationHeaders |


ApplicationAutorizationHeaders Class

[Missing <summary> documentation for "T:ASDSoft.WebSigner.Server.AspNetCore.Authorization.ApplicationAutorizationHeaders"]

Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.AspNetCore.AuthorizationApplicationAutorizationHeaders

Namespace: ASDSoft.WebSigner.Server.AspNetCore.Authorization
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class ApplicationAutorizationHeaders

The ApplicationAutorizationHeaders type exposes the following members.

Fields
Name | Description
AUTH_TOKEN_NAME |
BEARER_AUTH_SCHEMA |
Top
See Also

Reference

ASDSoft.WebSigner.Server.AspNetCore.Authorization Namespace


ApplicationAutorizationHeaders Fields

The ApplicationAutorizationHeaders type exposes the following members.

Fields
Name | Description
AUTH_TOKEN_NAME |
BEARER_AUTH_SCHEMA |
Top
See Also

Reference

ApplicationAutorizationHeaders Class
ASDSoft.WebSigner.Server.AspNetCore.Authorization Namespace


ApplicationAutorizationHeaders.AUTH_TOKEN_NAME Field

ApplicationAutorizationHeadersAUTH_TOKEN_NAME Field

[Missing <summary> documentation for "F:ASDSoft.WebSigner.Server.AspNetCore.Authorization.ApplicationAutorizationHeaders.AUTH_TOKEN_NAME"]

Namespace: ASDSoft.WebSigner.Server.AspNetCore.Authorization
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public const string AUTH_TOKEN_NAME = "Authorization"

Field Value

Type: String
See Also

Reference

ApplicationAutorizationHeaders Class
ASDSoft.WebSigner.Server.AspNetCore.Authorization Namespace


ApplicationAutorizationHeaders.BEARER_AUTH_SCHEMA Field

ApplicationAutorizationHeadersBEARER_AUTH_SCHEMA Field

[Missing <summary> documentation for "F:ASDSoft.WebSigner.Server.AspNetCore.Authorization.ApplicationAutorizationHeaders.BEARER_AUTH_SCHEMA"]

Namespace: ASDSoft.WebSigner.Server.AspNetCore.Authorization
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public const string BEARER_AUTH_SCHEMA = "Bearer"

Field Value

Type: String
See Also

Reference

ApplicationAutorizationHeaders Class
ASDSoft.WebSigner.Server.AspNetCore.Authorization Namespace


ASDSoft.WebSigner.Server.Browser Namespace

Communication with the client browser.
Classes
 | Class | Description
Public class | BrowserInfo | Information about client browser and client OS.
Public class | ClientStartupParams | Information for initialize Javascript client
Public class | ClientStartupParamsBase | Base information for create SignatureSession
Public class | CreateSessionRequest | Content identification for use in new created signature session.


BrowserInfo Class

Information about client browser and client OS.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.BrowserBrowserInfo

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class BrowserInfo

The BrowserInfo type exposes the following members.

Properties
 | Name | Description
Public property | Browser | Name of client browser.
Public property | BrowserVersion | Version of client browser.
 | Current | The main entry point for getting information about client browser and OS for the current request.
Public property | IsBrowserSupported | if client browser supported for WebSigner component.
Public property | IsClientSupported | if client OS and browser supported for WebSigner component.
Public property | IsMobilePlatform | if client OS is mobile platform (Android, iOS, iPad, ...).
Public property | IsOSSupported | if client OS supported for WebSigner component.
Public property | IsPowerSaveEnvironment |
Public property | OS | Name of client OS.
Public property | OSVersion | Version of client OS.
Public property | UnsupportedHtml | User message for unsupported client OS or browser in HTML format.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo Properties

The BrowserInfo type exposes the following members.

Properties
 | Name | Description
Public property | Browser | Name of client browser.
Public property | BrowserVersion | Version of client browser.
 | Current | The main entry point for getting information about client browser and OS for the current request.
Public property | IsBrowserSupported | if client browser supported for WebSigner component.
Public property | IsClientSupported | if client OS and browser supported for WebSigner component.
Public property | IsMobilePlatform | if client OS is mobile platform (Android, iOS, iPad, ...).
Public property | IsOSSupported | if client OS supported for WebSigner component.
Public property | IsPowerSaveEnvironment |
Public property | OS | Name of client OS.
Public property | OSVersion | Version of client OS.
Public property | UnsupportedHtml | User message for unsupported client OS or browser in HTML format.
Top
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.Browser Property

BrowserInfoBrowser Property

Name of client browser.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string Browser { get; }

Property Value

Type: String
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.BrowserVersion Property

BrowserInfoBrowserVersion Property

Version of client browser.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Version BrowserVersion { get; }

Property Value

Type: Version
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.Current Property

BrowserInfoCurrent Property

The main entry point for getting information about client browser and OS for the current request.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static BrowserInfo Current { get; }

Property Value

Type: BrowserInfo
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.IsBrowserSupported Property

BrowserInfoIsBrowserSupported Property

if client browser supported for WebSigner component.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool IsBrowserSupported { get; }

Property Value

Type: Boolean
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.IsClientSupported Property

BrowserInfoIsClientSupported Property

if client OS and browser supported for WebSigner component.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool IsClientSupported { get; }

Property Value

Type: Boolean
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.IsMobilePlatform Property

BrowserInfoIsMobilePlatform Property

if client OS is mobile platform (Android, iOS, iPad, ...).

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool IsMobilePlatform { get; }

Property Value

Type: Boolean
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.IsOSSupported Property

BrowserInfoIsOSSupported Property

if client OS supported for WebSigner component.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool IsOSSupported { get; }

Property Value

Type: Boolean
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.IsPowerSaveEnvironment Property

BrowserInfoIsPowerSaveEnvironment Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.Browser.BrowserInfo.IsPowerSaveEnvironment"]

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool IsPowerSaveEnvironment { get; }

Property Value

Type: Boolean
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.OS Property

BrowserInfoOS Property

Name of client OS.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string OS { get; }

Property Value

Type: String
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.OSVersion Property

BrowserInfoOSVersion Property

Version of client OS.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Version OSVersion { get; }

Property Value

Type: Version
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


BrowserInfo.UnsupportedHtml Property

BrowserInfoUnsupportedHtml Property

User message for unsupported client OS or browser in HTML format.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string UnsupportedHtml { get; }

Property Value

Type: String
See Also

Reference

BrowserInfo Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams Class

Information for initialize Javascript client
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.BrowserClientStartupParamsBase
ASDSoft.WebSigner.Server.BrowserClientStartupParams

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public class ClientStartupParams : ClientStartupParamsBase

The ClientStartupParams type exposes the following members.

Properties
 | Name | Description
Public property | BaseUri | Base URL of web application (root).
 | CultureInfo | Current user language. (Inherited from ClientStartupParamsBase.)
Public property | HelpCssUrl | Url for application customized CSS for help page.
Public property | HelpUrl | Url for user help page.
Public property | InstallerUrl | Url for download client installer file.
Public property | Protocol | AsdWebSigner communication protocol version.
Public property | SessionId | Session ID for current signing request.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams Properties

The ClientStartupParams type exposes the following members.

Properties
 | Name | Description
Public property | BaseUri | Base URL of web application (root).
 | CultureInfo | Current user language. (Inherited from ClientStartupParamsBase.)
Public property | HelpCssUrl | Url for application customized CSS for help page.
Public property | HelpUrl | Url for user help page.
Public property | InstallerUrl | Url for download client installer file.
Public property | Protocol | AsdWebSigner communication protocol version.
Public property | SessionId | Session ID for current signing request.
Top
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.BaseUri Property

ClientStartupParamsBaseUri Property

Base URL of web application (root).

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "baseUri")]
[RequiredAttribute]
public string BaseUri { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.HelpCssUrl Property

ClientStartupParamsHelpCssUrl Property

Url for application customized CSS for help page.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "helpCssUrl")]
public string HelpCssUrl { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.HelpUrl Property

ClientStartupParamsHelpUrl Property

Url for user help page.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "helpUrl")]
[RequiredAttribute]
public string HelpUrl { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.InstallerUrl Property

ClientStartupParamsInstallerUrl Property

Url for download client installer file.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "installerUrl")]
[RequiredAttribute]
public string InstallerUrl { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.Protocol Property

ClientStartupParamsProtocol Property

AsdWebSigner communication protocol version.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "protocol")]
[RequiredAttribute]
public string Protocol { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParams.SessionId Property

ClientStartupParamsSessionId Property

Session ID for current signing request.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "sessionId")]
[RequiredAttribute]
public string SessionId { get; }

Property Value

Type: String
See Also

Reference

ClientStartupParams Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParamsBase Class

Base information for create SignatureSession
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.BrowserClientStartupParamsBase
ASDSoft.WebSigner.Server.ApiSignRequest
ASDSoft.WebSigner.Server.BrowserClientStartupParams

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public abstract class ClientStartupParamsBase

The ClientStartupParamsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ClientStartupParamsBase | Initializes a new instance of the ClientStartupParamsBase class
Top
Properties
Name | Description
CultureInfo | Current user language.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParamsBase Constructor

Initializes a new instance of the ClientStartupParamsBase class

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected ClientStartupParamsBase()
See Also

Reference

ClientStartupParamsBase Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParamsBase Properties

The ClientStartupParamsBase type exposes the following members.

Properties
Name | Description
CultureInfo | Current user language.
Top
See Also

Reference

ClientStartupParamsBase Class
ASDSoft.WebSigner.Server.Browser Namespace


ClientStartupParamsBase.CultureInfo Property

ClientStartupParamsBaseCultureInfo Property

Current user language.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "cultureInfo")]
public string CultureInfo { get; set; }

Property Value

Type: String
Examples
cs-CZ
See Also

Reference

ClientStartupParamsBase Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Class

Content identification for use in new created signature session.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.BrowserCreateSessionRequest

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataContractAttribute]
public class CreateSessionRequest

The CreateSessionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CreateSessionRequest | Obsolete. Obsolete public constructor - Use static methods CreateForValue(String, String) and CreateForJsExpression(String, String) instead constructor.
Top
Properties
 | Name | Description
Public property | Category | Custom category name. For example Login, Document, ....
Public property | Identification | Custom description, for example ID of an object.
Top
Methods
 | Name | Description
 | CreateForJsExpression | Create content identification by JavaScript expression for use in new created signature session.
 | CreateForValue | Create content identification by value for use in new created signature session.
Public method | Equals | Returns a value that indicates whether the current instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns the hash code for the current instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Return value text representation of instance. (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Determines whether two specified CreateSessionRequest objects are equal.
Inequality | Determines whether two specified CreateSessionRequest objects are not equal.
Top
Fields
Name | Description
Login | Singleton instance represented Login session request.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Constructor

Note: This API is now obsolete.

Obsolete public constructor - Use static methods CreateForValue(String, String) and CreateForJsExpression(String, String) instead constructor.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[ObsoleteAttribute("Use static methods CreateForValue and CreateForJsExpression instead constructor.")]
public CreateSessionRequest(
    string category = "",
    string identification = ""
)

Parameters

category (Optional)
Type: SystemString
Custom category name. For example Login, Document, ....
identification (Optional)
Type: SystemString
Custom description, for example ID of an object.
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Properties

The CreateSessionRequest type exposes the following members.

Properties
 | Name | Description
Public property | Category | Custom category name. For example Login, Document, ....
Public property | Identification | Custom description, for example ID of an object.
Top
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Category Property

CreateSessionRequestCategory Property

Custom category name. For example Login, Document, ....

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "category")]
public string Category { get; }

Property Value

Type: String
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Identification Property

CreateSessionRequestIdentification Property

Custom description, for example ID of an object.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[DataMemberAttribute(Name = "identification")]
public string Identification { get; }

Property Value

Type: String
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Methods

The CreateSessionRequest type exposes the following members.

Methods
 | Name | Description
 | CreateForJsExpression | Create content identification by JavaScript expression for use in new created signature session.
 | CreateForValue | Create content identification by value for use in new created signature session.
Public method | Equals | Returns a value that indicates whether the current instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns the hash code for the current instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Return value text representation of instance. (Overrides ObjectToString.)
Top
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.CreateForJsExpression Method

CreateSessionRequestCreateForJsExpression Method

Create content identification by JavaScript expression for use in new created signature session.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static CreateSessionRequest CreateForJsExpression(
    string categoryJsExpression = "",
    string identificationJsExpression = ""
)

Parameters

categoryJsExpression (Optional)
Type: SystemString
Expression for get variable or call method in JavaScript returned category value for filling Category.
identificationJsExpression (Optional)
Type: SystemString
Expression for get variable or call method in JavaScript returned inedtification value for filling Identification.

Return Value

Type: CreateSessionRequest
New instance.
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.CreateForValue Method

CreateSessionRequestCreateForValue Method

Create content identification by value for use in new created signature session.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static CreateSessionRequest CreateForValue(
    string categoryValue = "",
    string identificationValue = ""
)

Parameters

categoryValue (Optional)
Type: SystemString
Custom category name. For example Login, Document, ....
identificationValue (Optional)
Type: SystemString
Custom description, for example ID of an object.

Return Value

Type: CreateSessionRequest
New instance.
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Equals Method

CreateSessionRequestEquals Method

Returns a value that indicates whether the current instance and a specified object are equal.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current instance.

Return Value

Type: Boolean
if obj is a CreateSessionRequest object and its Category and Identification properties are equals to that of the current instance. The comparison is ordinal and case-sensitive.
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.GetHashCode Method

CreateSessionRequestGetHashCode Method

Returns the hash code for the current instance.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
The hash code for the string representation of the current instance
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.ToString Method

CreateSessionRequestToString Method

Return value text representation of instance.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
Return value $"{Category} / {Identification}".
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Operators

The CreateSessionRequest type exposes the following members.

Operators
Name | Description
Equality | Determines whether two specified CreateSessionRequest objects are equal.
Inequality | Determines whether two specified CreateSessionRequest objects are not equal.
Top
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Equality Operator

CreateSessionRequestEquality Operator

Determines whether two specified CreateSessionRequest objects are equal.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static bool operator ==(
    CreateSessionRequest v1,
    CreateSessionRequest v2
)

Parameters

v1
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
The first object to compare.
v2
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
The second object to compare.

Return Value

Type: Boolean
if both v1 and v2 have the same Category and Identification values; otherwise, .
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Inequality Operator

CreateSessionRequestInequality Operator

Determines whether two specified CreateSessionRequest objects are not equal.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static bool operator !=(
    CreateSessionRequest v1,
    CreateSessionRequest v2
)

Parameters

v1
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
The first object to compare.
v2
Type: ASDSoft.WebSigner.Server.BrowserCreateSessionRequest
The second object to compare.

Return Value

Type: Boolean
if both v1 and v2 do not have the same Category and Identification values; otherwise, .
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest Fields

The CreateSessionRequest type exposes the following members.

Fields
Name | Description
Login | Singleton instance represented Login session request.
Top
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


CreateSessionRequest.Login Field

CreateSessionRequestLogin Field

Singleton instance represented Login session request.

Namespace: ASDSoft.WebSigner.Server.Browser
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static readonly CreateSessionRequest Login

Field Value

Type: CreateSessionRequest
See Also

Reference

CreateSessionRequest Class
ASDSoft.WebSigner.Server.Browser Namespace


ASDSoft.WebSigner.Server.Cache Namespace

Store signature session in cache.
Classes
 | Class | Description
Public class | Base64StreamHelper | Helper for convert large streamed data from and to base64 string.
Public class | CacheItem | Cache item for store SignatureSession in cache implemented by CachePersistorBase.
Public class | CacheItemT | Cache item for store in cache.
Public class | CachePersistorBase | Base class for implementation store of SignatureSession in cache.
Public class | ClusterFileCachePersistor | Store of SignatureSession in file system synchronized by file system in cluster (Web Farm).
Public class | FileCachePersistor | Store of SignatureSession in file system.
Public class | FileCachePersistorCleaner | Helper class for cleaning file type cache.
Public class | MemoryCachePersistor | Store of SignatureSession in memory.
Public class | SecureDocumentPersistor | Base class for implementation IDocumentPersistor with secure stored document by encryption.
Public class | SerializedCachePersistorBase | Base class for implementation store of SignatureSession in external cache that require serialization of signature session data.
Interfaces
 | Interface | Description
Public interface | ICacheSynchronizer | Interface for implementation of notification and synchronization changes SignatureSession items in the cache.
Public interface | IDocumentPersistor | Interface for implementation persisting of documents in Signature Context during signing process.
Enumerations
 | Enumeration | Description
Public enumeration | CachLockType | Enumeration of lock type for access SignatureSession in CachePersistorBase.


Base64StreamHelper Class

Helper for convert large streamed data from and to base64 string.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheBase64StreamHelper

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class Base64StreamHelper

The Base64StreamHelper type exposes the following members.

Methods
Name | Description
FromBase64String | Decode Base64 encoded data to binary stream.
ToBase64String | Convert binary data from stream to base64 encoded string.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


Base64StreamHelper Methods

The Base64StreamHelper type exposes the following members.

Methods
Name | Description
FromBase64String | Decode Base64 encoded data to binary stream.
ToBase64String | Convert binary data from stream to base64 encoded string.
Top
See Also

Reference

Base64StreamHelper Class
ASDSoft.WebSigner.Server.Cache Namespace


Base64StreamHelper.FromBase64String Method

Base64StreamHelperFromBase64String Method

Decode Base64 encoded data to binary stream.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static Stream FromBase64String(
    string base64String
)

Parameters

base64String
Type: SystemString
Base64 encoded binary data.

Return Value

Type: Stream
Stream for read binary data.
See Also

Reference

Base64StreamHelper Class
ASDSoft.WebSigner.Server.Cache Namespace


Base64StreamHelper.ToBase64String Method

Base64StreamHelperToBase64String Method

Convert binary data from stream to base64 encoded string.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static string ToBase64String(
    Stream binaryStream
)

Parameters

binaryStream
Type: System.IOStream
Stream for read binary data.

Return Value

Type: String
Base64 encoded binary data.
See Also

Reference

Base64StreamHelper Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem Class

Cache item for store SignatureSession in cache implemented by CachePersistorBase.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCacheItem SignatureSession
ASDSoft.WebSigner.Server.CacheCacheItem

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CacheItem : CacheItem<SignatureSession>

The CacheItem type exposes the following members.

Properties
 | Name | Description
Public property | Session | Signature session stored in the cache.
Public property | ValidToUtc | Absolute UTC time when item expired in the cache. (Inherited from CacheItemT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


CacheItem Properties

The CacheItem type exposes the following members.

Properties
 | Name | Description
Public property | Session | Signature session stored in the cache.
Public property | ValidToUtc | Absolute UTC time when item expired in the cache. (Inherited from CacheItemT.)
Top
See Also

Reference

CacheItem Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem.Session Property

CacheItemSession Property

Signature session stored in the cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureSession Session { get; }

Property Value

Type: SignatureSession
See Also

Reference

CacheItem Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem(T) Class

CacheItemT Class

Cache item for store in cache.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCacheItemT
ASDSoft.WebSigner.Server.CacheCacheItem

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class CacheItem<T>

Type Parameters

T
Type of serializable cache item

The CacheItemT type exposes the following members.

Constructors
 | Name | Description
Protected method | CacheItemT | Base constructor.
Top
Properties
 | Name | Description
Protected property | Item | Item stored in the cache.
Public property | ValidToUtc | Absolute UTC time when item expired in the cache.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


CacheItem(T) Constructor

CacheItemT Constructor

Base constructor.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected CacheItem(
    T item,
    DateTime validToUtc
)

Parameters

item
Type: T
Item stored in the cache.
validToUtc
Type: SystemDateTime
Absolute UTC time when item expired in the cache.
See Also

Reference

CacheItemT Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem(T) Properties

CacheItemT Properties

The CacheItemT generic type exposes the following members.

Properties
 | Name | Description
Protected property | Item | Item stored in the cache.
Public property | ValidToUtc | Absolute UTC time when item expired in the cache.
Top
See Also

Reference

CacheItemT Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem(T).Item Property

CacheItemTItem Property

Item stored in the cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected T Item { get; }

Property Value

Type: T
See Also

Reference

CacheItemT Class
ASDSoft.WebSigner.Server.Cache Namespace


CacheItem(T).ValidToUtc Property

CacheItemTValidToUtc Property

Absolute UTC time when item expired in the cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DateTime ValidToUtc { get; }

Property Value

Type: DateTime
See Also

Reference

CacheItemT Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase Class

Base class for implementation store of SignatureSession in cache.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCachePersistorBase
ASDSoft.WebSigner.Server.CacheMemoryCachePersistor
ASDSoft.WebSigner.Server.CacheSerializedCachePersistorBase

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class CachePersistorBase

The CachePersistorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CachePersistorBase | Base constructor.
Top
Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction.
Public property | DocumentPersistor |
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache.
Top
Methods
 | Name | Description
Public method | Delete | Remove signature session from cache.
Protected method | DeleteInternal | Specific implementation of deleting signature session from cache called from method Delete(String).
Protected method | GetExpiredSessionsId | Get all expired signature session items in the cache for cleaning cache.
Public method | Load | Load signature session from cache.
Public method | LoadProgress | Load progress of signatures saving from cache.
Public method | Save | Save signature session to cache.
Protected method | SaveInternal | Specific implementation of saving signature session to cache called from method Save(SignatureSession).
Public method | SaveProgress | Save progress of signatures saving to cache.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase Constructor

Base constructor.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected CachePersistorBase()
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase Properties

The CachePersistorBase type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction.
Public property | DocumentPersistor |
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache.
Top
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.DefaultExpiration Property

CachePersistorBaseDefaultExpiration Property

Default time expiration for store signature session in the cache without interaction.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected TimeSpan DefaultExpiration { get; set; }

Property Value

Type: TimeSpan
Remarks
Default implementation return 4 hours.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.DocumentPersistor Property

CachePersistorBaseDocumentPersistor Property

[Missing <summary> documentation for "P:ASDSoft.WebSigner.Server.Cache.CachePersistorBase.DocumentPersistor"]

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IDocumentPersistor DocumentPersistor { get; protected set; }

Property Value

Type: IDocumentPersistor
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.Synchronizer Property

CachePersistorBaseSynchronizer Property

Implementation of notification and synchronization changes in the cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public ICacheSynchronizer Synchronizer { get; protected set; }

Property Value

Type: ICacheSynchronizer
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase Methods

The CachePersistorBase type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Remove signature session from cache.
Protected method | DeleteInternal | Specific implementation of deleting signature session from cache called from method Delete(String).
Protected method | GetExpiredSessionsId | Get all expired signature session items in the cache for cleaning cache.
Public method | Load | Load signature session from cache.
Public method | LoadProgress | Load progress of signatures saving from cache.
Public method | Save | Save signature session to cache.
Protected method | SaveInternal | Specific implementation of saving signature session to cache called from method Save(SignatureSession).
Public method | SaveProgress | Save progress of signatures saving to cache.
Top
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.Delete Method

CachePersistorBaseDelete Method

Remove signature session from cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool Delete(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which deleting from cache. If signature session not found in cache, return .

Return Value

Type: Boolean
if signature session found and removed from the cache.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.DeleteInternal Method

CachePersistorBaseDeleteInternal Method

Specific implementation of deleting signature session from cache called from method Delete(String).

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void DeleteInternal(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session which deleting from the cache. If signature session not found in the cache, the exception not thrown.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.GetExpiredSessionsId Method

CachePersistorBaseGetExpiredSessionsId Method

Get all expired signature session items in the cache for cleaning cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract string[] GetExpiredSessionsId()

Return Value

Type: String
An array of IDs of expired signature session items.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.Load Method

CachePersistorBaseLoad Method

Load signature session from cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract SignatureSession Load(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which get from cache. If signature session not found in cache, return .

Return Value

Type: SignatureSession
Signature session stored in cache.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.LoadProgress Method

CachePersistorBaseLoadProgress Method

Load progress of signatures saving from cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract int LoadProgress(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress get from cache. If signature session not found in cache, return 0.

Return Value

Type: Int32
Progress 0-100% of saving signatures.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.Save Method

CachePersistorBaseSave Method

Save signature session to cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public void Save(
    SignatureSession session
)

Parameters

session
Type: ASDSoft.WebSigner.ServerSignatureSession
Signature session.
Remarks
If the signature session already exists in the cache, will be overwritten.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.SaveInternal Method

CachePersistorBaseSaveInternal Method

Specific implementation of saving signature session to cache called from method Save(SignatureSession).

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void SaveInternal(
    CacheItem cacheItem
)

Parameters

cacheItem
Type: ASDSoft.WebSigner.Server.CacheCacheItem
Cache item with signature session a expiration.
Remarks
If the signature session already exists in the cache, will be overwritten.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachePersistorBase.SaveProgress Method

CachePersistorBaseSaveProgress Method

Save progress of signatures saving to cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract void SaveProgress(
    string sessionId,
    int progress
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress saved to cache.
progress
Type: SystemInt32
Progress 0-100% of saving signatures.
See Also

Reference

CachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


CachLockType Enumeration

Enumeration of lock type for access SignatureSession in CachePersistorBase.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public enum CachLockType
Members
Member name | Value | Description
Read | 0 | Read from cache.
Create | 1 | Create item in cache.
Write | 2 | Update item in cache.
Delete | 3 | Delete item from cache.
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


ClusterFileCachePersistor Class

Store of SignatureSession in file system synchronized by file system in cluster (Web Farm).
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCachePersistorBase
ASDSoft.WebSigner.Server.CacheSerializedCachePersistorBase
ASDSoft.WebSigner.Server.CacheFileCachePersistor
ASDSoft.WebSigner.Server.CacheClusterFileCachePersistor

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class ClusterFileCachePersistor : FileCachePersistor

The ClusterFileCachePersistor type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterFileCachePersistor | Base constructor.
Top
Properties
 | Name | Description
Protected property | CacheFolder | Folder for store provide in constructor. (Inherited from FileCachePersistor.)
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session file from folder. (Inherited from FileCachePersistor.)
Protected method | GetExpiredSessionsId | Get all expired files in a folder for cleaning folder. (Inherited from FileCachePersistor.)
Protected method | GetFileInfo | Construct path for signature session file. (Inherited from FileCachePersistor.)
Public method | Load | Load and deserialize signature session from external cache. (Inherited from SerializedCachePersistorBase.)
Public method | LoadProgress | Load progress of signatures saving from file. (Inherited from FileCachePersistor.)
Protected method | LoadSerialized | Load the serialized signature session from file. (Inherited from FileCachePersistor.)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Inherited from SerializedCachePersistorBase.)
Public method | SaveProgress | Save progress of signatures saving to file. (Inherited from FileCachePersistor.)
Protected method | SaveSerialized | Save the serialized signature session to file. (Inherited from FileCachePersistor.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


ClusterFileCachePersistor Constructor

Base constructor.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public ClusterFileCachePersistor(
    DirectoryInfo cacheFolder
)

Parameters

cacheFolder
Type: System.IODirectoryInfo
Folder for the store on a shared network disk.
See Also

Reference

ClusterFileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


ClusterFileCachePersistor Properties

The ClusterFileCachePersistor type exposes the following members.

Properties
 | Name | Description
Protected property | CacheFolder | Folder for store provide in constructor. (Inherited from FileCachePersistor.)
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
See Also

Reference

ClusterFileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


ClusterFileCachePersistor Methods

The ClusterFileCachePersistor type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session file from folder. (Inherited from FileCachePersistor.)
Protected method | GetExpiredSessionsId | Get all expired files in a folder for cleaning folder. (Inherited from FileCachePersistor.)
Protected method | GetFileInfo | Construct path for signature session file. (Inherited from FileCachePersistor.)
Public method | Load | Load and deserialize signature session from external cache. (Inherited from SerializedCachePersistorBase.)
Public method | LoadProgress | Load progress of signatures saving from file. (Inherited from FileCachePersistor.)
Protected method | LoadSerialized | Load the serialized signature session from file. (Inherited from FileCachePersistor.)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Inherited from SerializedCachePersistorBase.)
Public method | SaveProgress | Save progress of signatures saving to file. (Inherited from FileCachePersistor.)
Protected method | SaveSerialized | Save the serialized signature session to file. (Inherited from FileCachePersistor.)
Top
See Also

Reference

ClusterFileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor Class

Store of SignatureSession in file system.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCachePersistorBase
ASDSoft.WebSigner.Server.CacheSerializedCachePersistorBase
ASDSoft.WebSigner.Server.CacheFileCachePersistor
ASDSoft.WebSigner.Server.CacheClusterFileCachePersistor

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class FileCachePersistor : SerializedCachePersistorBase

The FileCachePersistor type exposes the following members.

Constructors
 | Name | Description
Public method | FileCachePersistor | Constructor for change default folder for store.
Top
Properties
 | Name | Description
Protected property | CacheFolder | Folder for store provide in constructor.
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session file from folder. (Overrides CachePersistorBaseDeleteInternal(String).)
Protected method | GetExpiredSessionsId | Get all expired files in a folder for cleaning folder. (Overrides CachePersistorBaseGetExpiredSessionsId.)
Protected method | GetFileInfo | Construct path for signature session file.
Public method | Load | Load and deserialize signature session from external cache. (Inherited from SerializedCachePersistorBase.)
Public method | LoadProgress | Load progress of signatures saving from file. (Overrides CachePersistorBaseLoadProgress(String).)
Protected method | LoadSerialized | Load the serialized signature session from file. (Overrides SerializedCachePersistorBaseLoadSerialized(String).)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Inherited from SerializedCachePersistorBase.)
Public method | SaveProgress | Save progress of signatures saving to file. (Overrides CachePersistorBaseSaveProgress(String, Int32).)
Protected method | SaveSerialized | Save the serialized signature session to file. (Overrides SerializedCachePersistorBaseSaveSerialized(String, DateTime, Byte).)
Top
Remarks
This implementation used as default WebSigner component configuration. Default folder for store is GetTempPath + ASDWebSigner/SessionCache.
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor Constructor

Constructor for change default folder for store.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public FileCachePersistor(
    DirectoryInfo cacheFolder
)

Parameters

cacheFolder
Type: System.IODirectoryInfo
Folder for store.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor Properties

The FileCachePersistor type exposes the following members.

Properties
 | Name | Description
Protected property | CacheFolder | Folder for store provide in constructor.
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.CacheFolder Property

FileCachePersistorCacheFolder Property

Folder for store provide in constructor.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected DirectoryInfo CacheFolder { get; }

Property Value

Type: DirectoryInfo
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor Methods

The FileCachePersistor type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session file from folder. (Overrides CachePersistorBaseDeleteInternal(String).)
Protected method | GetExpiredSessionsId | Get all expired files in a folder for cleaning folder. (Overrides CachePersistorBaseGetExpiredSessionsId.)
Protected method | GetFileInfo | Construct path for signature session file.
Public method | Load | Load and deserialize signature session from external cache. (Inherited from SerializedCachePersistorBase.)
Public method | LoadProgress | Load progress of signatures saving from file. (Overrides CachePersistorBaseLoadProgress(String).)
Protected method | LoadSerialized | Load the serialized signature session from file. (Overrides SerializedCachePersistorBaseLoadSerialized(String).)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Inherited from SerializedCachePersistorBase.)
Public method | SaveProgress | Save progress of signatures saving to file. (Overrides CachePersistorBaseSaveProgress(String, Int32).)
Protected method | SaveSerialized | Save the serialized signature session to file. (Overrides SerializedCachePersistorBaseSaveSerialized(String, DateTime, Byte).)
Top
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.DeleteInternal Method

FileCachePersistorDeleteInternal Method

Delete signature session file from folder.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void DeleteInternal(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session which file deleting. If file not found in the folder, the exception not thrown.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.GetExpiredSessionsId Method

FileCachePersistorGetExpiredSessionsId Method

Get all expired files in a folder for cleaning folder.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override string[] GetExpiredSessionsId()

Return Value

Type: String
An array of IDs of expired signature session items.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.GetFileInfo Method

FileCachePersistorGetFileInfo Method

Construct path for signature session file.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected FileInfo GetFileInfo(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the SignatureSession.

Return Value

Type: FileInfo
Path for signature session file.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.LoadProgress Method

FileCachePersistorLoadProgress Method

Load progress of signatures saving from file.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override int LoadProgress(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress get from cache. If signature session not found in cache, return 0.

Return Value

Type: Int32
Progress 0-100% of saving signatures.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.LoadSerialized Method

FileCachePersistorLoadSerialized Method

Load the serialized signature session from file.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override byte[] LoadSerialized(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session loaded from cache.

Return Value

Type: Byte
Serialized signature session stored in file.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.SaveProgress Method

FileCachePersistorSaveProgress Method

Save progress of signatures saving to file.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override void SaveProgress(
    string sessionId,
    int progress
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress saved to cache.
progress
Type: SystemInt32
Progress 0-100% of saving signatures.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistor.SaveSerialized Method

FileCachePersistorSaveSerialized Method

Save the serialized signature session to file.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void SaveSerialized(
    string sessionId,
    DateTime validToUtc,
    byte[] serializedSession
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session saved to file.
validToUtc
Type: SystemDateTime
Absolute UTC time when file expired.
serializedSession
Type: SystemByte
Serialized signature session.
See Also

Reference

FileCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistorCleaner Class

Helper class for cleaning file type cache.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheFileCachePersistorCleaner

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class FileCachePersistorCleaner

The FileCachePersistorCleaner type exposes the following members.

Methods
Name | Description
GetExpiredSessionsId | Get all expired files in a folder for cleaning folder.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistorCleaner Methods

The FileCachePersistorCleaner type exposes the following members.

Methods
Name | Description
GetExpiredSessionsId | Get all expired files in a folder for cleaning folder.
Top
See Also

Reference

FileCachePersistorCleaner Class
ASDSoft.WebSigner.Server.Cache Namespace


FileCachePersistorCleaner.GetExpiredSessionsId Method

FileCachePersistorCleanerGetExpiredSessionsId Method

Get all expired files in a folder for cleaning folder.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static string[] GetExpiredSessionsId(
    DirectoryInfo cacheFolder,
    string fileExtension
)

Parameters

cacheFolder
Type: System.IODirectoryInfo
Directory in file system, where is cache item stored.
fileExtension
Type: SystemString
Type of files (file extensions)

Return Value

Type: String
An array of IDs of expired signature session items.
See Also

Reference

FileCachePersistorCleaner Class
ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer Interface

Interface for implementation of notification and synchronization changes SignatureSession items in the cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface ICacheSynchronizer

The ICacheSynchronizer type exposes the following members.

Methods
 | Name | Description
Public method | AddChangeHandler | Add a handler for getting changes in the signature session cache.
Public method | Lock | Lock cache for concurrent access.
Public method | OnChanged | Called by CachePersistorBase on add, update and remove SignatureSession in cache.
Public method | RemoveChangeHandler | Remove a handler for getting changes in the signature session cache.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer Methods

The ICacheSynchronizer type exposes the following members.

Methods
 | Name | Description
Public method | AddChangeHandler | Add a handler for getting changes in the signature session cache.
Public method | Lock | Lock cache for concurrent access.
Public method | OnChanged | Called by CachePersistorBase on add, update and remove SignatureSession in cache.
Public method | RemoveChangeHandler | Remove a handler for getting changes in the signature session cache.
Top
See Also

Reference

ICacheSynchronizer Interface
ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer.AddChangeHandler Method

ICacheSynchronizerAddChangeHandler Method

Add a handler for getting changes in the signature session cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void AddChangeHandler(
    string sessionId,
    Action<SignatureSession> onChangeAction
)

Parameters

sessionId
Type: SystemString
The SessionId of the SignatureSession.
onChangeAction
Type: SystemAction SignatureSession
Delegate calling on change.
See Also

Reference

ICacheSynchronizer Interface
ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer.Lock Method

ICacheSynchronizerLock Method

Lock cache for concurrent access.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void Lock(
    string sessionId,
    CachLockType lockType,
    Action action
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session.
lockType
Type: ASDSoft.WebSigner.Server.CacheCachLockType
Operation lock type
action
Type: SystemAction
Delegate for execute action called in lock mode.
See Also

Reference

ICacheSynchronizer Interface
ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer.OnChanged Method

ICacheSynchronizerOnChanged Method

Called by CachePersistorBase on add, update and remove SignatureSession in cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void OnChanged(
    SignatureSession session
)

Parameters

session
Type: ASDSoft.WebSigner.ServerSignatureSession
Cahnged signature session.
Remarks
Implementation must call all delegates added by method AddChangeHandler(String, ActionSignatureSession).
See Also

Reference

ICacheSynchronizer Interface
ASDSoft.WebSigner.Server.Cache Namespace


ICacheSynchronizer.RemoveChangeHandler Method

ICacheSynchronizerRemoveChangeHandler Method

Remove a handler for getting changes in the signature session cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void RemoveChangeHandler(
    string sessionId,
    Action<SignatureSession> onChangeAction
)

Parameters

sessionId
Type: SystemString
The SessionId of the SignatureSession.
onChangeAction
Type: SystemAction SignatureSession
Delegate calling on change added by method AddChangeHandler(String, ActionSignatureSession).
See Also

Reference

ICacheSynchronizer Interface
ASDSoft.WebSigner.Server.Cache Namespace


IDocumentPersistor Interface

Interface for implementation persisting of documents in Signature Context during signing process.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IDocumentPersistor

The IDocumentPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create new persist stream for store document.
Public method | Delete | Delete stored document.
Public method | OpenRead | Open stream for reading persisted document.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


IDocumentPersistor Methods

The IDocumentPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create new persist stream for store document.
Public method | Delete | Delete stored document.
Public method | OpenRead | Open stream for reading persisted document.
Top
See Also

Reference

IDocumentPersistor Interface
ASDSoft.WebSigner.Server.Cache Namespace


IDocumentPersistor.Create Method

IDocumentPersistorCreate Method

Create new persist stream for store document.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Stream Create(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
Unique temporary Id for store and retrive document.

Return Value

Type: Stream
Stream for writing document.
See Also

Reference

IDocumentPersistor Interface
ASDSoft.WebSigner.Server.Cache Namespace


IDocumentPersistor.Delete Method

IDocumentPersistorDelete Method

Delete stored document.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void Delete(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
Id used in method Create(Guid)
See Also

Reference

IDocumentPersistor Interface
ASDSoft.WebSigner.Server.Cache Namespace


IDocumentPersistor.OpenRead Method

IDocumentPersistorOpenRead Method

Open stream for reading persisted document.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Stream OpenRead(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
Id used in method Create(Guid)

Return Value

Type: Stream
Stream for reading document.
See Also

Reference

IDocumentPersistor Interface
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor Class

Store of SignatureSession in memory.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCachePersistorBase
ASDSoft.WebSigner.Server.CacheMemoryCachePersistor

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public class MemoryCachePersistor : CachePersistorBase

The MemoryCachePersistor type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryCachePersistor | Initializes a new instance of the MemoryCachePersistor class
Top
Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session item from the memory cache (Overrides CachePersistorBaseDeleteInternal(String).)
Protected method | GetExpiredSessionsId | Get all expired signature session items in the memory cache for cleaning cache. (Overrides CachePersistorBaseGetExpiredSessionsId.)
Public method | Load | Load signature session from memory cache. (Overrides CachePersistorBaseLoad(String).)
Public method | LoadProgress | Load progress of signatures saving from memory cache. (Overrides CachePersistorBaseLoadProgress(String).)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Save signature session item to the memory cache. (Overrides CachePersistorBaseSaveInternal(CacheItem).)
Public method | SaveProgress | Save progress of signatures saving to memory cache (Overrides CachePersistorBaseSaveProgress(String, Int32).)
Top
Remarks
Restart of application pool delete all items in cache and ending the signature process can throw an exception!
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor Constructor

Initializes a new instance of the MemoryCachePersistor class

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public MemoryCachePersistor()
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor Properties

The MemoryCachePersistor type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor Methods

The MemoryCachePersistor type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Delete signature session item from the memory cache (Overrides CachePersistorBaseDeleteInternal(String).)
Protected method | GetExpiredSessionsId | Get all expired signature session items in the memory cache for cleaning cache. (Overrides CachePersistorBaseGetExpiredSessionsId.)
Public method | Load | Load signature session from memory cache. (Overrides CachePersistorBaseLoad(String).)
Public method | LoadProgress | Load progress of signatures saving from memory cache. (Overrides CachePersistorBaseLoadProgress(String).)
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Save signature session item to the memory cache. (Overrides CachePersistorBaseSaveInternal(CacheItem).)
Public method | SaveProgress | Save progress of signatures saving to memory cache (Overrides CachePersistorBaseSaveProgress(String, Int32).)
Top
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.DeleteInternal Method

MemoryCachePersistorDeleteInternal Method

Delete signature session item from the memory cache

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void DeleteInternal(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session which deleting from the cache. If signature session not found in the cache, the exception not thrown.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.GetExpiredSessionsId Method

MemoryCachePersistorGetExpiredSessionsId Method

Get all expired signature session items in the memory cache for cleaning cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override string[] GetExpiredSessionsId()

Return Value

Type: String
An array of IDs of expired signature session items.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.Load Method

MemoryCachePersistorLoad Method

Load signature session from memory cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override SignatureSession Load(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which get from cache. If signature session not found in cache, return .

Return Value

Type: SignatureSession
Signature session stored in memory.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.LoadProgress Method

MemoryCachePersistorLoadProgress Method

Load progress of signatures saving from memory cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override int LoadProgress(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress get from cache. If signature session not found in cache, return 0.

Return Value

Type: Int32
Progress 0-100% of saving signatures.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.SaveInternal Method

MemoryCachePersistorSaveInternal Method

Save signature session item to the memory cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void SaveInternal(
    CacheItem cacheItem
)

Parameters

cacheItem
Type: ASDSoft.WebSigner.Server.CacheCacheItem
Cache item with signature session a expiration.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


MemoryCachePersistor.SaveProgress Method

MemoryCachePersistorSaveProgress Method

Save progress of signatures saving to memory cache

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override void SaveProgress(
    string sessionId,
    int progress
)

Parameters

sessionId
Type: SystemString
The SessionId of signature session which progress saved to cache.
progress
Type: SystemInt32
Progress 0-100% of saving signatures.
See Also

Reference

MemoryCachePersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor Class

Base class for implementation IDocumentPersistor with secure stored document by encryption.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheSecureDocumentPersistor

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class SecureDocumentPersistor : IDocumentPersistor

The SecureDocumentPersistor type exposes the following members.

Constructors
 | Name | Description
Protected method | SecureDocumentPersistor | Initializes a new instance of the SecureDocumentPersistor class
Top
Methods
 | Name | Description
Public method | Create | See to Create(Guid)
Public method | Delete | See to Delete(Guid)
Protected method | GetReadStream | See to OpenRead(Guid)
Protected method | GetWriteStream | See to Create(Guid)
Public method | OpenRead | See to OpenRead(Guid)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor Constructor

Initializes a new instance of the SecureDocumentPersistor class

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SecureDocumentPersistor()
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor Methods

The SecureDocumentPersistor type exposes the following members.

Methods
 | Name | Description
Public method | Create | See to Create(Guid)
Public method | Delete | See to Delete(Guid)
Protected method | GetReadStream | See to OpenRead(Guid)
Protected method | GetWriteStream | See to Create(Guid)
Public method | OpenRead | See to OpenRead(Guid)
Top
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor.Create Method

SecureDocumentPersistorCreate Method

See to Create(Guid)

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Stream Create(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
See to Create(Guid)

Return Value

Type: Stream
Stream for writing document secured by encryption.

Implements

IDocumentPersistorCreate(Guid)
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor.Delete Method

SecureDocumentPersistorDelete Method

See to Delete(Guid)

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract void Delete(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
See to Delete(Guid)

Implements

IDocumentPersistorDelete(Guid)
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor.GetReadStream Method

SecureDocumentPersistorGetReadStream Method

See to OpenRead(Guid)

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Stream GetReadStream(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
See to OpenRead(Guid)

Return Value

Type: Stream
See to OpenRead(Guid)
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor.GetWriteStream Method

SecureDocumentPersistorGetWriteStream Method

See to Create(Guid)

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract Stream GetWriteStream(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
See to Create(Guid)

Return Value

Type: Stream
See to Create(Guid)
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SecureDocumentPersistor.OpenRead Method

SecureDocumentPersistorOpenRead Method

See to OpenRead(Guid)

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Stream OpenRead(
    Guid storedDocumentId
)

Parameters

storedDocumentId
Type: SystemGuid
See to OpenRead(Guid)

Return Value

Type: Stream
Decrypted stream for reading persisted document.

Implements

IDocumentPersistorOpenRead(Guid)
See Also

Reference

SecureDocumentPersistor Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase Class

Base class for implementation store of SignatureSession in external cache that require serialization of signature session data.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.CacheCachePersistorBase
ASDSoft.WebSigner.Server.CacheSerializedCachePersistorBase
ASDSoft.WebSigner.Server.CacheFileCachePersistor

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class SerializedCachePersistorBase : CachePersistorBase

The SerializedCachePersistorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SerializedCachePersistorBase | Initializes a new instance of the SerializedCachePersistorBase class
Top
Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Specific implementation of deleting signature session from cache called from method Delete(String). (Inherited from CachePersistorBase.)
Protected method | GetExpiredSessionsId | Get all expired signature session items in the cache for cleaning cache. (Inherited from CachePersistorBase.)
Public method | Load | Load and deserialize signature session from external cache. (Overrides CachePersistorBaseLoad(String).)
Public method | LoadProgress | Load progress of signatures saving from cache. (Inherited from CachePersistorBase.)
Protected method | LoadSerialized | The specific implementation of external cache for loading the serialized signature session from external cache.
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Overrides CachePersistorBaseSaveInternal(CacheItem).)
Public method | SaveProgress | Save progress of signatures saving to cache. (Inherited from CachePersistorBase.)
Protected method | SaveSerialized | The specific implementation of external cache for saving the serialized signature session.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase Constructor

Initializes a new instance of the SerializedCachePersistorBase class

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected SerializedCachePersistorBase()
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase Properties

The SerializedCachePersistorBase type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultExpiration | Default time expiration for store signature session in the cache without interaction. (Inherited from CachePersistorBase.)
Public property | DocumentPersistor | (Inherited from CachePersistorBase.)
Public property | Synchronizer | Implementation of notification and synchronization changes in the cache. (Inherited from CachePersistorBase.)
Top
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase Methods

The SerializedCachePersistorBase type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Remove signature session from cache. (Inherited from CachePersistorBase.)
Protected method | DeleteInternal | Specific implementation of deleting signature session from cache called from method Delete(String). (Inherited from CachePersistorBase.)
Protected method | GetExpiredSessionsId | Get all expired signature session items in the cache for cleaning cache. (Inherited from CachePersistorBase.)
Public method | Load | Load and deserialize signature session from external cache. (Overrides CachePersistorBaseLoad(String).)
Public method | LoadProgress | Load progress of signatures saving from cache. (Inherited from CachePersistorBase.)
Protected method | LoadSerialized | The specific implementation of external cache for loading the serialized signature session from external cache.
Public method | Save | Save signature session to cache. (Inherited from CachePersistorBase.)
Protected method | SaveInternal | Serialize and save signature session item to the external cache. (Overrides CachePersistorBaseSaveInternal(CacheItem).)
Public method | SaveProgress | Save progress of signatures saving to cache. (Inherited from CachePersistorBase.)
Protected method | SaveSerialized | The specific implementation of external cache for saving the serialized signature session.
Top
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase.Load Method

SerializedCachePersistorBaseLoad Method

Load and deserialize signature session from external cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override SignatureSession Load(
    string sessionId
)

Parameters

sessionId
Type: SystemString

Return Value

Type: SignatureSession
Signature session stored in external cache.
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase.LoadSerialized Method

SerializedCachePersistorBaseLoadSerialized Method

The specific implementation of external cache for loading the serialized signature session from external cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract byte[] LoadSerialized(
    string sessionId
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session loaded from cache.

Return Value

Type: Byte
Serialized signature session stored in external cache.
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase.SaveInternal Method

SerializedCachePersistorBaseSaveInternal Method

Serialize and save signature session item to the external cache.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void SaveInternal(
    CacheItem cacheItem
)

Parameters

cacheItem
Type: ASDSoft.WebSigner.Server.CacheCacheItem
Cache item with signature session a expiration.
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


SerializedCachePersistorBase.SaveSerialized Method

SerializedCachePersistorBaseSaveSerialized Method

The specific implementation of external cache for saving the serialized signature session.

Namespace: ASDSoft.WebSigner.Server.Cache
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void SaveSerialized(
    string sessionId,
    DateTime validToUtc,
    byte[] serializedSession
)

Parameters

sessionId
Type: SystemString
The SessionId of the signature session saved to cache.
validToUtc
Type: SystemDateTime
Absolute UTC time when item expired in the cache.
serializedSession
Type: SystemByte
Serialized signature session.
See Also

Reference

SerializedCachePersistorBase Class
ASDSoft.WebSigner.Server.Cache Namespace


ASDSoft.WebSigner.Server.Content Namespace

Definitions of content for signing on server-side.
Classes
 | Class | Description
Public class | BinaryContent | Represent binary data for signing by Data
Public class | BuildableDocumentLinkContentBaseTConfiguration | Base implementation for a document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document.
Public class | DocumentInfo | Description of document for signing.
Public class | DocumentLinkContent | Base implementation for a document which can be shown for signing by a hyperlink in the client application.
Public class | DocumentSignerLinkContent | Content for a document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document by ASDSoft.SignTools (PDF, XML, Office, ...).
Public class | DocumentSignerLinkContentBuilderConfiguration | Configuration for signing document.
Protected class | DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration | Representation of SignTools DocumentSignerConfiguration
Public class | FileContent | Content for a file which can be shown for signing by a hyperlink in the client application and signing hash of this file.
Public class | HashContent | Represent hash for signing by Hash
Public class | PdfSignerLinkContentBuilderConfiguration | Content for PDF document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document by ASDSoft.SignTools.Pdf.
Interfaces
 | Interface | Description
Public interface | IContentBuilder | Interface for special content with supporting build content for signing from document.
Public interface | IContentBuilderTConfiguration | Interface for special content with supporting build content for signing from document.
Public interface | IContentBuilderConfiguration | Configuration for signing document.
Public interface | IDocumentLinkContent | Interface for implementation inherited classes from ContentBase which can show document for signing by hyperlink in client application.


BinaryContent Class

Represent binary data for signing by Data
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentDocumentLinkContent
ASDSoft.WebSigner.Server.ContentHashContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class BinaryContent : ContentBase<byte[]>

The BinaryContent type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryContent(Object) | Constructor for create instance without known content at instance creation time.
Public method | BinaryContent(Byte, Object) | Constructor for create instance with known content at instance creation time.
Protected method | BinaryContent(SignatureType, Object) | Base constructor for inherited classes without known content at instance creation time.
Protected method | BinaryContent(Byte, SignatureType, Object) | Base constructor for inherited classes with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides ContentBaseIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Overrides ContentBaseGetContentData.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Overrides ContentBaseGetContentTitle.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Constructor

Overload List
 | Name | Description
Public method | BinaryContent(Object) | Constructor for create instance without known content at instance creation time.
Public method | BinaryContent(Byte, Object) | Constructor for create instance with known content at instance creation time.
Protected method | BinaryContent(SignatureType, Object) | Base constructor for inherited classes without known content at instance creation time.
Protected method | BinaryContent(Byte, SignatureType, Object) | Base constructor for inherited classes with known content at instance creation time.
Top
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Constructor (Object)

Constructor for create instance without known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public BinaryContent(
    Object applicationContentId = null
)

Parameters

applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

BinaryContent Class
BinaryContent Overload
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Constructor (Byte[], Object)

BinaryContent Constructor (Byte, Object)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public BinaryContent(
    byte[] content,
    Object applicationContentId = null
)

Parameters

content
Type: SystemByte
Binary data for signing.
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

BinaryContent Class
BinaryContent Overload
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Constructor (SignatureType, Object)

Base constructor for inherited classes without known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected BinaryContent(
    SignatureType signatureType,
    Object applicationContentId = null
)

Parameters

signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

BinaryContent Class
BinaryContent Overload
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Constructor (Byte[], SignatureType, Object)

BinaryContent Constructor (Byte, SignatureType, Object)

Base constructor for inherited classes with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected BinaryContent(
    byte[] content,
    SignatureType signatureType,
    Object applicationContentId = null
)

Parameters

content
Type: SystemByte
Binary data or hash for signing.
signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

BinaryContent Class
BinaryContent Overload
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Properties

The BinaryContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides ContentBaseIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate
Top
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent.IsLink Property

BinaryContentIsLink Property

Always return .

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool IsLink { get; }

Property Value

Type: Boolean
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent.Title Property

BinaryContentTitle Property

Content title for display in client window for selecting a certificate

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string Title { get; set; }

Property Value

Type: String
Remarks
If Title not set, will be use text returned from method GetContentTitle.
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent Methods

The BinaryContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Overrides ContentBaseGetContentData.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Overrides ContentBaseGetContentTitle.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent.GetContentData Method

BinaryContentGetContentData Method

Return binary data or hash of content for signing.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override byte[] GetContentData()

Return Value

Type: Byte
Binary data or hash for signing.
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BinaryContent.GetContentTitle Method

BinaryContentGetContentTitle Method

Return text description of content for display in client window for selecting a certificate.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override string GetContentTitle()

Return Value

Type: String
Title text. If not set, than Base64 encoded binary data. Inherited classes can override for custom description text.
See Also

Reference

BinaryContent Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Class

BuildableDocumentLinkContentBaseTConfiguration Class

Base implementation for a document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentDocumentLinkContent
ASDSoft.WebSigner.Server.ContentBuildableDocumentLinkContentBaseTConfiguration
ASDSoft.WebSigner.Server.ContentDocumentSignerLinkContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class BuildableDocumentLinkContentBase<TConfiguration> : DocumentLinkContent,
    IContentBuilder<TConfiguration>, IContentBuilder
where TConfiguration : IContentBuilderConfiguration

Type Parameters

TConfiguration
Type of configuration class

The BuildableDocumentLinkContentBaseTConfiguration type exposes the following members.

Constructors
 | Name | Description
Protected method | BuildableDocumentLinkContentBaseTConfiguration(Object, String) | Constructor for create instance without known document at instance creation time.
Protected method | BuildableDocumentLinkContentBaseTConfiguration(Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Configuration | Configuration for signing document
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | SignedDocumentData | Obsolete. Binary data of final signed document.
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
Methods
 | Name | Description
Protected method | ClearDocumentCacheInternal | (Overrides DocumentLinkContentClearDocumentCacheInternal.)
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document.
Protected method | PrepareForExternalSign | Compute hash or digest of document and prepare document for external sign.
Protected method | ResetLazyContent | (Inherited from DocumentLinkContent.)
Protected method | SaveSignatureToDocument | Save signature to document prepared by PrepareForExternalSign(Stream, Stream, HashAlgorithmName, X509Certificate2, Byte).
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Constructor

BuildableDocumentLinkContentBaseTConfiguration Constructor

Overload List
 | Name | Description
Protected method | BuildableDocumentLinkContentBaseTConfiguration(Object, String) | Constructor for create instance without known document at instance creation time.
Protected method | BuildableDocumentLinkContentBaseTConfiguration(Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Top
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Constructor (Object, String)

BuildableDocumentLinkContentBaseTConfiguration Constructor (Object, String)

Constructor for create instance without known document at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected BuildableDocumentLinkContentBase(
    Object documentId,
    string documentName
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
BuildableDocumentLinkContentBaseTConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Constructor (Object, String, DocumentInfo)

BuildableDocumentLinkContentBaseTConfiguration Constructor (Object, String, DocumentInfo)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected BuildableDocumentLinkContentBase(
    Object documentId,
    string documentName,
    DocumentInfo document
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
document
Type: ASDSoft.WebSigner.Server.ContentDocumentInfo
Description and full binary content of the document for signing.
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
BuildableDocumentLinkContentBaseTConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Properties

BuildableDocumentLinkContentBaseTConfiguration Properties

The BuildableDocumentLinkContentBaseTConfiguration generic type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Configuration | Configuration for signing document
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | SignedDocumentData | Obsolete. Binary data of final signed document.
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).Configuration Property

BuildableDocumentLinkContentBaseTConfigurationConfiguration Property

Configuration for signing document

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public TConfiguration Configuration { get; set; }

Property Value

Type: TConfiguration

Implements

IContentBuilderTConfigurationConfiguration
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).SignedDocumentData Property

BuildableDocumentLinkContentBaseTConfigurationSignedDocumentData Property

Note: This API is now obsolete.

Binary data of final signed document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[ObsoleteAttribute("Use method OpenSignedDocumentRead() instead property SignedDocumentData.")]
public byte[] SignedDocumentData { get; }

Property Value

Type: Byte
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration) Methods

BuildableDocumentLinkContentBaseTConfiguration Methods

The BuildableDocumentLinkContentBaseTConfiguration generic type exposes the following members.

Methods
 | Name | Description
Protected method | ClearDocumentCacheInternal | (Overrides DocumentLinkContentClearDocumentCacheInternal.)
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document.
Protected method | PrepareForExternalSign | Compute hash or digest of document and prepare document for external sign.
Protected method | ResetLazyContent | (Inherited from DocumentLinkContent.)
Protected method | SaveSignatureToDocument | Save signature to document prepared by PrepareForExternalSign(Stream, Stream, HashAlgorithmName, X509Certificate2, Byte).
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).ClearDocumentCacheInternal Method

BuildableDocumentLinkContentBaseTConfigurationClearDocumentCacheInternal Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Content.BuildableDocumentLinkContentBase`1.ClearDocumentCacheInternal"]

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void ClearDocumentCacheInternal()
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).OpenSignedDocumentRead Method

BuildableDocumentLinkContentBaseTConfigurationOpenSignedDocumentRead Method

Open stream for read final signed document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Stream OpenSignedDocumentRead()

Return Value

Type: Stream
Opened read stream with final signed document.

Implements

IContentBuilderOpenSignedDocumentRead
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).PrepareForExternalSign Method

BuildableDocumentLinkContentBaseTConfigurationPrepareForExternalSign Method

Compute hash or digest of document and prepare document for external sign.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void PrepareForExternalSign(
    Stream documentSourceStream,
    Stream preparedDocumentTargetStream,
    HashAlgorithmName signatureHashAlgorithm,
    X509Certificate2 certificate,
    out byte[] content
)

Parameters

documentSourceStream
Type: System.IOStream
Stream with document data for signing
preparedDocumentTargetStream
Type: System.IOStream
Traget stream for write prepared document for signing.
signatureHashAlgorithm
Type: ASDSoft.WebSignerHashAlgorithmName
Hash algorithm for compute digest of document.
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Public part of signing X509 certificate.
content
Type: SystemByte
Computed hash or digest for signing. Will be filled to Content by infrastructure.
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


BuildableDocumentLinkContentBase(TConfiguration).SaveSignatureToDocument Method

BuildableDocumentLinkContentBaseTConfigurationSaveSignatureToDocument Method

Save signature to document prepared by PrepareForExternalSign(Stream, Stream, HashAlgorithmName, X509Certificate2, Byte).

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void SaveSignatureToDocument(
    Stream preparedDocumentSourceStream,
    Stream signedDocumentTargetStream,
    X509Certificate2 certificate,
    byte[] signature
)

Parameters

preparedDocumentSourceStream
Type: System.IOStream
Stream with data of document prepared by PrepareForExternalSign(Stream, Stream, HashAlgorithmName, X509Certificate2, Byte)
signedDocumentTargetStream
Type: System.IOStream
Target stream for write final signed document. Can be read later by OpenSignedDocumentRead
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Public part of signing X509 certificate.
signature
Type: SystemByte
Created RSA signature.
See Also

Reference

BuildableDocumentLinkContentBaseTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Class

Description of document for signing.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ContentDocumentInfo

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class DocumentInfo

The DocumentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentInfo(Byte, String) | Secondary constructor for help provide binary data of document without stream.
Public method | DocumentInfo(Stream, String) | Primary recommended constructor.
Top
Properties
 | Name | Description
Public property | ContentType | Media type of document used for downloading document in browser, for example application/pdf for PDF document.
Public property | HasData | Indicates, that document for signing is filled.
Top
Methods
 | Name | Description
Public method | OpenRead | Open stream for read original document for signing.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Constructor

Overload List
 | Name | Description
Public method | DocumentInfo(Byte, String) | Secondary constructor for help provide binary data of document without stream.
Public method | DocumentInfo(Stream, String) | Primary recommended constructor.
Top
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Constructor (Byte[], String)

DocumentInfo Constructor (Byte, String)

Secondary constructor for help provide binary data of document without stream.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentInfo(
    byte[] documentData,
    string contentType
)

Parameters

documentData
Type: SystemByte
Binary data of document.
contentType
Type: SystemString
Media type of document used for downloading document in browser, for example application/pdf for PDF document.
See Also

Reference

DocumentInfo Class
DocumentInfo Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Constructor (Stream, String)

Primary recommended constructor.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentInfo(
    Stream documentStream,
    string contentType
)

Parameters

documentStream
Type: System.IOStream
Stream with data of document. All content of document will be readed inside this constructor.
contentType
Type: SystemString
Media type of document used for downloading document in browser, for example application/pdf for PDF document.
Remarks
All content of document will be readed from documentStream inside this constructor. After create instance of DocumentInfo caller can close this stream.
See Also

Reference

DocumentInfo Class
DocumentInfo Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Properties

The DocumentInfo type exposes the following members.

Properties
 | Name | Description
Public property | ContentType | Media type of document used for downloading document in browser, for example application/pdf for PDF document.
Public property | HasData | Indicates, that document for signing is filled.
Top
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo.ContentType Property

DocumentInfoContentType Property

Media type of document used for downloading document in browser, for example application/pdf for PDF document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string ContentType { get; }

Property Value

Type: String
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo.HasData Property

DocumentInfoHasData Property

Indicates, that document for signing is filled.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool HasData { get; }

Property Value

Type: Boolean
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo Methods

The DocumentInfo type exposes the following members.

Methods
 | Name | Description
Public method | OpenRead | Open stream for read original document for signing.
Top
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentInfo.OpenRead Method

DocumentInfoOpenRead Method

Open stream for read original document for signing.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public Stream OpenRead()

Return Value

Type: Stream
Opened read stream with original document for signing.
See Also

Reference

DocumentInfo Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Class

Base implementation for a document which can be shown for signing by a hyperlink in the client application.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentDocumentLinkContent
ASDSoft.WebSigner.Server.ContentBuildableDocumentLinkContentBaseTConfiguration
ASDSoft.WebSigner.Server.ContentFileContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class DocumentLinkContent : BinaryContent,
    IDocumentLinkContent

The DocumentLinkContent type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentLinkContent(Object, String, SignatureType) | Constructor for create instance without known content at instance creation time.
Public method | DocumentLinkContent(Object, String, Byte, SignatureType) | Constructor for create instance with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing.
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides BinaryContentIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
Methods
 | Name | Description
Protected method | ClearDocumentCacheInternal |
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Protected method | ResetLazyContent | (Overrides ContentBaseTResetLazyContent.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Constructor

Overload List
 | Name | Description
Public method | DocumentLinkContent(Object, String, SignatureType) | Constructor for create instance without known content at instance creation time.
Public method | DocumentLinkContent(Object, String, Byte, SignatureType) | Constructor for create instance with known content at instance creation time.
Top
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Constructor (Object, String, SignatureType)

Constructor for create instance without known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentLinkContent(
    Object documentId,
    string documentName,
    SignatureType signatureType
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
See Also

Reference

DocumentLinkContent Class
DocumentLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Constructor (Object, String, Byte[], SignatureType)

DocumentLinkContent Constructor (Object, String, Byte, SignatureType)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentLinkContent(
    Object documentId,
    string documentName,
    byte[] content,
    SignatureType signatureType
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
content
Type: SystemByte
Document computed data or hash for signing.
signatureType
Type: ASDSoft.WebSignerSignatureType
Signature type (Data or Hash).
See Also

Reference

DocumentLinkContent Class
DocumentLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Properties

The DocumentLinkContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing.
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Overrides BinaryContentIsLink.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent.Document Property

DocumentLinkContentDocument Property

Description and full binary content of document for signing.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentInfo Document { get; set; }

Property Value

Type: DocumentInfo

Implements

IDocumentLinkContentDocument
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent.IsLink Property

DocumentLinkContentIsLink Property

Always return .

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public override bool IsLink { get; }

Property Value

Type: Boolean
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent Methods

The DocumentLinkContent type exposes the following members.

Methods
 | Name | Description
Protected method | ClearDocumentCacheInternal |
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Protected method | ResetLazyContent | (Overrides ContentBaseTResetLazyContent.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent.ClearDocumentCacheInternal Method

DocumentLinkContentClearDocumentCacheInternal Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Content.DocumentLinkContent.ClearDocumentCacheInternal"]

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual void ClearDocumentCacheInternal()
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentLinkContent.ResetLazyContent Method

DocumentLinkContentResetLazyContent Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Content.DocumentLinkContent.ResetLazyContent"]

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected override void ResetLazyContent()
See Also

Reference

DocumentLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Class

Content for a document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document by ASDSoft.SignTools (PDF, XML, Office, ...).
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentDocumentLinkContent
ASDSoft.WebSigner.Server.ContentBuildableDocumentLinkContentBase DocumentSignerLinkContentBuilderConfiguration
ASDSoft.WebSigner.Server.ContentDocumentSignerLinkContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class DocumentSignerLinkContent : BuildableDocumentLinkContentBase<DocumentSignerLinkContentBuilderConfiguration>

The DocumentSignerLinkContent type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSignerLinkContent(String, Object, String) | Constructor for create instance without known document at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, Byte) | Constructor for create instance with known content at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, Stream) | Constructor for create instance with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Configuration | Configuration for signing document (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | DocumentFileExtension | File extension of document, for example PDF, XML, DOCX, ...
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | SignedDocumentData | Obsolete. Binary data of final signed document. (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document. (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Constructor

Overload List
 | Name | Description
Public method | DocumentSignerLinkContent(String, Object, String) | Constructor for create instance without known document at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, Byte) | Constructor for create instance with known content at instance creation time.
Public method | DocumentSignerLinkContent(String, Object, String, Stream) | Constructor for create instance with known content at instance creation time.
Top
See Also

Reference

DocumentSignerLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Constructor (String, Object, String)

Constructor for create instance without known document at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContent(
    string documentFileExtension,
    Object documentId,
    string documentName
)

Parameters

documentFileExtension
Type: SystemString
File extension of document, for example PDF, XML, DOCX, ...
documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
See Also

Reference

DocumentSignerLinkContent Class
DocumentSignerLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Constructor (String, Object, String, DocumentInfo)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContent(
    string documentFileExtension,
    Object documentId,
    string documentName,
    DocumentInfo documentInfo
)

Parameters

documentFileExtension
Type: SystemString
File extension of document, for example PDF, XML, DOCX, ...
documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
documentInfo
Type: ASDSoft.WebSigner.Server.ContentDocumentInfo
Content of document.
See Also

Reference

DocumentSignerLinkContent Class
DocumentSignerLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Constructor (String, Object, String, Byte[])

DocumentSignerLinkContent Constructor (String, Object, String, Byte)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContent(
    string documentFileExtension,
    Object documentId,
    string documentName,
    byte[] documentData
)

Parameters

documentFileExtension
Type: SystemString
File extension of document, for example PDF, XML, DOCX, ...
documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
documentData
Type: SystemByte
Binary data of document.
See Also

Reference

DocumentSignerLinkContent Class
DocumentSignerLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Constructor (String, Object, String, Stream)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContent(
    string documentFileExtension,
    Object documentId,
    string documentName,
    Stream documentStream
)

Parameters

documentFileExtension
Type: SystemString
File extension of document, for example PDF, XML, DOCX, ...
documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
documentStream
Type: System.IOStream
Stream with data of document.
See Also

Reference

DocumentSignerLinkContent Class
DocumentSignerLinkContent Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Properties

The DocumentSignerLinkContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Configuration | Configuration for signing document (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | DocumentFileExtension | File extension of document, for example PDF, XML, DOCX, ...
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | SignedDocumentData | Obsolete. Binary data of final signed document. (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
See Also

Reference

DocumentSignerLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent.DocumentFileExtension Property

DocumentSignerLinkContentDocumentFileExtension Property

File extension of document, for example PDF, XML, DOCX, ...

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string DocumentFileExtension { get; }

Property Value

Type: String
See Also

Reference

DocumentSignerLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContent Methods

The DocumentSignerLinkContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document. (Inherited from BuildableDocumentLinkContentBaseTConfiguration.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

DocumentSignerLinkContent Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Class

Configuration for signing document.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ContentDocumentSignerLinkContentBuilderConfiguration

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class DocumentSignerLinkContentBuilderConfiguration : IContentBuilderConfiguration

The DocumentSignerLinkContentBuilderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSignerLinkContentBuilderConfiguration | Base constructor for manual configuration.
Public method | DocumentSignerLinkContentBuilderConfiguration(IDocumentSignerConfiguration) | Constructor for pre-configuration from another configuration.
Public method | DocumentSignerLinkContentBuilderConfiguration(String) | Constructor for pre-configuration from configuration file.
Top
Properties
 | Name | Description
Public property | AdesLevel | PAdES/XAdES/CAdES level for signature.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
Methods
 | Name | Description
Protected method | CreateDocumentSignerConfiguration | Convert this instance to a implementation of IDocumentSignerConfiguration
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Constructor

Overload List
 | Name | Description
Public method | DocumentSignerLinkContentBuilderConfiguration | Base constructor for manual configuration.
Public method | DocumentSignerLinkContentBuilderConfiguration(IDocumentSignerConfiguration) | Constructor for pre-configuration from another configuration.
Public method | DocumentSignerLinkContentBuilderConfiguration(String) | Constructor for pre-configuration from configuration file.
Top
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Constructor

Base constructor for manual configuration.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContentBuilderConfiguration()
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
DocumentSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Constructor (IDocumentSignerConfiguration)

Constructor for pre-configuration from another configuration.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContentBuilderConfiguration(
    IDocumentSignerConfiguration configuration
)

Parameters

configuration
Type: ASDSoft.SignToolsIDocumentSignerConfiguration
Configuration that will be copied to current instance
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
DocumentSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Constructor (String)

Constructor for pre-configuration from configuration file.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerLinkContentBuilderConfiguration(
    string configurationName
)

Parameters

configurationName
Type: SystemString
Configuration name from collections of elements in ASDSoft.SignTools/documentSigner.
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
DocumentSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Properties

The DocumentSignerLinkContentBuilderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | PAdES/XAdES/CAdES level for signature.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.AdesLevel Property

DocumentSignerLinkContentBuilderConfigurationAdesLevel Property

PAdES/XAdES/CAdES level for signature.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public AdesLevel? AdesLevel { get; set; }

Property Value

Type: Nullable AdesLevel
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.SignatureHashAlgorithm Property

DocumentSignerLinkContentBuilderConfigurationSignatureHashAlgorithm Property

Hash algorithm for compute digest of document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public HashAlgorithmName? SignatureHashAlgorithm { get; set; }

Property Value

Type: Nullable HashAlgorithmName

Implements

IContentBuilderConfigurationSignatureHashAlgorithm
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.TSAName Property

DocumentSignerLinkContentBuilderConfigurationTSAName Property

The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string TSAName { get; set; }

Property Value

Type: String

Implements

IContentBuilderConfigurationTSAName
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration Methods

The DocumentSignerLinkContentBuilderConfiguration type exposes the following members.

Methods
 | Name | Description
Protected method | CreateDocumentSignerConfiguration | Convert this instance to a implementation of IDocumentSignerConfiguration
Top
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.CreateDocumentSignerConfiguration Method

DocumentSignerLinkContentBuilderConfigurationCreateDocumentSignerConfiguration Method

Convert this instance to a implementation of IDocumentSignerConfiguration

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected virtual IDocumentSignerConfiguration CreateDocumentSignerConfiguration(
    HashAlgorithmName defaultSignatureHashAlgorithm
)

Parameters

defaultSignatureHashAlgorithm
Type: ASDSoft.WebSignerHashAlgorithmName
Default hash algorithm for compute digest of document. Used, if not configured in SignatureHashAlgorithm.

Return Value

Type: IDocumentSignerConfiguration
SignTools DocumentSignerConfiguration
See Also

Reference

DocumentSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration) Class

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class

Representation of SignTools DocumentSignerConfiguration
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ContentDocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected class DocumentSignerConfiguration<TConfiguration> : IDocumentSignerConfiguration
where TConfiguration : DocumentSignerLinkContentBuilderConfiguration

Type Parameters

TConfiguration
Type of WebSigner DocumentSignerLinkContentBuilderConfiguration

The DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration | Base constructor
Top
Properties
 | Name | Description
Public property | AdesLevel | See AdesLevel.
Public property | Name | See Name. Always return #runtime#.
Public property | SignatureHashAlgorithm | See SignatureHashAlgorithm.
Public property | TSAInfo | See TSAInfo.
Public property | UseTimeStamp | See UseTimeStamp.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration) Constructor

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Constructor

Base constructor

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public DocumentSignerConfiguration(
    HashAlgorithmName defaultSignatureHashAlgorithm,
    TConfiguration configuration
)

Parameters

defaultSignatureHashAlgorithm
Type: ASDSoft.WebSignerHashAlgorithmName
Default hash algorithm for compute digest of document. Used, if not configured in configuration parameter.
configuration
Type: TConfiguration
WebSigner DocumentSignerLinkContentBuilderConfiguration
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerConfiguration(TConfiguration) Properties

DocumentSignerConfigurationTConfiguration Properties

The DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration generic type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | See AdesLevel.
Public property | Name | See Name. Always return #runtime#.
Public property | SignatureHashAlgorithm | See SignatureHashAlgorithm.
Public property | TSAInfo | See TSAInfo.
Public property | UseTimeStamp | See UseTimeStamp.
Top
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration).AdesLevel Property

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfigurationAdesLevel Property

See AdesLevel.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public AdesLevel AdesLevel { get; }

Property Value

Type: AdesLevel

Implements

IDocumentSignerConfigurationAdesLevel
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration).Name Property

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfigurationName Property

See Name. Always return #runtime#.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String

Implements

IDocumentSignerConfigurationName
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration).SignatureHashAlgorithm Property

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfigurationSignatureHashAlgorithm Property

See SignatureHashAlgorithm.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public HashOid SignatureHashAlgorithm { get; }

Property Value

Type: HashOid

Implements

IDocumentSignerConfigurationSignatureHashAlgorithm
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration).TSAInfo Property

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfigurationTSAInfo Property

See TSAInfo.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public GenericTSAInfo TSAInfo { get; }

Property Value

Type: GenericTSAInfo

Implements

IDocumentSignerConfigurationTSAInfo
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


DocumentSignerLinkContentBuilderConfiguration.DocumentSignerConfiguration(TConfiguration).UseTimeStamp Property

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfigurationUseTimeStamp Property

See UseTimeStamp.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public bool UseTimeStamp { get; }

Property Value

Type: Boolean

Implements

IDocumentSignerConfigurationUseTimeStamp
See Also

Reference

DocumentSignerLinkContentBuilderConfigurationDocumentSignerConfigurationTConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


FileContent Class

Content for a file which can be shown for signing by a hyperlink in the client application and signing hash of this file.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentDocumentLinkContent
ASDSoft.WebSigner.Server.ContentFileContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class FileContent : DocumentLinkContent,
    IContentBuilder

The FileContent type exposes the following members.

Constructors
 | Name | Description
Public method | FileContent(Object, String) | Constructor for create instance without known document at instance creation time.
Public method | FileContent(Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


FileContent Constructor

Overload List
 | Name | Description
Public method | FileContent(Object, String) | Constructor for create instance without known document at instance creation time.
Public method | FileContent(Object, String, DocumentInfo) | Constructor for create instance with known content at instance creation time.
Top
See Also

Reference

FileContent Class
ASDSoft.WebSigner.Server.Content Namespace


FileContent Constructor (Object, String)

Constructor for create instance without known document at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public FileContent(
    Object documentId,
    string documentName
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
See Also

Reference

FileContent Class
FileContent Overload
ASDSoft.WebSigner.Server.Content Namespace


FileContent Constructor (Object, String, DocumentInfo)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public FileContent(
    Object documentId,
    string documentName,
    DocumentInfo documentInfo
)

Parameters

documentId
Type: SystemObject
Unique ID generated by hosting application identified document in hosting application.
documentName
Type: SystemString
Document name displayed in client window for selecting a certificate. Value is set to Title.
documentInfo
Type: ASDSoft.WebSigner.Server.ContentDocumentInfo
Content of document.
See Also

Reference

FileContent Class
FileContent Overload
ASDSoft.WebSigner.Server.Content Namespace


FileContent Properties

The FileContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | Document | Description and full binary content of document for signing. (Inherited from DocumentLinkContent.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Public property | IsLink | Always return . (Inherited from DocumentLinkContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
See Also

Reference

FileContent Class
ASDSoft.WebSigner.Server.Content Namespace


FileContent Methods

The FileContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

FileContent Class
ASDSoft.WebSigner.Server.Content Namespace


HashContent Class

Represent hash for signing by Hash
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.ContentContentBase
ASDSoft.WebSigner.ContentContentBase Byte
ASDSoft.WebSigner.Server.ContentBinaryContent
ASDSoft.WebSigner.Server.ContentHashContent

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public class HashContent : BinaryContent

The HashContent type exposes the following members.

Constructors
 | Name | Description
Public method | HashContent(Object) | Constructor for create instance without known content at instance creation time.
Public method | HashContent(Byte, Object) | Constructor for create instance with known content at instance creation time.
Top
Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from BinaryContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


HashContent Constructor

Overload List
 | Name | Description
Public method | HashContent(Object) | Constructor for create instance without known content at instance creation time.
Public method | HashContent(Byte, Object) | Constructor for create instance with known content at instance creation time.
Top
See Also

Reference

HashContent Class
ASDSoft.WebSigner.Server.Content Namespace


HashContent Constructor (Object)

Constructor for create instance without known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public HashContent(
    Object applicationContentId = null
)

Parameters

applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

HashContent Class
HashContent Overload
ASDSoft.WebSigner.Server.Content Namespace


HashContent Constructor (Byte[], Object)

HashContent Constructor (Byte, Object)

Constructor for create instance with known content at instance creation time.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public HashContent(
    byte[] hash,
    Object applicationContentId = null
)

Parameters

hash
Type: SystemByte
Computed hash for signing.
applicationContentId (Optional)
Type: SystemObject
Optional unique ID generated by hosting application identified content in hosting application (for example ID of document)
See Also

Reference

HashContent Class
HashContent Overload
ASDSoft.WebSigner.Server.Content Namespace


HashContent Properties

The HashContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID generated by hosting application identified content in hosting application (for example ID of document). (Inherited from ContentBase.)
Public property | Content | Content for signing, for example, text, byte array, ... (Inherited from ContentBaseT.)
Public property | HasContent | Only for internal use. (Inherited from ContentBaseT.)
Protected property | HasLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | IsLink | Always return . (Inherited from BinaryContent.)
Public property | NeedResetLazyContent | Only for internal use. (Inherited from ContentBase.)
Public property | SignatureType | Signature type (Data or Hash). (Inherited from ContentBase.)
Public property | Title | Content title for display in client window for selecting a certificate (Inherited from BinaryContent.)
Top
See Also

Reference

HashContent Class
ASDSoft.WebSigner.Server.Content Namespace


HashContent Methods

The HashContent type exposes the following members.

Methods
 | Name | Description
Public method | GetContentData | Return binary data or hash of content for signing. (Inherited from BinaryContent.)
Public method | GetContentTitle | Return text description of content for display in client window for selecting a certificate. (Inherited from BinaryContent.)
Protected method | ResetLazyContent | Only for internal use. (Inherited from ContentBaseT.)
Public method | SetContent | Lazy setting of content if not set in constructor. (Inherited from ContentBaseT.)
Top
See Also

Reference

HashContent Class
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder Interface

Interface for special content with supporting build content for signing from document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IContentBuilder

The IContentBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Configuration for signing document
Top
Methods
 | Name | Description
Public method | BuildContent | Build content for signing from document stored in this instance
Public method | OpenSignedDocumentRead | Open stream for read final signed document.
Public method | SaveSignatureToDocument | Save signature to document prepared by BuildContent(HashAlgorithmName, X509Certificate2).
Top
Remarks
Usually implemented by document content with supporting internal store of signature, for example PDF, XML, Office, CMS.
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder Properties

The IContentBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Configuration for signing document
Top
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder.Configuration Property

IContentBuilderConfiguration Property

Configuration for signing document

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
IContentBuilderConfiguration Configuration { get; }

Property Value

Type: IContentBuilderConfiguration
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder Methods

The IContentBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildContent | Build content for signing from document stored in this instance
Public method | OpenSignedDocumentRead | Open stream for read final signed document.
Public method | SaveSignatureToDocument | Save signature to document prepared by BuildContent(HashAlgorithmName, X509Certificate2).
Top
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder.BuildContent Method

IContentBuilderBuildContent Method

Build content for signing from document stored in this instance

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Object BuildContent(
    HashAlgorithmName signatureHashAlgorithm,
    X509Certificate2 certificate
)

Parameters

signatureHashAlgorithm
Type: ASDSoft.WebSignerHashAlgorithmName
Hash algorithm for compute digest of document.
certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Public part of signing X509 certificate.

Return Value

Type: Object
Content for signing, usually byte[] with hash or digest of document.
Remarks
Implementation must be thread safe, when sign more than one content per session.
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder.OpenSignedDocumentRead Method

IContentBuilderOpenSignedDocumentRead Method

Open stream for read final signed document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Stream OpenSignedDocumentRead()

Return Value

Type: Stream
Opened read stream with final signed document.
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder.SaveSignatureToDocument Method

IContentBuilderSaveSignatureToDocument Method

Save signature to document prepared by BuildContent(HashAlgorithmName, X509Certificate2).

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void SaveSignatureToDocument(
    X509Certificate2 certificate,
    byte[] signature
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
Public part of signing X509 certificate.
signature
Type: SystemByte
Created RSA signature.
Remarks
Implementation must be thread safe, when sign more than one content per session.
See Also

Reference

IContentBuilder Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder(TConfiguration) Interface

IContentBuilderTConfiguration Interface

Interface for special content with supporting build content for signing from document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IContentBuilder<TConfiguration> : IContentBuilder
where TConfiguration : IContentBuilderConfiguration

Type Parameters

TConfiguration
Type of configuration class.

The IContentBuilderTConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Configuration for signing document
Top
Methods
 | Name | Description
Public method | BuildContent | Build content for signing from document stored in this instance (Inherited from IContentBuilder.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document. (Inherited from IContentBuilder.)
Public method | SaveSignatureToDocument | Save signature to document prepared by BuildContent(HashAlgorithmName, X509Certificate2). (Inherited from IContentBuilder.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder(TConfiguration) Properties

IContentBuilderTConfiguration Properties

The IContentBuilderTConfiguration generic type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Configuration for signing document
Top
See Also

Reference

IContentBuilderTConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder(TConfiguration).Configuration Property

IContentBuilderTConfigurationConfiguration Property

Configuration for signing document

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
TConfiguration Configuration { get; set; }

Property Value

Type: TConfiguration
See Also

Reference

IContentBuilderTConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilder(TConfiguration) Methods

IContentBuilderTConfiguration Methods

The IContentBuilderTConfiguration generic type exposes the following members.

Methods
 | Name | Description
Public method | BuildContent | Build content for signing from document stored in this instance (Inherited from IContentBuilder.)
Public method | OpenSignedDocumentRead | Open stream for read final signed document. (Inherited from IContentBuilder.)
Public method | SaveSignatureToDocument | Save signature to document prepared by BuildContent(HashAlgorithmName, X509Certificate2). (Inherited from IContentBuilder.)
Top
See Also

Reference

IContentBuilderTConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilderConfiguration Interface

Configuration for signing document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IContentBuilderConfiguration

The IContentBuilderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevelName | PAdES/XAdES/CAdES level for signature. Valid values are None, Basic, LtvOcsp.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


IContentBuilderConfiguration Properties

The IContentBuilderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevelName | PAdES/XAdES/CAdES level for signature. Valid values are None, Basic, LtvOcsp.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.
Top
See Also

Reference

IContentBuilderConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilderConfiguration.AdesLevelName Property

IContentBuilderConfigurationAdesLevelName Property

PAdES/XAdES/CAdES level for signature. Valid values are None, Basic, LtvOcsp.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string AdesLevelName { get; }

Property Value

Type: String
See Also

Reference

IContentBuilderConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilderConfiguration.SignatureHashAlgorithm Property

IContentBuilderConfigurationSignatureHashAlgorithm Property

Hash algorithm for compute digest of document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
HashAlgorithmName? SignatureHashAlgorithm { get; }

Property Value

Type: Nullable HashAlgorithmName
See Also

Reference

IContentBuilderConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IContentBuilderConfiguration.TSAName Property

IContentBuilderConfigurationTSAName Property

The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string TSAName { get; }

Property Value

Type: String
See Also

Reference

IContentBuilderConfiguration Interface
ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent Interface

Interface for implementation inherited classes from ContentBase which can show document for signing by hyperlink in client application.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IDocumentLinkContent

The IDocumentLinkContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID of document generated by hosting application for downloading full document.
Public property | Document | Description and full binary content of document for signing.
Top
Methods
 | Name | Description
Public method | ClearDocumentCache |
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent Properties

The IDocumentLinkContent type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationContentId | Unique ID of document generated by hosting application for downloading full document.
Public property | Document | Description and full binary content of document for signing.
Top
See Also

Reference

IDocumentLinkContent Interface
ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent.ApplicationContentId Property

IDocumentLinkContentApplicationContentId Property

Unique ID of document generated by hosting application for downloading full document.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
Object ApplicationContentId { get; }

Property Value

Type: Object
See Also

Reference

IDocumentLinkContent Interface
ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent.Document Property

IDocumentLinkContentDocument Property

Description and full binary content of document for signing.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
DocumentInfo Document { get; set; }

Property Value

Type: DocumentInfo
See Also

Reference

IDocumentLinkContent Interface
ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent Methods

The IDocumentLinkContent type exposes the following members.

Methods
 | Name | Description
Public method | ClearDocumentCache |
Top
See Also

Reference

IDocumentLinkContent Interface
ASDSoft.WebSigner.Server.Content Namespace


IDocumentLinkContent.ClearDocumentCache Method

IDocumentLinkContentClearDocumentCache Method

[Missing <summary> documentation for "M:ASDSoft.WebSigner.Server.Content.IDocumentLinkContent.ClearDocumentCache"]

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void ClearDocumentCache()
See Also

Reference

IDocumentLinkContent Interface
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Class

Content for PDF document which can be shown for signing by a hyperlink in the client application and with supporting build content for signing from document by ASDSoft.SignTools.Pdf.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ContentDocumentSignerLinkContentBuilderConfiguration
ASDSoft.WebSigner.Server.ContentPdfSignerLinkContentBuilderConfiguration

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PdfSignerLinkContentBuilderConfiguration : DocumentSignerLinkContentBuilderConfiguration

The PdfSignerLinkContentBuilderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSignerLinkContentBuilderConfiguration | Base constructor for manual configuration.
Public method | PdfSignerLinkContentBuilderConfiguration(IPdfSignerConfiguration) | Constructor for pre-configuration from another configuration.
Public method | PdfSignerLinkContentBuilderConfiguration(String) | Constructor for pre-configuration from configuration file.
Top
Properties
 | Name | Description
Public property | AdesLevel | PAdES/XAdES/CAdES level for signature. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Public property | CanRepairPdf | If PDF has not yet been signed, then can allow edit PDF for signature compliance if need.
Public property | SignatureAppearance | Definition for visual signature.
Public property | SignatureBufferKbSize | Size of basic buffer in PDF for signature content without size for TSA and OCSP. Default is 8 kB.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Public property | SignatureInfo | Basic information for new signature.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Constructor

Overload List
 | Name | Description
Public method | PdfSignerLinkContentBuilderConfiguration | Base constructor for manual configuration.
Public method | PdfSignerLinkContentBuilderConfiguration(IPdfSignerConfiguration) | Constructor for pre-configuration from another configuration.
Public method | PdfSignerLinkContentBuilderConfiguration(String) | Constructor for pre-configuration from configuration file.
Top
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Constructor

Base constructor for manual configuration.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public PdfSignerLinkContentBuilderConfiguration()
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
PdfSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Constructor (IPdfSignerConfiguration)

Constructor for pre-configuration from another configuration.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public PdfSignerLinkContentBuilderConfiguration(
    IPdfSignerConfiguration configuration
)

Parameters

configuration
Type: IPdfSignerConfiguration
Configuration that will be copied to current instance
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
PdfSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Constructor (String)

Constructor for pre-configuration from configuration file.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public PdfSignerLinkContentBuilderConfiguration(
    string configurationName
)

Parameters

configurationName
Type: SystemString
Configuration name from collections of elements in ASDSoft.SignTools/documentSigner.
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
PdfSignerLinkContentBuilderConfiguration Overload
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration Properties

The PdfSignerLinkContentBuilderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AdesLevel | PAdES/XAdES/CAdES level for signature. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Public property | CanRepairPdf | If PDF has not yet been signed, then can allow edit PDF for signature compliance if need.
Public property | SignatureAppearance | Definition for visual signature.
Public property | SignatureBufferKbSize | Size of basic buffer in PDF for signature content without size for TSA and OCSP. Default is 8 kB.
Public property | SignatureHashAlgorithm | Hash algorithm for compute digest of document. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Public property | SignatureInfo | Basic information for new signature.
Public property | TSAName | The configured TSA name used for the signature timestamp. If not specified, then timestamp will not be inserted. (Inherited from DocumentSignerLinkContentBuilderConfiguration.)
Top
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration.CanRepairPdf Property

PdfSignerLinkContentBuilderConfigurationCanRepairPdf Property

If PDF has not yet been signed, then can allow edit PDF for signature compliance if need.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public bool? CanRepairPdf { get; set; }

Property Value

Type: Nullable Boolean
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration.SignatureAppearance Property

PdfSignerLinkContentBuilderConfigurationSignatureAppearance Property

Definition for visual signature.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public ISignatureAppearanceConfiguration SignatureAppearance { get; set; }

Property Value

Type: ISignatureAppearanceConfiguration
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration.SignatureBufferKbSize Property

PdfSignerLinkContentBuilderConfigurationSignatureBufferKbSize Property

Size of basic buffer in PDF for signature content without size for TSA and OCSP. Default is 8 kB.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public int? SignatureBufferKbSize { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


PdfSignerLinkContentBuilderConfiguration.SignatureInfo Property

PdfSignerLinkContentBuilderConfigurationSignatureInfo Property

Basic information for new signature.

Namespace: ASDSoft.WebSigner.Server.Content
Assembly: ASDSoft.WebSigner.Server.SignTools.Pdf (in ASDSoft.WebSigner.Server.SignTools.Pdf.dll) Version: 2.5.0
Syntax
C#
Copy
public SignatureInfoData SignatureInfo { get; }

Property Value

Type: SignatureInfoData
See Also

Reference

PdfSignerLinkContentBuilderConfiguration Class
ASDSoft.WebSigner.Server.Content Namespace


ASDSoft.WebSigner.Server.Content.Converters Namespace

Converters for create content instances from text representation.
Classes
 | Class | Description
Public class | ContentConverterProvider | Provider for register and getting IContentConverter.
Public class | ContentConverterProviderExtensions | Extend ContentConverterProvider for register content providers for ASDSoft.SignTools document signers (PDF, XML, DOCX, ...)
Interfaces
 | Interface | Description
Public interface | IContentConverter | Interface for implementation of conversion string to typed content.


ContentConverterProvider Class

Provider for register and getting IContentConverter.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.Content.ConvertersContentConverterProvider

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public sealed class ContentConverterProvider

The ContentConverterProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetConverter | Return registered singleton instance of content converter.
Public method | GetRegisteredConverters | Return collection of names for all registered content converters.
Public method | RegisterConverter | Register new content converter.
Top
Fields
Name | Description
Instance | Singleton instance of content provider. Only for .NET Framework.
Top
Extension Methods
 | Name | Description
Public Extension Method | RegisterDocumentSignerContentConverters | Register content converters for all supported signing documents from ASDSoft.SignTools. (Defined by ContentConverterProviderExtensions.)
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider Methods

The ContentConverterProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetConverter | Return registered singleton instance of content converter.
Public method | GetRegisteredConverters | Return collection of names for all registered content converters.
Public method | RegisterConverter | Register new content converter.
Top
Extension Methods
 | Name | Description
Public Extension Method | RegisterDocumentSignerContentConverters | Register content converters for all supported signing documents from ASDSoft.SignTools. (Defined by ContentConverterProviderExtensions.)
Top
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider.GetConverter Method

ContentConverterProviderGetConverter Method

Return registered singleton instance of content converter.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IContentConverter GetConverter(
    string name
)

Parameters

name
Type: SystemString
Name of registered content converter (Text, HashBase64, BinaryDataBase64, DelayHash, DelayData)

Return Value

Type: IContentConverter
Singleton instance for specified name
Exceptions
Exception | Condition
KeyNotFoundException | The property is retrieved and key does not exist in the collection.
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider.GetRegisteredConverters Method

ContentConverterProviderGetRegisteredConverters Method

Return collection of names for all registered content converters.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public IEnumerable<string> GetRegisteredConverters()

Return Value

Type: IEnumerable String
Name of registerd content converter.
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider.RegisterConverter Method

ContentConverterProviderRegisterConverter Method

Register new content converter.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public void RegisterConverter(
    string name,
    IContentConverter converter
)

Parameters

name
Type: SystemString
Name of registered content converter
converter
Type: ASDSoft.WebSigner.Server.Content.ConvertersIContentConverter
Instance of content converter
Exceptions
Exception | Condition
ArgumentException | An element with the same key already exists in the Dictionary.
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider Fields

The ContentConverterProvider type exposes the following members.

Fields
Name | Description
Instance | Singleton instance of content provider. Only for .NET Framework.
Top
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProvider.Instance Field

ContentConverterProviderInstance Field

Singleton instance of content provider. Only for .NET Framework.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static readonly ContentConverterProvider Instance

Field Value

Type: ContentConverterProvider
See Also

Reference

ContentConverterProvider Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProviderExtensions Class

Extend ContentConverterProvider for register content providers for ASDSoft.SignTools document signers (PDF, XML, DOCX, ...)
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.Content.ConvertersContentConverterProviderExtensions

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class ContentConverterProviderExtensions

The ContentConverterProviderExtensions type exposes the following members.

Methods
Name | Description
RegisterDocumentSignerContentConverters | Register content converters for all supported signing documents from ASDSoft.SignTools.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProviderExtensions Methods

The ContentConverterProviderExtensions type exposes the following members.

Methods
Name | Description
RegisterDocumentSignerContentConverters | Register content converters for all supported signing documents from ASDSoft.SignTools.
Top
See Also

Reference

ContentConverterProviderExtensions Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


ContentConverterProviderExtensions.RegisterDocumentSignerContentConverters Method

ContentConverterProviderExtensionsRegisterDocumentSignerContentConverters Method

Register content converters for all supported signing documents from ASDSoft.SignTools.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static void RegisterDocumentSignerContentConverters(
    this ContentConverterProvider contentConverterProvider
)

Parameters

contentConverterProvider
Type: ASDSoft.WebSigner.Server.Content.ConvertersContentConverterProvider
Extended provider instance

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ContentConverterProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ContentConverterProviderExtensions Class
ASDSoft.WebSigner.Server.Content.Converters Namespace


IContentConverter Interface

Interface for implementation of conversion string to typed content.

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IContentConverter

The IContentConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertFromText | Convert text to instance of specific implementation base class ContentBase
Top
See Also

Reference

ASDSoft.WebSigner.Server.Content.Converters Namespace


IContentConverter Methods

The IContentConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertFromText | Convert text to instance of specific implementation base class ContentBase
Top
See Also

Reference

IContentConverter Interface
ASDSoft.WebSigner.Server.Content.Converters Namespace


IContentConverter.ConvertFromText Method

IContentConverterConvertFromText Method

Convert text to instance of specific implementation base class ContentBase

Namespace: ASDSoft.WebSigner.Server.Content.Converters
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
ContentBase ConvertFromText(
    string contentTitle,
    string contentText,
    Object applicationContentId
)

Parameters

contentTitle
Type: SystemString
Content title for display in client window for selecting a certificate
contentText
Type: SystemString
Content in text representation.
applicationContentId
Type: SystemObject
Unique application ID of content.

Return Value

Type: ContentBase
Instance of specific content converter.
See Also

Reference

IContentConverter Interface
ASDSoft.WebSigner.Server.Content.Converters Namespace


ASDSoft.WebSigner.Server.Context Namespace

Interfaces and implementations for managing information from HttpContext.
Classes
 | Class | Description
Public class | NothingAuthenticationPersistor | Do not persist and restore user identity for situation, when application not need it.
Interfaces
 | Interface | Description
Public interface | IAuthenticationPersistor | Interface for persist user identification in SignatureSession and restore it. If not specified custom implementation during startup, use default implementation.


IAuthenticationPersistor Interface

Interface for persist user identification in SignatureSession and restore it. If not specified custom implementation during startup, use default implementation.

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public interface IAuthenticationPersistor

The IAuthenticationPersistor type exposes the following members.

Methods
 | Name | Description
Public method | GetCurrentUserIdentification | Get identification of current user for store in SignatureSession.
Public method | RestoreUser | Restore User from serialized user identification for client application requests.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Context Namespace


IAuthenticationPersistor Methods

The IAuthenticationPersistor type exposes the following members.

Methods
 | Name | Description
Public method | GetCurrentUserIdentification | Get identification of current user for store in SignatureSession.
Public method | RestoreUser | Restore User from serialized user identification for client application requests.
Top
See Also

Reference

IAuthenticationPersistor Interface
ASDSoft.WebSigner.Server.Context Namespace


IAuthenticationPersistor.GetCurrentUserIdentification Method

IAuthenticationPersistorGetCurrentUserIdentification Method

Get identification of current user for store in SignatureSession.

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
string GetCurrentUserIdentification()

Return Value

Type: String
User identification (for example from current HttpContext).
Remarks
Default implementation return Name from User. Called by infrastructure during creating new SignatureSession.
See Also

Reference

IAuthenticationPersistor Interface
ASDSoft.WebSigner.Server.Context Namespace


IAuthenticationPersistor.RestoreUser Method

IAuthenticationPersistorRestoreUser Method

Restore User from serialized user identification for client application requests.

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
void RestoreUser(
    string userIdentification
)

Parameters

userIdentification
Type: SystemString
Serialized user identification stored on creation signature session by GetCurrentUserIdentification.
Remarks
Default implementation set new instance of GenericPrincipal with Name retrieved by GetCurrentUserIdentification. Called by infrastructure before calling:
ProcessSigning(X509Certificate2, SignatureInfo)
GetContent(ContentBase, X509Certificate2)
GetDocument(IDocumentLinkContent)
ConfigureX509ChainForValidation(X509Chain, X509Certificate2, SignatureRequest)
ValidateQualifiedCertificate(X509Certificate2, EuTslStatusInfo, SignatureRequest, String)
ValidateCertificateExtended(X509Certificate2, SignatureRequest, String).
See Also

Reference

IAuthenticationPersistor Interface
ASDSoft.WebSigner.Server.Context Namespace


NothingAuthenticationPersistor Class

Do not persist and restore user identity for situation, when application not need it.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.ContextNothingAuthenticationPersistor

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public sealed class NothingAuthenticationPersistor : IAuthenticationPersistor

The NothingAuthenticationPersistor type exposes the following members.

Constructors
 | Name | Description
Public method | NothingAuthenticationPersistor | Initializes a new instance of the NothingAuthenticationPersistor class
Top
Methods
 | Name | Description
Public method | GetCurrentUserIdentification | Always return Empty
Public method | RestoreUser | Do nothing.
Top
See Also

Reference

ASDSoft.WebSigner.Server.Context Namespace


NothingAuthenticationPersistor Constructor

Initializes a new instance of the NothingAuthenticationPersistor class

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public NothingAuthenticationPersistor()
See Also

Reference

NothingAuthenticationPersistor Class
ASDSoft.WebSigner.Server.Context Namespace


NothingAuthenticationPersistor Methods

The NothingAuthenticationPersistor type exposes the following members.

Methods
 | Name | Description
Public method | GetCurrentUserIdentification | Always return Empty
Public method | RestoreUser | Do nothing.
Top
See Also

Reference

NothingAuthenticationPersistor Class
ASDSoft.WebSigner.Server.Context Namespace


NothingAuthenticationPersistor.GetCurrentUserIdentification Method

NothingAuthenticationPersistorGetCurrentUserIdentification Method

Always return Empty

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public string GetCurrentUserIdentification()

Return Value

Type: String
Empty

Implements

IAuthenticationPersistorGetCurrentUserIdentification
See Also

Reference

NothingAuthenticationPersistor Class
ASDSoft.WebSigner.Server.Context Namespace


NothingAuthenticationPersistor.RestoreUser Method

NothingAuthenticationPersistorRestoreUser Method

Do nothing.

Namespace: ASDSoft.WebSigner.Server.Context
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public void RestoreUser(
    string userIdentification
)

Parameters

userIdentification
Type: SystemString
Not used.

Implements

IAuthenticationPersistorRestoreUser(String)
See Also

Reference

NothingAuthenticationPersistor Class
ASDSoft.WebSigner.Server.Context Namespace


ASDSoft.WebSigner.Server.Logging Namespace

Logging signature process to trace.
Classes
 | Class | Description
Public class | Logger | Logging activity of signing process.


Logger Class

Logging activity of signing process.
Inheritance Hierarchy
SystemObject
ASDSoft.WebSigner.Server.LoggingLogger

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract class Logger

The Logger type exposes the following members.

Constructors
 | Name | Description
Protected method | Logger | Initializes a new instance of the Logger class
Top
Properties
Name | Description
Instance | The main entry point to logger instance.
Top
Methods
 | Name | Description
Public method | AddHtmlListener | Add writable Stream for write trace information in HTML formatting.
Public method | RemoveHtmlListener | Remove stream added by method AddHtmlListener(Stream) for ending write trace information to this stream.
Protected method | WriteDebug | Log message with level Debug/Verbose
Protected method | WriteError | Log message with level Error
Protected method | WriteWarning | Log message with level Warning
Top
Fields
Name | Description
SOURCE_NAME |
Top
Remarks
For logging is used standard configurable .NET trace mechanism with name ASDSoft.WebSigner.Server.
See Also

Reference

ASDSoft.WebSigner.Server.Logging Namespace


Logger Constructor

Initializes a new instance of the Logger class

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected Logger()
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger Properties

The Logger type exposes the following members.

Properties
Name | Description
Instance | The main entry point to logger instance.
Top
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.Instance Property

LoggerInstance Property

The main entry point to logger instance.

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static Logger Instance { get; }

Property Value

Type: Logger
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | AddHtmlListener | Add writable Stream for write trace information in HTML formatting.
Public method | RemoveHtmlListener | Remove stream added by method AddHtmlListener(Stream) for ending write trace information to this stream.
Protected method | WriteDebug | Log message with level Debug/Verbose
Protected method | WriteError | Log message with level Error
Protected method | WriteWarning | Log message with level Warning
Top
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.AddHtmlListener Method

LoggerAddHtmlListener Method

Add writable Stream for write trace information in HTML formatting.

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract void AddHtmlListener(
    Stream targetStream
)

Parameters

targetStream
Type: System.IOStream
Writable stream for write trace information in HTML formatting.
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.RemoveHtmlListener Method

LoggerRemoveHtmlListener Method

Remove stream added by method AddHtmlListener(Stream) for ending write trace information to this stream.

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public abstract void RemoveHtmlListener(
    Stream targetStream
)

Parameters

targetStream
Type: System.IOStream
Stream added by method AddHtmlListener(Stream).
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.WriteDebug Method

LoggerWriteDebug Method

Log message with level Debug/Verbose

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void WriteDebug(
    string message
)

Parameters

message
Type: SystemString
Message
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.WriteError Method

LoggerWriteError Method

Log message with level Error

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void WriteError(
    string message
)

Parameters

message
Type: SystemString
Message
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.WriteWarning Method

LoggerWriteWarning Method

Log message with level Warning

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected abstract void WriteWarning(
    string message
)

Parameters

message
Type: SystemString
Message
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger Fields

The Logger type exposes the following members.

Fields
Name | Description
SOURCE_NAME |
Top
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Logger.SOURCE_NAME Field

LoggerSOURCE_NAME Field

[Missing <summary> documentation for "F:ASDSoft.WebSigner.Server.Logging.Logger.SOURCE_NAME"]

Namespace: ASDSoft.WebSigner.Server.Logging
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
protected const string SOURCE_NAME = "ASDSoft.WebSigner.Server"

Field Value

Type: String
See Also

Reference

Logger Class
ASDSoft.WebSigner.Server.Logging Namespace


Microsoft.AspNetCore.Builder Namespace

System namespace from .NET Core services configuration.
Classes
 | Class | Description
Public class | AsdWebSignerExtensions | Extension methods for the ASDWebSigner Middleware


AsdWebSignerExtensions Class

Extension methods for the ASDWebSigner Middleware
Inheritance Hierarchy
SystemObject
Microsoft.AspNetCore.BuilderAsdWebSignerExtensions

Namespace: Microsoft.AspNetCore.Builder
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class AsdWebSignerExtensions

The AsdWebSignerExtensions type exposes the following members.

Methods
Name | Description
UseAsdWebSigner | Enables and configure ASDWebSigner Middleware
Top
See Also

Reference

Microsoft.AspNetCore.Builder Namespace


AsdWebSignerExtensions Methods

The AsdWebSignerExtensions type exposes the following members.

Methods
Name | Description
UseAsdWebSigner | Enables and configure ASDWebSigner Middleware
Top
See Also

Reference

AsdWebSignerExtensions Class
Microsoft.AspNetCore.Builder Namespace


AsdWebSignerExtensions.UseAsdWebSigner Method

AsdWebSignerExtensionsUseAsdWebSigner Method

Enables and configure ASDWebSigner Middleware

Namespace: Microsoft.AspNetCore.Builder
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IApplicationBuilder UseAsdWebSigner(
    this IApplicationBuilder app,
    StartupSettings startupSettings
)

Parameters

app
Type: IApplicationBuilder
Implemenation of the IApplicationBuilder
startupSettings
Type: ASDSoft.WebSigner.Server.AspNetCoreStartupSettings
Settings for configuration ASDWebSigner

Return Value

Type: IApplicationBuilder
Implemenation of the IApplicationBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerExtensions Class
Microsoft.AspNetCore.Builder Namespace


Microsoft.Extensions.DependencyInjection Namespace

System namespace for .NET Core services startup.
Classes
 | Class | Description
Public class | AsdWebSignerServiceCollectionExtensions | Extension methods for setting up ASDWebSigner services


AsdWebSignerServiceCollectionExtensions Class

Extension methods for setting up ASDWebSigner services
Inheritance Hierarchy
SystemObject
Microsoft.Extensions.DependencyInjectionAsdWebSignerServiceCollectionExtensions

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static class AsdWebSignerServiceCollectionExtensions

The AsdWebSignerServiceCollectionExtensions type exposes the following members.

Methods
Name | Description
AddAsdWebSignerTSigner | Adds ASDWebSigner services to the specified IServiceCollection.
AddAsdWebSignerApi(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, FuncIServiceProvider, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerWithSignToolsTSigner | Adds ASDWebSigner services with SignTools extensions to the specified IServiceCollection.
Top
See Also

Reference

Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions Methods

The AsdWebSignerServiceCollectionExtensions type exposes the following members.

Methods
Name | Description
AddAsdWebSignerTSigner | Adds ASDWebSigner services to the specified IServiceCollection.
AddAsdWebSignerApi(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, FuncIServiceProvider, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerWithSignToolsTSigner | Adds ASDWebSigner services with SignTools extensions to the specified IServiceCollection.
Top
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSigner(TSigner) Method

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerTSigner Method

Adds ASDWebSigner services to the specified IServiceCollection.

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSigner<TSigner>(
    this IMvcBuilder mvcBuilder,
    Action<IServiceProvider, ContentConverterProvider> setupAction = null
)
where TSigner : SignerBase

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.
setupAction (Optional)
Type: SystemAction IServiceProvider, ContentConverterProvider
Action for configure ContentConverterProvider

Type Parameters

TSigner
Type of Host application implementation of SignerBase for callback functions.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerApi Method

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerApi Method

Overload List
Name | Description
AddAsdWebSignerApi(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
AddAsdWebSignerApiTSignResultPersistor(IMvcBuilder, FuncIServiceProvider, TSignResultPersistor) | Adds ASDWebSigner REST API Interface
Top
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerApi Method (IMvcBuilder)

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerApi Method (IMvcBuilder)

Adds ASDWebSigner REST API Interface

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSignerApi(
    this IMvcBuilder mvcBuilder
)

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
AddAsdWebSignerApi Overload
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerApi(TSignResultPersistor) Method (IMvcBuilder)

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerApiTSignResultPersistor Method (IMvcBuilder)

Adds ASDWebSigner REST API Interface

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSignerApi<TSignResultPersistor>(
    this IMvcBuilder mvcBuilder
)
where TSignResultPersistor : class, ISignResultPersistor

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.

Type Parameters

TSignResultPersistor
Custom type of persistor for persist result for REST API calling.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
AddAsdWebSignerApi Overload
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerApi(TSignResultPersistor) Method (IMvcBuilder, TSignResultPersistor)

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerApiTSignResultPersistor Method (IMvcBuilder, TSignResultPersistor)

Adds ASDWebSigner REST API Interface

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSignerApi<TSignResultPersistor>(
    this IMvcBuilder mvcBuilder,
    TSignResultPersistor implementationInstance
)
where TSignResultPersistor : class, ISignResultPersistor

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.
implementationInstance
Type: TSignResultPersistor
Instance of persistor for persist result for REST API calling.

Type Parameters

TSignResultPersistor
Custom type of persistor for persist result for REST API calling.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
AddAsdWebSignerApi Overload
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerApi(TSignResultPersistor) Method (IMvcBuilder, Func(IServiceProvider, TSignResultPersistor))

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerApiTSignResultPersistor Method (IMvcBuilder, FuncIServiceProvider, TSignResultPersistor)

Adds ASDWebSigner REST API Interface

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSignerApi<TSignResultPersistor>(
    this IMvcBuilder mvcBuilder,
    Func<IServiceProvider, TSignResultPersistor> implementationFactory
)
where TSignResultPersistor : class, ISignResultPersistor

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.
implementationFactory
Type: SystemFunc IServiceProvider, TSignResultPersistor
Factory method for create persistor instance for persist result for REST API calling.

Type Parameters

TSignResultPersistor
Custom type of persistor for persist result for REST API calling.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
AddAsdWebSignerApi Overload
Microsoft.Extensions.DependencyInjection Namespace


AsdWebSignerServiceCollectionExtensions.AddAsdWebSignerWithSignTools(TSigner) Method

AsdWebSignerServiceCollectionExtensionsAddAsdWebSignerWithSignToolsTSigner Method

Adds ASDWebSigner services with SignTools extensions to the specified IServiceCollection.

Namespace: Microsoft.Extensions.DependencyInjection
Assembly: ASDSoft.WebSigner.Server (in ASDSoft.WebSigner.Server.dll) Version: 2.5.0
Syntax
C#
Copy
public static IMvcBuilder AddAsdWebSignerWithSignTools<TSigner>(
    this IMvcBuilder mvcBuilder
)
where TSigner : SignerBase

Parameters

mvcBuilder
Type: IMvcBuilder
An IMvcBuilder that can be used to further configure the ASDWebSigner services.

Type Parameters

TSigner
Type of Host application implementation of SignerBase for callback functions.

Return Value

Type: IMvcBuilder
Implemenation of the IMvcBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMvcBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsdWebSignerServiceCollectionExtensions Class
Microsoft.Extensions.DependencyInjection Namespace